<!DOCTYPE html>
<html lang="en"><head><meta charset="utf-8" />

<!--	Lottery Post® (https://www.lotterypost.com)
	Author: Todd Northrop
	E-mail: webmaster (at) lotterypost (dot) com
	Copyright © 1999-2020. All Rights Reserved.
	Reproduction in whole or in part in any form or medium without express written permission of the Author is prohibited. See https://www.lotterypost.com/copyright
	Lottery Post and the Lottery Post logo are registered trademarks of Speednet Group, and may not be used without express written permission.
- - - - - - - - - - - - - - - - - - - - - - - - - - - -->

<title>Malfunction delays Saturday's Powerball lottery drawing | Lottery Post</title><meta name="application-name" content="Lottery Post" /><meta name="format-detection" content="telephone=no" /><meta name="msapplication-starturl" content="/" /><meta name="theme-color" content="#bcceff" /><meta name="viewport" content="width=968" /><meta name="title" content="Malfunction delays Saturday's Powerball lottery drawing" /><meta name="keywords" content="lottery,news,Powerball,Jackpots,Error,Multi-State Game,Drawing" /><meta name="description" content="People hoping to win the Powerball jackpot Saturday night had to wait a little longer to see the numbers." /><meta property="og:title" content="Malfunction delays Saturday's Powerball lottery drawing | Lottery Post" /><meta property="og:type" content="article" /><meta property="og:url" content="https://www.lotterypost.com/news/331226" /><meta property="og:description" content="People hoping to win the Powerball jackpot Saturday night had to wait a little longer to see the numbers." /><meta property="og:image" content="https://lp.vg/images/newsicon_powerball.jpg" /><meta property="og:image:width" content="280" /><meta property="og:image:height" content="200" /><meta property="og:image:alt" content="Powerball" /><meta property="og:site_name" content="Lottery Post" /><meta property="article:published_time" content="2020-03-08T11:55:25-04:00" /><meta property="article:tag" content="Lottery" /><meta property="article:tag" content="Powerball" /><meta property="article:tag" content="Jackpots" /><meta property="article:tag" content="Error" /><meta property="article:tag" content="Multi-State Game" /><meta property="article:tag" content="Drawing" /><meta name="twitter:card" content="summary" /><meta name="twitter:title" content="Malfunction delays Saturday's Powerball lottery drawing | Lottery Post" /><meta name="twitter:url" content="https://www.lotterypost.com/news/331226" /><meta name="twitter:description" content="People hoping to win the Powerball jackpot Saturday night had to wait a little longer to see the numbers." /><meta name="twitter:site" content="@LotteryPost" /><meta name="twitter:image" content="https://lp.vg/images/newsicon_powerball.jpg" /><link rel="canonical" href="https://www.lotterypost.com/news/331226" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:400,700" /><link rel="manifest" href="/manifest.webmanifest" /><link rel="shortcut icon" href="/images/theme/icon-lponly-48.ico" type="image/vnd.microsoft.icon" sizes="16x16 32x32 48x48" /><link rel="icon" href="/images/theme/icon-lp-192.png" type="image/png" sizes="192x192" /><link rel="apple-touch-icon" href="/images/theme/icon-lp-180.png" sizes="180x180" /><link rel="mask-icon" href="/images/svg/lp-mask.svg" color="#aa6500" /><link rel="search" href="/xml/SearchProviderForums.xml" type="application/opensearchdescription+xml" title="Lottery Post Search" /><link rel="preload" href="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js" as="script" /><link rel="alternate" href="https://www.lotterypost.com/rss/news/331226" type="application/rss+xml" title="Subscribe to &quot;Malfunction delays Saturday's Powerball lottery drawing&quot;" /><link rel="alternate" href="https://m.lotterypost.com/news/331226" media="only screen and (max-width: 640px)" /><script async src="https://www.googletagservices.com/tag/js/gpt.js"></script><script async src="https://c.amazon-adsystem.com/aax2/apstag.js"></script><script async src="https://lp.vg/js/f1/pb2.44.1.js"></script><script>var googletag=googletag||{};googletag.cmd=googletag.cmd||[];!function(g){g.cmd.push(function(){g.defineSlot('/13070090/LP_728x90',[728,90],'AUHead').addService(g.pubads());g.defineSlot('/13070090/LP_120x600',[120,600],'MasterAuLeft').addService(g.pubads());g.defineSlot('/13070090/LP_300x250_Primary',[300,250],'LP_ctl05').addService(g.pubads());g.defineSlot('/13070090/LP_300x250_Secondary',[300,250],'LP_ctl07').addService(g.pubads());g.defineSlot('/13070090/LP_468x60_Text',[468,60],'LP_FooterBannerAd').addService(g.pubads());g.defineSlot('/13070090/LP_300x250_Primary',[300,250],'LP_FooterBlockAd').addService(g.pubads());try{var i,e=document.getElementsByTagName('link'),l=e.length;for(i=0;i<l;i++){if(e[i].rel==='canonical'){g.pubads().set('page_url',e[i].href);i=l}}}catch(r){}g.pubads().setTargeting('Device','Computer');g.pubads().setTargeting('Content','Restrict');g.pubads().setTargeting('Category','News');g.pubads().disableInitialLoad();g.pubads().enableSingleRequest();g.pubads().collapseEmptyDivs();g.pubads().enableLazyLoad({fetchMarginPercent:500,renderMarginPercent:200,mobileScaling:2.0});g.enableServices()})}(googletag);var pbBds=function(n,t,i,r,u,f,e){var o={code:n,mediaTypes:{banner:{sizes:t}},bids:[]},s;if(i&&o.bids.push({bidder:"appnexus",params:{placementId:i,reserve:.01}}),r)for(s=0;s<t.length;s++)o.bids.push({bidder:"ix",params:{siteId:r,size:t[s]}});return u&&o.bids.push({bidder:"pubmatic",params:{publisherId:"157856",adSlot:u,kadfloor:.01}}),f&&o.bids.push({bidder:"sortable",params:{tagId:f,floor:.01}}),e&&o.bids.push({bidder:"sovrn",params:{tagid:e,bidfloor:.01}}),o},pbjs=pbjs||{};pbjs.que=pbjs.que||[];pbjs.que.push(function(){pbjs.setConfig({bidderTimeout:900,priceGranularity:{buckets:[{min:0,max:3,increment:.01},{min:3,max:8,increment:.05},{min:8,max:10,increment:.1},{min:10,max:20,increment:.5},{min:20,max:30,increment:1}]},sortable:{siteId:'lotterypost.com'},userSync:{filterSettings:{iframe:{bidders:'*',filter:'include'}},syncDelay:6000,syncsPerBidder:3}})});var pbSlots=[pbBds('AUHead',[[728,90]],'14442905','341167','LP_728x90','AUHead','594224'),pbBds('MasterAuLeft',[[120,600]],'14442905','341162','LP_120x600','MasterAuLeft','594228'),pbBds('LP_ctl05',[[300,250]],'14442905','341164','LP_300x250_Primary','LP_ctl05','594225'),pbBds('LP_ctl07',[[300,250]],'14442905','341164','LP_300x250_Secondary','LP_ctl07','594225'),pbBds('LP_FooterBlockAd',[[300,250]],'14442905','341164','LP_300x250_Primary','LP_FooterBlockAd','594225')];var apstag=apstag||{q:function(n,t){apstag._Q.push([n,t])},init:function(){apstag.q('i',arguments)},fetchBids:function(){apstag.q('f',arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};apstag.init({pubID:'c6915d94-7b34-4363-b9a6-c45dfdb5e581',adServer:'googletag',bidTimeout:900});var a9Slots=[{slotID:'AUHead',slotName:'/13070090/LP_728x90',sizes:[[728,90]]},{slotID:'MasterAuLeft',slotName:'/13070090/LP_120x600',sizes:[[120,600]]},{slotID:'LP_ctl05',slotName:'/13070090/LP_300x250_Primary',sizes:[[300,250]]},{slotID:'LP_ctl07',slotName:'/13070090/LP_300x250_Secondary',sizes:[[300,250]]},{slotID:'LP_FooterBlockAd',slotName:'/13070090/LP_300x250_Primary',sizes:[[300,250]]}];!function(n,t){function e(){for(var n in i)if(i[n])return!1;return!0}function u(n){r||(i[n]=!1,e()&&f())}function f(){r||window.aNotOK||(r=!0,googletag.cmd.push(function(){try{n&&apstag.setDisplayBids()}catch(i){}try{t&&pbjs.setTargetingForGPTAsync()}catch(i){}googletag.pubads().refresh()}))}function o(){t&&pbjs.que.push(function(){pbjs.addAdUnits(pbSlots);pbjs.requestBids({bidsBackHandler:function(){u("prebid")}})});n&&apstag.fetchBids({slots:a9Slots},function(){u("a9")})}var i={a9:n,prebid:t},r=!1;t||n?(o(),window.setTimeout(f,1500)):googletag.pubads().refresh()}(!0,!0);</script><script type="application/ld+json">{"@context":"https://schema.org/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.lotterypost.com/news/331226"},"description":"People hoping to win the Powerball jackpot Saturday night had to wait a little longer to see the numbers.","commentCount":"7","datePublished":"2020-03-08T11:55:25-04:00","dateModified":"2020-03-08T11:55:25-04:00","headline":"Malfunction delays Saturday's Powerball lottery drawing","keywords":"lottery,Powerball,Jackpots,Error,Multi-State Game,Drawing","image":["https://lp.vg/images/newsicon_powerball.jpg"],"thumbnailUrl":"https://lp.vg/images/newsicon_powerball.jpg","dateline":"","author":{"@type":"Organization","name":"Lottery Post Staff"},"publisher":{"@type":"Organization","name":"Lottery Post","logo":{"@type":"ImageObject","url":"https://www.lotterypost.com/images/lp_icon_310.png"}}}</script><script>var _mNHandle=_mNHandle||{},medianet_versionId='3121199';_mNHandle.queue=_mNHandle.queue||[];</script><script async src="https://contextual.media.net/dmedianet.js?cid=8CU2OF2D5"></script><link rel="preload" href="https://lp.vg/js/ds00211.0/MwtGFZn69uAwUEBU1xQNAHR7FoSyGDVA6BzbcVg6aEZjnjKKk9Rrt8egtyaKSMzNkICrg4d5Ke3NoOtwS(DCOHQzmBP4wqL5veCYtyspv2G4oJ(GmxykoLR3upAk3jTVdPDBW3)eWVULWUdXqyPlPo5XO3Sw59KQ9KsazSqMcavoZum1EbsJt4aEoh8LduaYVHw1t4noRQqJbz0RYqRmuHkkUQy7qdpzIpr8K17s5RmjTbzMB8D)AW2)WxOiEiAyAev7/fT63e2l0(w57RziKWEWnZGXkx5o8VFdgMeuNDiNOb4)qsO4TyeuA21e4qbbDRZM(F2qtwXDiGHa9WmnFwMn6kGfgjLRINM4OOo3Ikjjz72wB6X3viQJ20GY56CC9Fn9LotbSuJY1gomZVvnl1J00jurMNYQV)RwODW4Kun2Ql7qMUAzUAa06AGgKY0EBuIVY2V5NiHZPTFaaFK1xP8DXFH6FCyE5bSZ60H)CF5I=" as="script" /><script>var LPPreInit={version:"00211.0",status:0};</script><link rel="stylesheet" href="https://lp.vg/css/ds00211.0/j2HKnp0oKDOVoos8SA3Bpy3UHd7cAufta4eroYaXMYvxFuRA8ykjub9LnljwiyZ(Ho5EV7u8sDx6g)gMvHadnHlvbESIYJ1X6oeAghqHEshdvvI473HCzerwIb2juyuPKT8OTLHfuZgKateNm4TWxrNbcJF76)WXsXrqF2gAZSoyrDeFDbyj)cFCwis69h3CboX1do29vAaXKGVNqtsflqVx01a7xcrL8RpkHHFsqZwRNwD5laTCXGja1s1WPvb)I8FZ/NKGS35HhGdM28kV5Z5BArPjXoC7jBHKu(ywMVDdSW31RbPFL7nbavW)JN4lnsVeZ6SHo3qzBtwDmsyvWIIloUgbndTtTYRlwZZBJuGexDcWMA5U9FEsCbk4DBndQKcff6AxqIT4jHSfQ3vP()YshYgvKBPArMotDFLaCbz1v)kJOSJ0utGisWCgaOB)M6SEccP8pUVoCdXt4qJuB19RmMR98Zj0NlODiPkrWKRo=" /><style>html,body,#pagewidth{min-width:968px;}</style><script async src="https://www.googletagmanager.com/gtm.js?id=GTM-D86W"></script><script>var dataLayer=dataLayer||[];dataLayer.push({"gtm.start":+new Date,event:"gtm.js"});</script></head><body data-id="5435871147245"><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-D86W" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><form method="post" action="/news/331226?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+LotteryNews+%28Lottery+Post%3A+Latest+Lottery+News%29" id="MainForm"><div class="aspNetHidden"><input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" /></div><div id="header"><div id="headerContent"><a class="logo" href="/"><img src="https://lp.vg/images/lp_logo.png" srcset="https://lp.vg/images/lp_logo-1.5x.png 1.5x,https://lp.vg/images/lp_logo-2x.png 2x,https://lp.vg/images/lp_logo-3x.png 3x,https://lp.vg/images/lp_logo-4x.png 4x" width="220" height="80" alt="Lottery Post" /></a><div id="AUHead" class="AU AUStandard AUSize728x90" style="width:728px;height:90px"><script>googletag.cmd.push(function(){googletag.display('AUHead')})</script></div></div></div><div id="pagewidth"><div id="loginblock"><div id="bcSearch">&nbsp;</div><strong>Welcome&nbsp;Guest</strong><img src="/b.gif" alt="" /><br /> (&nbsp;<a title="Log in to your Lottery Post membership." href="/login">Log In</a> | <a title="Sign up for a free Lottery Post membership." href="/register">Register</a>&nbsp;) </div><table id="mainframework" border="0" cellspacing="10" cellpadding="0"><tr><td id="mainframeworkleft"><div id="leftnav" class="pod withtitle"><p class="title">Quick Links</p><ul><li><a title="Lottery Post Home Page" href="/">Home</a></li><li class="lnBig"><a class="icon-memberships" title="Compare features between Lottery Post memberships" href="/memberships">Premium Memberships</a></li><li><a title="Go to the main forums page, see description of each forum" href="/forums">Forums</a></li><li><a title="Go to the Predictions main page" href="/predictions">Predictions</a></li><li><a title="View all lottery news stories, one month at a time" href="/news">News</a></li><li><a title="Go to the Lottery Results main page" href="/results">Lottery Results</a></li><li><a title="The world&#39;s most powerful lottery results search engine" href="/results/search">Search Drawings</a></li><li><a title="All the lottery systems and methods available at Lottery Post" href="/systems">Lottery Systems</a></li><li><a title="Lottery charts and data tables for Pick 3, Pick 4, and Quinto" href="/charts">Lottery Charts</a></li><li><a title="The world&#39;s best Full, Key, and Abbreviated lottery wheels, including custom (filtered) wheels" href="/wheels">Lottery Wheels</a></li><li><a title="Sorted listing of current worldwide jackpots" href="/jackpots">Worldwide Jackpots</a></li><li><a title="Generate random numbers (&quot;Quick Picks&quot;) for any lottery game" href="/quickpicks">Quick Picks</a></li><li><a title="View historical events at Lottery Post and around the world that happened on today's date" href="/onthisday">On This Day in History</a></li><li><a title="See the blogs (personal web journals) of all Lottery Post members" href="/blogs">Blogs</a></li><li><a title="Play Lottery Post&#39;s online games" href="/games">Online Games</a></li><li><a title="Contact the Lottery Post staff by e-mail" href="/contact">Contact Us</a></li><li><a title="Support Lottery Post by whitelisting lotterypost.com in your ad blocker" href="/whitelist">Whitelist Lottery Post</a></li><li><a title="View the Lottery Post forum rules" href="/rules">Rules</a></li><li class="lnBig"><a class="icon-books" title="Large selection of lottery books" href="/books">Lottery Book Store</a></li><li class="lnBig"><a class="icon-gift" title="Lottery Post Gift Shop" href="http://www.cafepress.com/lotterypost/">Lottery Post Gift Shop</a></li><li class="lnBig"><a class="icon-facebook" title="Lottery Post Facebook page" href="https://www.facebook.com/LotteryPost">Visit us on Facebook</a></li><li class="lnBig"><a class="icon-twitter" title="Lottery Post Twitter page" href="https://www.twitter.com/lotterypost">Follow us on Twitter</a></li><li class="lnBig"><a class="icon-youtube" title="Lottery Post YouTube page" href="https://www.youtube.com/lotterypost">Subscribe on YouTube</a></li></ul><a title="Mega Millions and Powerball Lottery News and Results" href="https://www.usamega.com/"><img src="https://lp.vg/images/usa-mega-button.png" srcset="https://lp.vg/images/usa-mega-button-1.5x.png 1.5x,https://lp.vg/images/usa-mega-button-2x.png 2x" class="usamega" width="86" height="46" alt="USA Mega" /></a><a class="tile140" title="Lottery Places free app for iPhone, Android, and Windows" href="https://www.lotteryplaces.com/"><img src="https://lp.vg/images/LotteryPlaces_140x375.jpg" srcset="https://lp.vg/images/LotteryPlaces_140x375_1.5x.jpg 1.5x,https://lp.vg/images/LotteryPlaces_140x375_2x.jpg 2x" width="140" height="375" alt="Lottery Places" /></a><div id="MasterAuLeft" class="masterAuLeft AU AUStandard AUSize120x600" style="width:120px;height:600px"><script>googletag.cmd.push(function(){googletag.display('MasterAuLeft')})</script></div><div id="AmazonAu"><div id="amazonAu"><a href="https://amzn.to/2xkCMe0" class="amazonLogo whiteglass" rel="external nofollow noopener"><ins></ins></a><div class="amazonContent"><a href="https://amzn.to/2wFWSCe" title="Lottery Post 2012 Lottery Results Almanac, United States Edition" rel="external noopener"><img src="https://lp.vg/images/amazon/Results2012-US-FrontCover-57x72.jpg" srcset="https://lp.vg/images/amazon/Results2012-US-FrontCover-57x72-1.5x.jpg 1.5x,https://lp.vg/images/amazon/Results2012-US-FrontCover-57x72-2x.jpg 2x" class="amazonBookIcon" width="57" height="72" alt="Lottery Post 2012 Lottery Results Almanac, United States Edition" /></a><a href="https://amzn.to/2wFWSCe" title="Lottery Post 2012 Lottery Results Almanac, United States Edition" rel="external noopener">2012 Lottery Results Almanac, USA Edition</a><br />by Todd Northrop</div><div class="amazonGoStore"><a id="" href="/books" class="CB CB-Box amazonGoStoreButton"><span>More lottery books</span></a></div></div></div><ul class="tinylist"><li><a title="Online JavaScript Compressor, featuring YUI Compressor and Microsoft Ajax Minifier" href="/js-compress.aspx">JavaScript Compressor</a></li><li><a title="Online CSS Compressor" href="/css-compress.aspx">CSS Compressor</a></li><li><a title="MyBrowserInfo.com" onclick="this.target=&#39;_blank&#39;;" rel="noopener" href="https://mybrowserinfo.com/">Browser Information</a></li></ul></div><div id="LastVisitPanel" class="leftnavbox pod"><div class="minortextwrapper">You&nbsp;last&nbsp;visited March&nbsp;8,&nbsp;2020, 4:49&nbsp;pm</div></div><div class="leftnavbox pod"><div class="minortextwrapper"> All times shown are<br />Eastern Time (GMT-5:00) <div class="smallFootNote"><a title="Update your time zone" rel="nofollow" href="/control_account.asp">Update your time zone</a></div></div></div></td><td id="mainframeworkbody"><div id="breadcrumb" class="clr"><div id="bcLike" class="pageShare"><label>Recommend<br />Lottery Post</label><div><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.lotterypost.com%2F" rel="external noopener"><img src="https://lp.vg/images/facebook-share.png" width="60" height="20" alt="Recommend Lottery Post on Facebook"/></a></div></div><script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":{"@type":"Thing","@id":"https://www.lotterypost.com/"}},{"@type":"ListItem","position":2,"name":"Forums","item":{"@type":"Thing","@id":"https://www.lotterypost.com/forums"}},{"@type":"ListItem","position":3,"name":"Lottery News","item":{"@type":"Thing","@id":"https://www.lotterypost.com/forum/11"}},{"@type":"ListItem","position":4,"name":"Malfunction delays Saturday's Powerball lottery drawing","item":{"@type":"Thing","@id":"https://www.lotterypost.com/news/331226"}}]}</script><ol><li><a href="/" title="Lottery Post Home Page">Home</a></li>&nbsp;&rsaquo; <li><a href="/forums" title="Forums">Forums</a></li>&nbsp;&rsaquo; <li><a href="/forum/11" title="Lottery News">Lottery News</a></li>&nbsp;&rsaquo; <li title="Malfunction delays Saturday's Powerball lottery drawing">Malfunction delays Saturday's Powerball lottery drawing</li></ol></div><div id="LP_NewsStory" class="newsstorywrapper"><div class="newsstory"><h1 id="LP_NewsHeadline" class="headline">Malfunction delays Saturday's Powerball lottery drawing</h1><div class="maincol"><div class="newsbyline"><p id="LP_NewsByline" class="publishdate">Mar 8, 2020, 11:55 am</p><p id="LP_NewsComments" class="newscommentslink"><a id="LP_ctl13" href="javascript:;" title="Scroll down to comments" class="CB" data-sprite="say" data-click="$.scrollTo('#newsEnd',{offset:{top:-10}});return false;"><span>7 comments</span></a></p></div><div id="LP_NewsShare" class="pageShare"><label>Recommend This</label><div><a href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fwww.lotterypost.com%2fnews%2f331226" rel="external noopener"><img src="https://lp.vg/images/facebook-share.png" width="60" height="20" alt="Share this news story on Facebook"/></a></div><div><a href="https://twitter.com/share?url=https%3a%2f%2fwww.lotterypost.com%2fnews%2f331226&text=Malfunction+delays+Saturday%27s+Powerball+lottery+drawing&via=LotteryPost" rel="external noopener"><img src="https://lp.vg/images/twitter-tweet.png" width="60" height="20" alt="Tweet this news story on Twitter"/></a></div></div><div id="newsbody"><div id="newsQuickOptions"><img id="LP_NewsIcon" src="/images/newsicon_powerball_331226.jpg" width="140" height="100" class="newsphoto" alt="Powerball" title="Powerball: Malfunction delays Saturday's Powerball lottery drawing" /><small id="LP_NewsIconCaption">Powerball: Malfunction delays Saturday's Powerball lottery drawing</small><ul style="margin: 10px 0 0;padding: 0;list-style-type:none;"><li><a id="LP_NewsEmail" href="/e-mail_topic.asp?tp=331226" title="E-mail this story to a friend" class="CB" data-sprite="mail" data-newwindow="1"><span>E-mail to a friend</span></a></li><li><a id="LP_NewsPrint" href="/print-topic.asp?tp=331226" title="Open a plain version of this news story that is better for printing" class="CB" data-sprite="print" data-newwindow="1"><span>Printer-friendly</span></a></li><li><a id="LP_NewsLink" href="javascript:;" title="Display the permanent link (&quot;permalink&quot;) to this news story" class="CB" data-sprite="link" data-click="return ThreadPage.showPermaLink('https://www.lotterypost.com/news/331226','Malfunction+delays+Saturday%27s+Powerball+lottery+drawing',this);"><span>Link to this story</span></a></li></ul><span class="ratethis">Rating:</span><span id="rating331226"></span></div><div id="LP_NewsContent"><p style="font: bold 16px/32px Arial, Helvetica, FreeSans, sans-serif;"><img src="//lp.vg/images/theme/icon-movie-32.png" border="0" alt="" style="width: 32px; height: 32px; margin: 0 4px; vertical-align: middle;" srcset="//lp.vg/images/theme/icon-movie-48.png 1.5x,//lp.vg/images/theme/icon-movie-64.png 2x,//lp.vg/images/theme/icon-movie-96.png 3x,//lp.vg/images/theme/icon-movie-128.png 4x" />Includes video report</p><p>People hoping to win the Powerball jackpot Saturday night had to wait a little longer to see the numbers.</p><p>When viewers tuned in for the drawing, instead of seeing of bouncing balls the saw an empty lottery machine.</p><p>An announcement was made saying: &quot;because of a technical problem we are unable to bring you the Powerball drawing at this time.&quot;</p><p>Eventually the winning numbers were posted online, and USA Mega contains all the winning number and prize information, including the final official drawing video, on its <a href="https://www.usamega.com/powerball-drawing.asp?d=3/7/2020" rel="external noopener noopener">Powerball Drawing Detail for March&nbsp;7,&nbsp;2020</a> page.</p><p>After the winning numbers were eventually drawn Saturday night, they were 7, 15, 21, 33, and 62, with Powerball number&nbsp;23. The Power Play multiplier was&nbsp;2.</p><p>There were no tickets sold for the drawing that matched all the numbers drawn, making the next jackpot for Wednesday $110&nbsp;million, with a cash value of $88.1&nbsp;million.</p><p style="margin-top: 20px; font: bold 14px Arial, Helvetica, FreeSans, sans-serif;">VIDEO: Watch the report</p><p><script type="application/ld+json"> {"@context":"https://schema.org","@type":"VideoObject","name":"Malfunction delays Saturday's Powerball lottery drawing","description":"People hoping to win the Powerball jackpot Saturday night had to wait a little longer to see the numbers.","thumbnailUrl":"https://img.youtube.com/vi/eSPTlQjor44/hqdefault.jpg","uploadDate":"2020-03-08T11:50:00-05:00","duration":"PT0M26S","embedUrl":"https://youtu.be/eSPTlQjor44"} </script></p><p><img src="https://img.youtube.com/vi/eSPTlQjor44/hqdefault.jpg" border="0" alt="eSPTlQjor44" class="video" width="420" height="236" /></p></div></div><div id="LP_AfterNewsBody" class="clr"></div><div id="LP_RelatedLinks" class="newsbox newslinks"><p style="clear: both;font: bold 16px Arial,Helvetica,sans-serif;">Related Links</p><ul class="newslinklist"><li><ins class="sprite-16 sprite-link-ext-16"></ins><a href="https://www.usamega.com/" title="USA Mega - Home of Powerball and Mega Millions">USA Mega - Home of Powerball and Mega Millions</a></li><li><ins class="sprite-16 sprite-link-ext-16"></ins><a href="https://www.lotterypost.com/partner/4" title="Play Powerball online">Play Powerball online</a></li></ul></div><p id="LP_NewsSource" class="newssource"><ins class="sprite-16 sprite-world-16"></ins>Lottery Post Staff</p><div id="268110983"><script>_mNHandle.queue.push(function(){_mNDetails.loadTag('268110983','750x200','268110983')});</script></div><p id="LP_NewsFoot" class="newsFootOptions"><strong><ins class="sprite-32 sprite-say-32"></ins>We'd love to see your comments here!&nbsp; <a title="Sign up for a free Lottery Post membership." href="/register">Register for a FREE membership</a>&nbsp;&mdash; it takes just a few moments&nbsp;&mdash; and you'll be able to post comments here and on any of our forums. <span></span>If you're already a member, you can <a title="Log in to your Lottery Post membership." href="/login">Log In</a> to post a comment.</strong></p></div><div class="sidebar"><div class="nextprevstory"></div><div id="fontChanger" class="newsbox clr"><div class="choices styles"><label>Style:</label><ul><li><a id="fontStyle0" style="font-family:Arial,Helvetica,sans-serif;" onclick="return NewsPage?NewsPage.setFontStyle(0):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'style','Narrow');}" href="javascript:;"><span>A</span></a></li><li><a id="fontStyle1" style="font-family:Verdana,Geneva,sans-serif;" onclick="return NewsPage?NewsPage.setFontStyle(1):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'style','Normal');}" href="javascript:;"><span>A</span></a></li><li><a id="fontStyle2" style="font-family:Georgia,'Times New Roman',Times,serif;" onclick="return NewsPage?NewsPage.setFontStyle(2):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'style','Newsprint');}" href="javascript:;"><span>A</span></a></li></ul></div><div class="choices sizes" style="position:relative;"><label>Size:</label><ul><li><a id="fontSize0" style="font-size:8px;" onclick="return NewsPage?NewsPage.setFontSize(0):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'size','Small');}" href="javascript:;"><span>A</span></a></li><li><a id="fontSize1" style="font-size:11px;" onclick="return NewsPage?NewsPage.setFontSize(1):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'size','Normal');}" href="javascript:;"><span>A</span></a></li><li><a id="fontSize2" style="font-size:14px;" onclick="return NewsPage?NewsPage.setFontSize(2):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'size','Large');}" href="javascript:;"><span>A</span></a></li></ul></div></div><div id="LP_ctl05" class="newsSideAd AU AUStandard AUSize300x250" style="width:300px;height:250px"><script>googletag.cmd.push(function(){googletag.display('LP_ctl05')})</script></div><div id="LP_RelatedStories" class="sidebox relatedstories"><h1>Related Stories</h1><ul><li><a id="LP_RelatedStoryList_ctl00_0" href="/news/330745" title="Related story: Powerball $396.9 million winning lottery ticket sold in Florida" class="CB" data-sprite="news"><span style="white-space:normal;">Powerball $396.9 million winning lottery ticket sold in Florida <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Jan&nbsp;30,&nbsp;2020</span></span></a></li><li><a id="LP_RelatedStoryList_ctl00_1" href="/news/330180" title="Related story: Winner claims prize for $150 million Powerball lottery ticket sold at CA/NV border" class="CB" data-sprite="news"><span style="white-space:normal;">Winner claims prize for $150 million Powerball lottery ticket sold at CA/NV border <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Dec&nbsp;20,&nbsp;2019</span></span></a></li><li><a id="LP_RelatedStoryList_ctl00_2" href="/news/329477" title="Related story: Northern Michigan father of 7 claims $80M Powerball lottery jackpot" class="CB" data-sprite="news"><span style="white-space:normal;">Northern Michigan father of 7 claims $80M Powerball lottery jackpot <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Oct&nbsp;24,&nbsp;2019</span></span></a></li><li><a id="LP_RelatedStoryList_ctl00_3" href="/news/237456" title="Related story: Wrong ticket wins Georgia woman $25 million" class="CB" data-sprite="news"><span style="white-space:normal;">Wrong ticket wins Georgia woman $25 million <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Oct&nbsp;5,&nbsp;2011</span></span></a></li><li><a id="LP_RelatedStoryList_ctl00_4" href="/news/198706" title="Related story: Powerball lottery jackpot cracks $200M mark" class="CB" data-sprite="news"><span style="white-space:normal;">Powerball lottery jackpot cracks $200M mark <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Aug&nbsp;13,&nbsp;2009</span></span></a></li></ul></div><div id="LP_StoryTags" class="newsbox tags"><h1 class="tags"><ins class="sprite-24 sprite-globe-checklist-24"></ins>Tags for this news story</h1><ul class="tags"><li><a title="Drawing" rel="tag" href="/tag/drawing" style="font-size:15px;">Drawing</a></li>&#32; <li><a title="Error" rel="tag" href="/tag/error" style="font-size:15px;">Error</a></li>&#32; <li><a title="Jackpots" rel="tag" href="/tag/jackpots" style="font-size:22px;">Jackpots</a></li>&#32; <li><a title="Multi-State Game" rel="tag" href="/tag/multi-state_game" style="font-size:19px;">Multi-State Game</a></li>&#32; <li><a title="Powerball" rel="tag" href="/tag/powerball" style="font-size:19px;">Powerball</a></li>&#32; </ul><h2>Other Popular Tags</h2><ul class="tags clr"><li><a title="Administration" href="/tag/administration" style="font-size:13px;">Administration</a></li>&#32; <li><a title="Crime" href="/tag/crime" style="font-size:13px;">Crime</a></li>&#32; <li><a title="Financials" href="/tag/financials" style="font-size:14px;">Financials</a></li>&#32; <li><a title="Insider Buzz" href="/tag/insider_buzz" style="font-size:14px;">Insider Buzz</a></li>&#32; <li><a title="Legal" href="/tag/legal" style="font-size:14px;">Legal</a></li>&#32; <li><a title="Legislation" href="/tag/legislation" style="font-size:14px;">Legislation</a></li>&#32; <li><a title="Mega Millions" href="/tag/mega_millions" style="font-size:14px;">Mega Millions</a></li>&#32; <li><a title="Scratch Games" href="/tag/scratch_games" style="font-size:14px;">Scratch Games</a></li>&#32; <li><a title="Winner Stories" href="/tag/winner_stories" style="font-size:18px;">Winner Stories</a></li>&#32; <li><a title="Winning Ticket Announcement" href="/tag/winning_ticket_announcement" style="font-size:14px;">Winning Ticket Announcement</a></li>&#32; <li style="float:right; margin:5px 0 0 10px;"><a title="Display all news story tags (the &quot;Tag Cloud&quot;)" href="/tags" style="font-size:14px;">More &raquo;</a></li></ul></div><div id="LP_ctl07" class="AU AUStandard AUSize300x250" style="width:300px;height:250px"><script>googletag.cmd.push(function(){googletag.display('LP_ctl07')})</script></div></div></div></div><div id="newsEnd"><span id="LP_NewsCommentsDesc" class="commentsDesc">7 comments. Last comment 9 minutes ago by <a href="/member/92148" data-member="92148" class="popmenu platinum">grwurston</a>.</span><div class="pagerlayout pagerlayoutinline"><table border="0" cellspacing="0" cellpadding="0"><tr><td><span style="margin-right:8px;">Page <strong>1</strong> of <strong>1</strong></span></td><td><div id="LP_PagerNews" class="pagercontrol sprite-pager sprite-pager-ddd"></div></td></tr></table></div></div><div id="message" class="pod withtitle fortext clr"><div class="titlelinks"><a id="LP_PreviousTopic" href="javascript:__doPostBack(&#39;ctl00$LP$PreviousTopic&#39;,&#39;&#39;)" title="Previous Topic" class="CB" data-sprite="back"><span>Previous Topic</span></a><a id="LP_NextTopic" href="javascript:__doPostBack(&#39;ctl00$LP$NextTopic&#39;,&#39;&#39;)" title="Next Topic" class="CB CB-ImageRight" data-sprite="next"><span>Next Topic</span></a></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6222708"></a><div class="name"><a href="/member/67915" data-member="67915" class="popmenu"><strong>dpoly1</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/avatars/driver.png" width="64" height="64" alt="dpoly1's avatar - driver" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank5" title="Senior"></b></div>PA<br />United States<br />Member&nbsp;#66139<br />October 16, 2008<br />1956&nbsp;Posts<br />Offline</div></td><td class="content"><table class="headcontent" border="0"><tr><td class="body"><strong>Posted:</strong> Today, 12:04&nbsp;pm - IP Logged</td><td class="options"></td></tr></table><div class="lpThreadContent"><p><span style="font-family: 'Arial Black', 'Avant Garde', Arial, Helvetica, FreeSans, sans-serif; font-size: 24px;">They do that past bedtime anyway LOL!</span></p><p><span style="font-family: 'Arial Black', 'Avant Garde', Arial, Helvetica, FreeSans, sans-serif; font-size: 24px;">I don't watch.</span></p><div class="signature"><p><span style="color: #000080;"><span style="font-family: Franklin Gothic Medium,Impact,Arial Black,sans-serif; font-size: 16px;"><strong>dpoly1 - Playing the lottery to save the jobs of those that build, transport, sell &amp; maintain luxury items!</strong></span><span style="font-size: 16px;"><strong>&nbsp;-</strong></span></span></p><p>&nbsp;</p><p><span style="color: #000080; font-size: 16px;"><strong><span style="font-family: Franklin Gothic Medium,Impact,Arial Black,sans-serif;">Eschew Poverty ........... Vote Conservative!</span></strong></span></p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6222709"></a><div class="name"><a href="/member/136608" data-member="136608" class="popmenu"><strong>Uluska</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/avatars/strawberry.jpg" width="64" height="64" alt="Uluska's avatar - strawberry" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank3" title="Experienced"></b></div><br />United States<br />Member&nbsp;#134623<br />November 2, 2012<br />1162&nbsp;Posts<br />Offline</div></td><td class="content"><table class="headcontent" border="0"><tr><td class="body"><strong>Posted:</strong> Today, 12:07&nbsp;pm - IP Logged</td><td class="options"></td></tr></table><div class="lpThreadContent"><p>Sounds fishy. Most likely they wanted to create greater rollover, to heat things up. Lately I start distrusting what lottery shows online, in a video, it can be all graphics,&nbsp; with numbers chosen by officials prior to the drawing.</p></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6222718"></a><div class="name"><a href="/member/195079" data-member="195079" class="popmenu platinum"><strong>Big Joey</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="https://members.lotterypost.com/big-joey/images/ADVATAR%20_NEW.jpg" width="100" height="84" alt="Big Joey's avatar - ADVATAR 20_NEW.jpg" /></div><div class="tag"><b class="platinum" title="Platinum Member"></b></div><div class="tag"><b class="rank rank2" title="Regular"></b></div>Louisiana<br />United States<br />Member&nbsp;#191895<br />August 27, 2018<br />484&nbsp;Posts<br />Offline</div></td><td class="content"><table class="headcontent" border="0"><tr><td class="body"><strong>Posted:</strong> Today, 12:15&nbsp;pm - IP Logged</td><td class="options"></td></tr></table><div class="lpThreadContent"><p>I only had one white ball.</p><div class="signature"><p><strong>All number sets are contenders until the drawing occurs.</strong></p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6222724"></a><div class="name"><a href="/member/185619" data-member="185619" class="popmenu gold"><strong>Kygrl07</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="gold" title="Gold Member"></b></div><div class="tag"><b class="rank rank0 rankname-top" title="New Member">New Member</b></div><br />United States<br />Member&nbsp;#183286<br />July 26, 2017<br />13&nbsp;Posts<br />Offline</div></td><td class="content"><table class="headcontent" border="0"><tr><td class="body"><strong>Posted:</strong> Today, 12:37&nbsp;pm - IP Logged</td><td class="options"></td></tr></table><div class="lpThreadContent"><p>KY draw was delayed also.</p></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6222760"></a><div class="name"><a href="/member/79872" data-member="79872" class="popmenu platinum"><strong>JezzVim</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="platinum" title="Platinum Member"></b></div><div class="tag"><b class="rank rank3" title="Experienced"></b></div>Pennsylvania<br />United States<br />Member&nbsp;#78050<br />August 6, 2009<br />831&nbsp;Posts<br />Offline</div></td><td class="content"><table class="headcontent" border="0"><tr><td class="body"><strong>Posted:</strong> Today, 1:03&nbsp;pm - IP Logged</td><td class="options"></td></tr></table><div class="lpThreadContent"><p><span style="font-size: 18px;">WHO didn't weight the balls???&nbsp; &nbsp;Hahaha!</span></p><div class="signature"><p style="margin: 12pt 0in; text-align: center;"><span style="font-size: 16px;"><strong><span style="color: black; font-family: 'Verdana','sans-serif';">Life Is Wonderful If You Don't Weaken</span></strong></span></p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6222834"></a><div class="name"><a href="/member/163706" data-member="163706" class="popmenu"><strong>djpowerball1234</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank0 rankname-top" title="New Member">New Member</b></div>northern fl<br />United States<br />Member&nbsp;#161490<br />December 1, 2014<br />16&nbsp;Posts<br /><span class="online">Online</span></div></td><td class="content"><table class="headcontent" border="0"><tr><td class="body"><strong>Posted:</strong> Today, 2:45&nbsp;pm - IP Logged</td><td class="options"></td></tr></table><div class="lpThreadContent"><p><span style="font-size: 24px;">very fishy. can't have a drawing due to a malfunction. they never say what kind of malfunction.&nbsp; and where is the video of the drawing after they fixed the machine</span></p></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6222879"></a><div class="name"><a href="/member/92148" data-member="92148" class="popmenu platinum"><strong>grwurston</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/avatars/_Lottery-012.jpg" width="64" height="64" alt="grwurston's avatar - Lottery-012.jpg" /></div><div class="tag"><b class="platinum" title="Platinum Member"></b></div><div class="tag">Win Today.</div><div class="tag"><b class="rank rank7" title="Guru"></b></div>bel air maryland<br />United States<br />Member&nbsp;#90247<br />April 24, 2010<br />8724&nbsp;Posts<br /><span class="online">Online</span></div></td><td class="content"><table class="headcontent" border="0"><tr><td class="body"><strong>Posted:</strong> Today, 4:40&nbsp;pm - IP Logged</td><td class="options"></td></tr></table><div class="lpThreadContent"><div class="quote"><label><strong>Quote:</strong> Originally posted by <a href="/member/163706" data-member="163706" class="popmenu">djpowerball1234</a> on March 8, 2020</label><div class="quotebody"><p><span style="font-size: 24px;">very fishy. can't have a drawing due to a malfunction. they never say what kind of malfunction.&nbsp; and where is the video of the drawing after they fixed the machine</span></p></div></div><p><span style="font-size: 16px;">The drawing video is on the link in the story. <a href="https://www.usamega.com/powerball-drawing.asp?d=3/7/2020" rel="external noopener">https://www.usamega.com/powerball-drawing.asp?d=3/7/2020</a></span></p><p><span style="font-size: 16px;">See that? All the pre tests in the world, won't prevent a malfunction from happening during the official drawing.&nbsp;</span></p><p><span style="font-size: 16px;">So what's the point of having them?</span></p><p><span style="font-size: 16px;">Especially when all the lotteries always have a Plan B, just in case something like this does happen.</span></p><div class="signature"><p>&quot;You can observe a lot just by watching.&quot; Yogi Berra, Hall of Fame baseball player. <br /><br /> The numbers will tell you what numbers to play. Pay attention to the numbers.</p><p>Every lottery system can be improved. If you're not winning almost every day, yours can be made better.</p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div class="podfooter"><table border="0" class="podfooterlayout"><tr><td class="left"> &nbsp; </td><td class="center"><div class="pagerlayout pagerlayoutinline"><table border="0" cellspacing="0" cellpadding="0"><tr><td><span style="margin-right:8px;">Page <strong>1</strong> of <strong>1</strong></span></td><td><div id="LP_PagerFoot" class="pagercontrol sprite-pager sprite-pager-ddd"></div></td></tr></table></div></td><td class="right"><span class="nobr"></span></td></tr></table><div id="LP_RssFoot" class="podRssSection"><a id="LP_NewsRss" href="/rss/news/331226" title="Subscribe to the RSS feed for this news story and comments" class="CB" data-sprite="feed"><span>Subscribe to this news story</span></a></div></div></div><table class="blockAuLayout"><tr><td><div id="LP_FooterBannerAd" class="AU AUStandard AUSize468x60" style="width:468px;height:60px"><script>googletag.cmd.push(function(){googletag.display('LP_FooterBannerAd')})</script></div></td><th><div id="LP_FooterBlockAd" class="AU AUStandard AUSize300x250" style="width:300px;height:250px"><script>googletag.cmd.push(function(){googletag.display('LP_FooterBlockAd')})</script></div></th></tr></table></td></tr></table><ul id="mainMenu" class="jqMenu nonMbr" style="display:none;visibility:hidden"><li id="menuSpaceL"></li><li class="mainMenu"><a href="/forums">Forums</a><ul class="jqMenuPanel"><li><a href="/activetopics">Active Topics</a></li><li><a href="/search">Search</a></li><li><a href="/dailytopics" class="mbrOnly">Daily Topics</a></li><li><a href="/chat">Chat (Limited Schedule)</a></li><li class="title">General Discussion</li><li><a href="/forum/1">Lottery Discussion</a></li><li><a href="/forum/11">Lottery News</a></li><li><a href="/forum/10">Lottery Systems</a></li><li><a href="/forum/12">Mathematics</a></li><li><a href="/forum/13">Mystical</a></li><li><a href="/forum/2">Gaming</a></li><li class="title">Specific Lottery Games</li><li><a href="/forum/3">Pick 3</a></li><li><a href="/forum/4">Pick 4</a></li><li><a href="/forum/5">Pick 5</a></li><li><a href="/forum/6">Jackpot Games</a></li><li><a href="/forum/8">Instant ("Scratch-Off") Games</a></li><li class="title">Lottery Post Administration</li><li><a href="/help">Help</a></li><li><a href="/forum/7">Suggestions</a></li></ul></li><li class="mainMenu"><a href="/results">Results</a><ul class="jqMenuPanel"><li><a href="/results">Lottery Results Home Page</a></li><li class="sep"></li><li><a href="/results/search" class="mbrOnly">Search Past Results</a></li><li><a href="/results/custom" class="mbrOnly">Custom Lottery Results</a></li><li><a href="/results/daily" class="mbrOnly">Daily Numbers Games</a></li><li><a href="/results/all" class="mbrOnly">All Results on One Page</a></li><li class="sep"></li><li><a href="#">United States</a><ul class="jqMenuPanel cols3"><li><a href="/results/az">Arizona</a></li><li><a href="/results/ar">Arkansas</a></li><li><a href="/results/ca">California</a></li><li><a href="/results/co">Colorado</a></li><li><a href="/results/ct">Connecticut</a></li><li><a href="/results/de">Delaware</a></li><li><a href="/results/fl">Florida</a></li><li><a href="/results/ga">Georgia</a></li><li><a href="/results/id">Idaho</a></li><li><a href="/results/il">Illinois</a></li><li><a href="/results/in">Indiana</a></li><li><a href="/results/ia">Iowa</a></li><li><a href="/results/ks">Kansas</a></li><li><a href="/results/ky">Kentucky</a></li><li><a href="/results/la">Louisiana</a></li><li><a href="/results/me">Maine</a></li><li><a href="/results/md">Maryland</a></li><li><a href="/results/ma">Massachusetts</a></li><li><a href="/results/mi">Michigan</a></li><li><a href="/results/mn">Minnesota</a></li><li><a href="/results/ms">Mississippi</a></li><li><a href="/results/mo">Missouri</a></li><li><a href="/results/mt">Montana</a></li><li><a href="/results/ne">Nebraska</a></li><li><a href="/results/nh">New Hampshire</a></li><li><a href="/results/nj">New Jersey</a></li><li><a href="/results/nm">New Mexico</a></li><li><a href="/results/ny">New York</a></li><li><a href="/results/nc">North Carolina</a></li><li><a href="/results/nd">North Dakota</a></li><li><a href="/results/oh">Ohio</a></li><li><a href="/results/ok">Oklahoma</a></li><li><a href="/results/or">Oregon</a></li><li><a href="/results/pa">Pennsylvania</a></li><li><a href="/results/pr">Puerto Rico</a></li><li><a href="/results/ri">Rhode Island</a></li><li><a href="/results/sc">South Carolina</a></li><li><a href="/results/sd">South Dakota</a></li><li><a href="/results/tn">Tennessee</a></li><li><a href="/results/tx">Texas</a></li><li><a href="/results/vt">Vermont</a></li><li><a href="/results/va">Virginia</a></li><li><a href="/results/wa">Washington</a></li><li><a href="/results/dc">Washington, D.C.</a></li><li><a href="/results/wv">West Virginia</a></li><li><a href="/results/wi">Wisconsin</a></li><li><a href="/results/wy">Wyoming</a></li></ul></li><li><a href="#">Canada</a><ul class="jqMenuPanel"><li><a href="/results/ac">Atlantic Canada</a></li><li><a href="/results/bc">British Columbia</a></li><li><a href="/results/on">Ontario</a></li><li><a href="/results/qc">Québec</a></li><li><a href="/results/wc">Western Canada</a></li></ul></li><li><a href="#">Europe</a><ul class="jqMenuPanel"><li><a href="/results/germany">Germany</a></li><li><a href="/results/ie">Ireland</a></li><li><a href="/results/italy">Italy</a></li><li><a href="/results/uk">United Kingdom</a></li></ul></li><li><a href="#">Multi-Jurisdiction</a><ul class="jqMenuPanel"><li><a href="/results/xx">Multi-State (United States)</a></li><li><a href="/results/zz">Multi-Province (Canada)</a></li><li><a href="/results/yy">Multi-Country</a></li></ul></li><li class="sep"></li><li><a href="/jackpots">Current Lottery Jackpots</a></li><li class="sep"></li><li><a href="/gadget">Lottery Results Gadget for Windows</a></li><li><a href="/lottery-report-card.asp">State Lottery Report Card</a></li><li><a href="/petition-true-drawings.aspx">Help Eliminate Computerized Drawings</a></li></ul></li><li class="mainMenu"><a href="/predictions">Predictions</a><ul class="jqMenuPanel"><li><a href="/predictions">Predictions Home Page</a></li><li class="sep"></li><li><a href="#">United States</a><ul class="jqMenuPanel cols3"><li><a href="/predictions-state.asp?s=az">Arizona</a></li><li><a href="/predictions-state.asp?s=ar">Arkansas</a></li><li><a href="/predictions-state.asp?s=ca">California</a></li><li><a href="/predictions-state.asp?s=co">Colorado</a></li><li><a href="/predictions-state.asp?s=ct">Connecticut</a></li><li><a href="/predictions-state.asp?s=de">Delaware</a></li><li><a href="/predictions-state.asp?s=fl">Florida</a></li><li><a href="/predictions-state.asp?s=ga">Georgia</a></li><li><a href="/predictions-state.asp?s=id">Idaho</a></li><li><a href="/predictions-state.asp?s=il">Illinois</a></li><li><a href="/predictions-state.asp?s=in">Indiana</a></li><li><a href="/predictions-state.asp?s=ia">Iowa</a></li><li><a href="/predictions-state.asp?s=ks">Kansas</a></li><li><a href="/predictions-state.asp?s=ky">Kentucky</a></li><li><a href="/predictions-state.asp?s=la">Louisiana</a></li><li><a href="/predictions-state.asp?s=me">Maine</a></li><li><a href="/predictions-state.asp?s=md">Maryland</a></li><li><a href="/predictions-state.asp?s=ma">Massachusetts</a></li><li><a href="/predictions-state.asp?s=mi">Michigan</a></li><li><a href="/predictions-state.asp?s=mn">Minnesota</a></li><li><a href="/predictions-state.asp?s=ms">Mississippi</a></li><li><a href="/predictions-state.asp?s=mo">Missouri</a></li><li><a href="/predictions-state.asp?s=mt">Montana</a></li><li><a href="/predictions-state.asp?s=ne">Nebraska</a></li><li><a href="/predictions-state.asp?s=nh">New Hampshire</a></li><li><a href="/predictions-state.asp?s=nj">New Jersey</a></li><li><a href="/predictions-state.asp?s=nm">New Mexico</a></li><li><a href="/predictions-state.asp?s=ny">New York</a></li><li><a href="/predictions-state.asp?s=nc">North Carolina</a></li><li><a href="/predictions-state.asp?s=nd">North Dakota</a></li><li><a href="/predictions-state.asp?s=oh">Ohio</a></li><li><a href="/predictions-state.asp?s=ok">Oklahoma</a></li><li><a href="/predictions-state.asp?s=or">Oregon</a></li><li><a href="/predictions-state.asp?s=pa">Pennsylvania</a></li><li><a href="/predictions-state.asp?s=pr">Puerto Rico</a></li><li><a href="/predictions-state.asp?s=ri">Rhode Island</a></li><li><a href="/predictions-state.asp?s=sc">South Carolina</a></li><li><a href="/predictions-state.asp?s=sd">South Dakota</a></li><li><a href="/predictions-state.asp?s=tn">Tennessee</a></li><li><a href="/predictions-state.asp?s=tx">Texas</a></li><li><a href="/predictions-state.asp?s=vt">Vermont</a></li><li><a href="/predictions-state.asp?s=va">Virginia</a></li><li><a href="/predictions-state.asp?s=wa">Washington</a></li><li><a href="/predictions-state.asp?s=dc">Washington, D.C.</a></li><li><a href="/predictions-state.asp?s=wv">West Virginia</a></li><li><a href="/predictions-state.asp?s=wi">Wisconsin</a></li><li><a href="/predictions-state.asp?s=wy">Wyoming</a></li></ul></li><li><a href="#">Canada</a><ul class="jqMenuPanel"><li><a href="/predictions-state.asp?s=ac">Atlantic Canada</a></li><li><a href="/predictions-state.asp?s=bc">British Columbia</a></li><li><a href="/predictions-state.asp?s=on">Ontario</a></li><li><a href="/predictions-state.asp?s=qc">Québec</a></li><li><a href="/predictions-state.asp?s=wc">Western Canada</a></li></ul></li><li><a href="#">Europe</a><ul class="jqMenuPanel"><li><a href="/predictions-state.asp?s=02">Germany</a></li><li><a href="/predictions-state.asp?s=ie">Ireland</a></li><li><a href="/predictions-state.asp?s=uk">United Kingdom</a></li></ul></li><li><a href="#">Multi-Jurisdiction</a><ul class="jqMenuPanel"><li><a href="/predictions-state.asp?s=xx">Multi-State (United States)</a></li><li><a href="/predictions-state.asp?s=zz">Multi-Province (Canada)</a></li><li><a href="/predictions-state.asp?s=yy">Multi-Country</a></li></ul></li><li class="sep"></li><li><a href="/predictions-winners.asp">See Yesterday's Winners</a></li><li><a href="/predictions-statistics-top.asp">Top Predictors</a></li><li class="sep"></li><li><a href="/predictions-member.asp" class="disabled">My Predictions</a></li><li><a href="/predictions-statistics.asp" class="disabled">My Prediction Statistics</a></li><li><a href="/post-prediction-form.asp" class="mbrOnly">Post Predictions</a></li><li class="sep"></li><li><a href="/wheels">Lottery Wheels</a></li><li><a href="/deflate3.asp" class="mbrOnly">Deflate 3 Number Reduction System</a></li><li><a href="/deflate4.asp" class="mbrOnly">Deflate 4 Number Reduction System</a></li><li><a href="/deflate5.asp" class="mbrOnly">Deflate 5 Number Reduction System</a></li><li><a href="/inspector3.asp" class="mbrOnly">Inspector 3 Number Classification System</a></li><li><a href="/inspector4.asp" class="mbrOnly">Inspector 4 Number Classification System</a></li></ul></li><li class="mainMenu"><a href="/memberships">Members</a><ul class="jqMenuPanel"><li><a href="/login">Log In</a></li><li><a href="/register">Register for a Free Membership</a></li><li class="sep"></li><li><a href="/memberships">Compare Membership Features</a></li><li class="sep"></li><li><a href="/memberlist" class="mbrOnly">Member List</a></li><li class="sep"></li><li><a href="/member/profile" class="disabled">My Profile</a></li><li><a href="/member/recentposts" class="disabled">My Recent Posts</a></li><li><a href="/member/favorites" class="disabled">My Favorites</a></li><li><a href="/control_subs.asp" class="disabled">My Subscriptions</a></li><li><a href="/blocklist.aspx" class="disabled">My Block List</a></li><li><a href="/imagemanager.aspx" class="disabled">My Images (Image Manager)</a></li><li class="sep">&nbsp;</li><li><a href="/blogs">Blogs Home Page</a></li><li><a href="/blog" class="disabled">My Blog</a></li><li><a href="/new-blog.aspx" class="mbrOnly">Post New Blog Entry</a></li><li><a href="/search/blogs">Search Blogs</a></li><li><a href="/control_blog.asp" class="mbrOnly">Premium Blog Settings</a></li><li class="sep"></li><li><a href="/chat">Chat (Limited Schedule)</a></li><li class="sep"></li><li><a href="/features.asp">Premium Features</a></li><li><a href="/buy-membership.asp">Buy/Renew Membership</a></li></ul></li><li class="mainMenu"><a href="/systems">Systems</a><ul class="jqMenuPanel"><li><a href="/systems">Lottery Systems Home page</a></li><li class="sep"></li><li><a href="/deflate3.asp" class="mbrOnly">Deflate 3 Number Set Reduction</a></li><li><a href="/deflate4.asp" class="mbrOnly">Deflate 4 Number Set Reduction</a></li><li><a href="/deflate5.asp" class="mbrOnly">Deflate 5 Number Set Reduction</a></li><li><a href="/inspector3.asp" class="mbrOnly">Inspector 3 Number Set Analysis</a></li><li><a href="/inspector4.asp" class="mbrOnly">Inspector 4 Number Set Analysis</a></li><li class="sep"></li><li><a href="/reports/combinations">Combinations Analysis for Pick 3 and Pick 4</a></li><li><a href="/reports/pairs">Pairs Analysis for Pick 3 and Pick 4</a></li><li class="sep"></li><li><a href="/system-lucky-tracker.aspx">Lucky's Daily Tracker</a></li><li><a href="/system-lucky-followers.aspx">Lucky's Followers System</a></li><li><a href="/system-lucky-1up1down.asp">Lucky's 1-Up 1-Down System</a></li><li class="sep"></li><li><a href="/vtracs">VTracs Home Page</a></li><li><a href="/vtracs/results" class="mbrOnly">VTrac Lottery Results</a></li><li><a href="/vtracs/search" class="mbrOnly">VTracs Search Engine</a></li><li><a href="#">VTrac Charts</a><ul class="jqMenuPanel"><li><a href="/vtracs/mirrors/pick3">VTrac Pick 3 Mirror Combinations</a></li><li><a href="/vtracs/mirrors/pick4">VTrac Pick 4 Mirror Combinations</a></li><li><a href="/vtracs/mirrors/quinto">VTrac Quinto Mirror Combinations</a></li></ul></li><li class="sep"></li><li><a href="/wheels">Lottery Wheels Home Page</a></li><li><a href="/wheels/positional" class="mbrOnly">Positional Wheels for Pick 3, Pick 4, and Quinto</a></li><li><a href="/wheels/pick5" class="mbrOnly">Pick 5 Wheels</a></li><li><a href="/wheels/pick6" class="mbrOnly">Pick 6 Wheels</a></li><li class="sep"></li><li><a href="/quickpicks">Quick Picks Generator</a></li><li><a href="/words-to-numbers">Convert Words and Phrases to Lottery Numbers</a></li><li><a href="/combinations">Lottery Combinations Generator</a></li></ul></li><li class="mainMenu"><a href="#">Resources</a><ul class="jqMenuPanel"><li><a href="/search">Search for something</a></li><li class="sep"></li><li><a href="/news">Lottery News</a></li><li><a href="/tags">Lottery News Story Tags ("Tag Cloud")</a></li><li><a href="/rss">Syndicated RSS 2.0 Feeds</a></li><li class="sep"></li><li><a href="/onthisday">On This Day in History</a></li><li><a href="/calendar">Event Calendar</a></li><li><a href="/lunarcalendar">Lunar Calendar</a></li><li><a href="#">Lottery Charts</a><ul class="jqMenuPanel"><li><a href="/charts">Lottery Charts Main Page</a></li><li class="sep"></li><li><a href="/charts/pick3/combinations">Pick 3 Straight and Box Combinations</a></li><li><a href="/charts/pick3/sums">Pick 3 Sums</a></li><li><a href="/charts/pick3/rootsums">Pick 3 Root Sums</a></li><li><a href="/charts/pick3/sumlastdigit">Pick 3 Sum Last Digit</a></li><li><a href="/vtracs/mirrors/pick3">VTrac Pick 3 Mirror Combinations</a></li><li class="sep"></li><li><a href="/charts/pick4/combinations">Pick 4 Straight and Box Combinations</a></li><li><a href="/charts/pick4/sums">Pick 4 Sums</a></li><li><a href="/charts/pick4/rootsums">Pick 4 Root Sums</a></li><li><a href="/charts/pick4/sumlastdigit">Pick 4 Sum Last Digit</a></li><li><a href="/vtracs/mirrors/pick4">VTrac Pick 4 Mirror Combinations</a></li><li class="sep"></li><li><a href="/charts/quinto/combinations">Quinto Straight and Box Combinations</a></li><li><a href="/charts/quinto/sums">Quinto Sums</a></li><li><a href="/charts/quinto/rootsums">Quinto Root Sums</a></li><li><a href="/charts/quinto/sumlastdigit">Quinto Sum Last Digit</a></li><li><a href="/vtracs/mirrors/quinto">VTrac Quinto Mirror Combinations</a></li><li class="sep"></li><li><a href="/charts/mystical/lacharada">La Charada</a></li></ul></li><li><a href="/quickpicks">Quick Picks Generator</a></li><li><a href="/combinations">Lottery Combinations Generator</a></li><li><a href="/odds">Lottery Odds Calculator</a></li><li class="sep"></li><li><a href="/activeusers" class="mbrOnly">Who's Online</a></li><li><a href="/activity" class="mbrOnly">Monitor Site Activity</a></li><li class="sep"></li><li><a href="/contact">Contact Us</a></li><li><a href="#">About Us</a><ul class="jqMenuPanel"><li><a href="/about">About Lottery Post</a></li><li><a href="/changelog">Web Site Change Log</a></li><li><a href="/sitemap">Site Map</a></li><li class="sep"></li><li><a href="/rules">Forum Rules</a></li><li><a href="/privacy">Privacy Statement</a></li><li><a href="/copyright">Copyright Notice</a></li><li><a href="/terms.aspx">Terms and Conditions of Use</a></li><li><a href="/linkpolicy.aspx">Link Policy</a></li></ul></li><li class="sep"></li><li><a href="#">Online Games</a><ul class="jqMenuPanel"><li><a href="/games">Games Main Page</a></li><li class="sep"></li><li><a href="/2048">Play 2048</a></li><li><a href="/sudoku">Play Sudoku</a></li></ul></li><li><a href="/books">Lottery Book Store</a></li><li><a href="http://www.cafepress.com/lotterypost/" rel="external noopener">Lottery Post Gift Shop</a></li><li><a href="/links">Lottery Links</a></li><li><a href="https://www.usamega.com/" rel="external noopener">USA Mega (Powerball/Mega Millions)</a></li><li class="sep"></li><li><a href="/browsertest">Browser Compatibility Test</a></li></ul></li><li class="mainMenu"><a href="#">Options</a><ul class="jqMenuPanel"><li><a href="/control.asp" class="disabled">Control Panel Home page</a></li><li class="sep"></li><li><a href="/control_profile.asp" class="disabled">Edit Profile</a></li><li><a href="/edit-signature.aspx" class="disabled">Create/Edit Signature</a></li><li><a href="/change-avatar.aspx" class="disabled">Add or Change Avatar</a></li><li class="sep"></li><li><a href="/control_account.asp" class="disabled">Account Settings</a></li><li><a href="/control_blog.asp" class="disabled">Premium Blog Settings</a></li><li><a href="/control_email.asp" class="disabled">E-mail Settings</a></li><li><a href="/control_favorites.asp" class="disabled">Favorites Settings</a></li><li><a href="/control_changeemail.asp" class="disabled">Change E-mail Address</a></li><li><a href="/changepassword">Change Password</a></li><li class="sep"></li><li><a href="/whitelist">Whitelist Lottery Post</a></li><li><a href="/DeleteCookies.aspx">Delete cookies set by Lottery Post</a></li><li class="sep"></li><li><a href="/login">Log In</a></li><li><a href="/register">Register for a Free Membership</a></li></ul></li><li id="menuSpaceR"></li></ul></div><div id="footer"><div id="footerContent"><div id="footerCols"><div class="col1"><div class="colContent"><label>First Time?</label><p>If you haven't already, check out the <a title="About Lottery Post" href="/about">About Us</a> page that explains the main features of our site.</p><p>Also, please take a few moments and review the <a title="Rules for posting at Lottery Post" href="/rules">rules</a> for posting at Lottery Post.</p><p>Any time you see a <samp title="This is an example of a popup menu link. You would click it to reveal a popup menu of options.">gray-underlined link</samp>, you can click the link to see a popup menu of options.</p><p><strong>Popular features:</strong></p><ul><li><a title="Lottery results (winning numbers)" href="/results">Lottery Results</a></li><li><a title="Lottery discussion forums" href="/forums">Discussion Forums</a></li><li><a title="Lottery predictions" href="/predictions">Predictions Board</a></li><li><a title="Lottery methods, systems, and wheels" href="/systems">Lottery Systems and Wheels</a></li><li><a title="Quality, hand-picked selection of lottery and dream books" href="/books">Book Store - lottery &amp; dream books</a></li><li><a title="Lottery Results Gadget for Windows" href="/gadget">Lottery Results Gadget</a></li></ul></div></div><div class="col2"><div class="colContent"><label>Need Help?</label><p>We try to include instructions on each page. Check for help content on the page that's giving you trouble.</p><p>The next place to seek help is our dedicated <a title="See Lottery Post's dedicated help forum" href="/help">Help forum</a> that contains detailed assistance for frequently requested topics.</p><p>If something isn't working properly, our automated <a title="Use the automated Browser Compatibility Test" href="/browsertest">Browser Test</a> page can quickly identify common problems.</p><p>Finally, the <a title="Contact Lottery Post" href="/contact">Contact Us</a> page has an incredible wealth of self-help material that answers 95% of the questions we are asked.</p><p>We always welcome <a title="Send us your feedback" href="/contact/site">feedback</a> and <a title="Send us your suggestions" href="/contact/suggest">suggestions</a>.</p></div></div><div class="col3"><div class="colContent"><label>About Lottery Post</label><p><a title="About Lottery Post" href="/about">About Us</a>&nbsp;&bull; <a title="Lottery Post Site Map" href="/sitemap">Site Map</a>&nbsp;&bull; <a title="Comparison chart of membership features" href="/memberships">Membership Features</a>&nbsp;&bull; <a title="Inquire about advertising at Lottery Post" href="/contact/ads">Advertising Opportunities</a>&nbsp;&bull; <a title="DMCA" href="/dmca">DMCA</a>&nbsp;&bull; <a title="See Lottery Post's journal of Web site changes" href="/changelog">Change Log</a>&nbsp;&bull; <a title="Rules for posting at Lottery Post" href="/rules">Rules</a>&nbsp;&bull; <a title="Lottery Post's Privacy Statement" href="/privacy">Privacy</a>&nbsp;&bull; <a title="See Lottery Post's Link Policy" href="/linkpolicy.aspx">Linking to Lottery Post</a></p><label>RSS Feeds</label><p><a title="Lottery Post's main index of RSS feeds" href="/rss">Index of Feeds</a>&nbsp;&bull; <a title="RSS feed of lottery news stories" href="http://feeds.lotterypost.com/LotteryNews">Lottery News</a>&nbsp;&bull; <a title="RSS feed of events" href="http://feeds.lotterypost.com/LotteryPostEventCalendar">Event Calendar</a>&nbsp;&bull; <a title="RSS feed of the latest posts on the discussion forums" href="http://feeds.lotterypost.com/LotteryPostActiveTopics">Latest Forum Posts</a>&nbsp;&bull; <a title="RSS feed of Lottery Post's journal of Web site changes" href="http://feeds.lotterypost.com/LotteryPostChangeLog">Web Site Change Log</a></p><label>Search Lottery Post</label><p>Search the news, forums, blogs, and even your private messages at our <a title="Search for something at Lottery Post" href="/search">Search</a> page.</p></div></div></div><div class="col4"><div class="colContent"><p>This page was generated in 0.0911 seconds.<br /><a href="/copyright">Copyright</a> &copy; 1999-2020 <a href="https://www.speednet.biz/">Speednet Group</a>.&nbsp; All rights reserved.</p></div></div></div></div><script src="https://lp.vg/script/advert.js"></script><script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"></script><div id="PagerMenuPanel"></div><div class="aspNetHidden"><input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="6E8D4450" /><input type="hidden" name="__VIEWSTATEENCRYPTED" id="__VIEWSTATEENCRYPTED" value="" /></div><script src="https://lp.vg/js/ds00211.0/MwtGFZn69uAwUEBU1xQNAHR7FoSyGDVA6BzbcVg6aEZjnjKKk9Rrt8egtyaKSMzNkICrg4d5Ke3NoOtwS(DCOHQzmBP4wqL5veCYtyspv2G4oJ(GmxykoLR3upAk3jTVdPDBW3)eWVULWUdXqyPlPo5XO3Sw59KQ9KsazSqMcavoZum1EbsJt4aEoh8LduaYVHw1t4noRQqJbz0RYqRmuHkkUQy7qdpzIpr8K17s5RmjTbzMB8D)AW2)WxOiEiAyAev7/fT63e2l0(w57RziKWEWnZGXkx5o8VFdgMeuNDiNOb4)qsO4TyeuA21e4qbbDRZM(F2qtwXDiGHa9WmnFwMn6kGfgjLRINM4OOo3Ikjjz72wB6X3viQJ20GY56CC9Fn9LotbSuJY1gomZVvnl1J00jurMNYQV)RwODW4Kun2Ql7qMUAzUAa06AGgKY0EBuIVY2V5NiHZPTFaaFK1xP8DXFH6FCyE5bSZ60H)CF5I="></script><script>$(function(){window.setTimeout(function(){$('#mainMenu').jqMenu({rightAlignElement:'#pagewidth',rightAlignOffset:316,rightAlignPopupLimit:true,recalcPositionOnFontLoad:'Oswald'});},1);});var mL={92148:[92148,'grwurston','','',0],67915:[67915,'dpoly1','','',0],136608:[136608,'Uluska','','',0],195079:[195079,'Big Joey','','',0],185619:[185619,'Kygrl07','','',0],79872:[79872,'JezzVim','','',0],163706:[163706,'djpowerball1234','','',0]};var gL={};$.ratingDefaults({servicePath:'/services/Callback.asmx',viewServiceMethod:'GetTopicRatings',saveServiceMethod:'SetTopicRating',deleteServiceMethod:'DeleteTopicRating',spinner:'<p><span class="spinner spinner0 spinner0-size16" style="vertical-align:middle;"><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i></span> Loading...</p>'});ThreadPage.initialize(331226,6222879,0,false,0,null);$('#rating331226').rating({ratedTargetID:331226,memberID:0,ratingMember:0,ratingCurrent:5,ratingCount:3});$($.wired(NewsPage, NewsPage.initialize));</script></form><script type="application/ld+json">{"@context":"https://schema.org/","@id":"https://www.lotterypost.com/#organization","@type":"Organization","name":"Lottery Post","url":"https://www.lotterypost.com/","logo":{"@type":"ImageObject","url":"https://www.lotterypost.com/images/lp_icon_310.png"},"founder":{"@type":"Person","name":"Todd Northrop"},"description":"Lottery Post is a popular website for lottery players to get the latest lottery results, prizes, and jackpots, and to discuss, share, and discover anything and everything about official government lottery games around the world.","sameAs":["https://www.youtube.com/LotteryPost","https://www.facebook.com/LotteryPost","https://twitter.com/LotteryPost","https://www.instagram.com/LotteryPost/"]}</script></body></html> 