<!DOCTYPE html>
<html lang="en"><head><meta charset="utf-8" />

<!--	Lottery Post® (https://www.lotterypost.com)
	Author: Todd Northrop
	E-mail: webmaster (at) lotterypost (dot) com
	Copyright © 1999-2020. All Rights Reserved.
	Reproduction in whole or in part in any form or medium without express written permission of the Author is prohibited. See https://www.lotterypost.com/copyright
	Lottery Post and the Lottery Post logo are registered trademarks of Speednet Group, and may not be used without express written permission.
- - - - - - - - - - - - - - - - - - - - - - - - - - - -->

<title>$750 MILLION: Second-largest Mega Millions jackpot in history to be drawn Friday | Lottery Post</title><meta name="application-name" content="Lottery Post" /><meta name="format-detection" content="telephone=no" /><meta name="msapplication-starturl" content="/" /><meta name="theme-color" content="#bcceff" /><meta name="viewport" content="width=968" /><meta name="title" content="$750 MILLION: Second-largest Mega Millions jackpot in history to be drawn Friday" /><meta name="keywords" content="lottery,news,Mega Millions,Jackpots,Multi-State Game" /><meta name="description" content="After 34 drawings without a jackpot winner, the multi-state Mega Millions lottery game now boasts a swelling jackpot of three-quarters of a billion dollars that could instantly put someone among the wealthiest people on the planet." /><meta property="og:title" content="$750 MILLION: Second-largest Mega Millions jackpot in history to be drawn Friday | Lottery Post" /><meta property="og:type" content="article" /><meta property="og:url" content="https://www.lotterypost.com/news/335225" /><meta property="og:description" content="After 34 drawings without a jackpot winner, the multi-state Mega Millions lottery game now boasts a swelling jackpot of three-quarters of a billion dollars that could instantly put someone among the wealthiest people on the planet." /><meta property="og:image" content="https://lp.vg/images/newsicon_megamillions.jpg" /><meta property="og:image:width" content="280" /><meta property="og:image:height" content="200" /><meta property="og:image:alt" content="Mega Millions" /><meta property="og:site_name" content="Lottery Post" /><meta property="article:published_time" content="2021-01-13T08:01:57-05:00" /><meta property="article:tag" content="Lottery" /><meta property="article:tag" content="Mega Millions" /><meta property="article:tag" content="Jackpots" /><meta property="article:tag" content="Multi-State Game" /><meta name="twitter:card" content="summary" /><meta name="twitter:title" content="$750 MILLION: Second-largest Mega Millions jackpot in history to be drawn Friday | Lottery Post" /><meta name="twitter:url" content="https://www.lotterypost.com/news/335225" /><meta name="twitter:description" content="After 34 drawings without a jackpot winner, the multi-state Mega Millions lottery game now boasts a swelling jackpot of three-quarters of a billion dollars that could instantly put someone among the wealthiest people on the planet." /><meta name="twitter:site" content="@LotteryPost" /><meta name="twitter:image" content="https://lp.vg/images/newsicon_megamillions.jpg" /><link rel="canonical" href="https://www.lotterypost.com/news/335225" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:400,700" /><link rel="manifest" href="/manifest.webmanifest" /><link rel="shortcut icon" href="/images/theme/icon-lponly-48.ico" type="image/vnd.microsoft.icon" sizes="16x16 32x32 48x48" /><link rel="icon" href="/images/theme/icon-lp-192.png" type="image/png" sizes="192x192" /><link rel="apple-touch-icon" href="/images/theme/icon-lp-180.png" sizes="180x180" /><link rel="mask-icon" href="/images/svg/lp-mask.svg" color="#aa6500" /><link rel="search" href="/xml/SearchProviderForums.xml" type="application/opensearchdescription+xml" title="Lottery Post Search" /><link rel="preload" href="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js" as="script" /><link rel="alternate" href="https://www.lotterypost.com/rss/news/335225" type="application/rss+xml" title="Subscribe to &quot;$750 MILLION: Second-largest Mega Millions jackpot in history to be drawn Friday&quot;" /><link rel="alternate" href="https://m.lotterypost.com/news/335225" media="only screen and (max-width: 640px)" /><script async src="https://www.googletagservices.com/tag/js/gpt.js"></script><script async src="https://c.amazon-adsystem.com/aax2/apstag.js"></script><script async src="https://lp.vg/js/f1/pb3.21.0.js"></script><script>var googletag=googletag||{};googletag.cmd=googletag.cmd||[];!function(g){g.cmd.push(function(){g.defineSlot('/13070090/LP_728x90',[728,90],'AUHead').addService(g.pubads());g.defineSlot('/13070090/LP_120x600',[120,600],'MasterAuLeft').addService(g.pubads());g.defineSlot('/13070090/LP_300x250_Primary',[300,250],'LP_ctl05').addService(g.pubads());g.defineSlot('/13070090/LP_300x250_Secondary',[300,250],'LP_ctl07').addService(g.pubads());g.defineSlot('/13070090/LP_468x60_Text',[468,60],'LP_FooterBannerAd').addService(g.pubads());g.defineSlot('/13070090/LP_300x250_Primary',[300,250],'LP_FooterBlockAd').addService(g.pubads());try{var i,e=document.getElementsByTagName('link'),l=e.length;for(i=0;i<l;i++){if(e[i].rel==='canonical'){g.pubads().set('page_url',e[i].href);i=l}}}catch(r){}g.pubads().setTargeting('Device','Computer');g.pubads().setTargeting('Content','Restrict');g.pubads().setTargeting('Category','News');g.pubads().disableInitialLoad();g.pubads().enableSingleRequest();g.pubads().collapseEmptyDivs();g.pubads().enableLazyLoad({fetchMarginPercent:500,renderMarginPercent:200,mobileScaling:2.0});g.enableServices()})}(googletag);var pbBds=function(n,t,i,r,u,f,e,o){var s={code:n,mediaTypes:{banner:{sizes:t}},bids:[]},h;if(i&&s.bids.push({bidder:"appnexus",params:{placementId:i,reserve:.01}}),r)for(h=0;h<t.length;h++)s.bids.push({bidder:"ix",params:{siteId:r,size:t[h]}});return u&&s.bids.push({bidder:"medianet",params:{cid:"8CUCSJ2Y7",crid:u,bidfloor:.01}}),f&&s.bids.push({bidder:"pubmatic",params:{publisherId:"157856",adSlot:f,kadfloor:".01"}}),e&&s.bids.push({bidder:"sortable",params:{tagId:e,floor:.01}}),o&&s.bids.push({bidder:"sovrn",params:{tagid:o,bidfloor:.01}}),s},pbjs=pbjs||{};pbjs.que=pbjs.que||[];pbjs.que.push(function(){pbjs.setConfig({bidderTimeout:900,priceGranularity:{buckets:[{min:0,max:3,increment:.01},{min:3,max:8,increment:.05},{min:8,max:10,increment:.1},{min:10,max:20,increment:.5},{min:20,max:30,increment:1}]},sortable:{siteId:'lotterypost.com'},userSync:{filterSettings:{iframe:{bidders:'*',filter:'include'}},syncDelay:6000,syncsPerBidder:3}})});var pbSlots=[pbBds('AUHead',[[728,90]],'14442905','341167','332319712','LP_728x90','AUHead','594224'),pbBds('MasterAuLeft',[[120,600]],'14442905','341162','795217702','LP_120x600','MasterAuLeft','594228'),pbBds('LP_ctl05',[[300,250]],'14442905','341164','251633185','LP_300x250_Primary','LP_ctl05','594225'),pbBds('LP_ctl07',[[300,250]],'14442905','341164','251633185','LP_300x250_Secondary','LP_ctl07','594225'),pbBds('LP_FooterBlockAd',[[300,250]],'14442905','341164','251633185','LP_300x250_Primary','LP_FooterBlockAd','594225')];var apstag=apstag||{q:function(n,t){apstag._Q.push([n,t])},init:function(){apstag.q('i',arguments)},fetchBids:function(){apstag.q('f',arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};apstag.init({pubID:'c6915d94-7b34-4363-b9a6-c45dfdb5e581',adServer:'googletag',bidTimeout:900});var a9Slots=[{slotID:'AUHead',slotName:'/13070090/LP_728x90',sizes:[[728,90]]},{slotID:'MasterAuLeft',slotName:'/13070090/LP_120x600',sizes:[[120,600]]},{slotID:'LP_ctl05',slotName:'/13070090/LP_300x250_Primary',sizes:[[300,250]]},{slotID:'LP_ctl07',slotName:'/13070090/LP_300x250_Secondary',sizes:[[300,250]]},{slotID:'LP_FooterBlockAd',slotName:'/13070090/LP_300x250_Primary',sizes:[[300,250]]}];!function(n,t){function e(){for(var n in i)if(i[n])return!1;return!0}function u(n){r||(i[n]=!1,e()&&f())}function f(){r||window.aNotOK||(r=!0,googletag.cmd.push(function(){try{n&&apstag.setDisplayBids()}catch(i){}try{t&&pbjs.setTargetingForGPTAsync()}catch(i){}googletag.pubads().refresh()}))}function o(){t&&pbjs.que.push(function(){pbjs.addAdUnits(pbSlots);pbjs.requestBids({bidsBackHandler:function(){u("prebid")}})});n&&apstag.fetchBids({slots:a9Slots},function(){u("a9")})}var i={a9:n,prebid:t},r=!1;t||n?(o(),window.setTimeout(f,1500)):googletag.pubads().refresh()}(!0,!0);</script><script type="application/ld+json">{"@context":"https://schema.org/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.lotterypost.com/news/335225"},"description":"After 34 drawings without a jackpot winner, the multi-state Mega Millions lottery game now boasts a swelling jackpot of three-quarters of a billion dollars that could instantly put someone among the wealthiest people on the planet.","commentCount":"8","datePublished":"2021-01-13T08:01:57-05:00","dateModified":"2021-01-13T08:01:57-05:00","headline":"$750 MILLION: Second-largest Mega Millions jackpot in history to be drawn Friday","keywords":"lottery,Mega Millions,Jackpots,Multi-State Game","image":["https://lp.vg/images/newsicon_megamillions.jpg"],"thumbnailUrl":"https://lp.vg/images/newsicon_megamillions.jpg","dateline":"","author":{"@type":"Person","name":"Todd Northrop"},"isAccessibleForFree":true,"publisher":{"@type":"Organization","name":"Lottery Post","logo":{"@type":"ImageObject","url":"https://www.lotterypost.com/images/lp_icon_310.png"}}}</script><script>var _mNHandle=_mNHandle||{},medianet_versionId='3121199';_mNHandle.queue=_mNHandle.queue||[];</script><script async src="https://contextual.media.net/dmedianet.js?cid=8CU2OF2D5"></script><link rel="preload" href="https://lp.vg/js/ds01218.3/MwtGFZn69uAwUEBU1xQNAHR7FoSyGDVA6BzbcVg6aEZjnjKKk9Rrt8egtyaKSMzNkICrg4d5Ke3NoOtwS(DCOHQzmBP4wqL5veCYtyspv2G4oJ(GmxykoLR3upAk3jTVdPDBW3)eWVULWUdXqyPlPo5XO3Sw59KQ9KsazSqMcavoZum1EbsJt4aEoh8LduaYVHw1t4noRQqJbz0RYqRmuHkkUQy7qdpzIpr8K17s5RmjTbzMB8D)AW2)WxOiEiAyAev7/fT63e2l0(w57RziKWEWnZGXkx5o8VFdgMeuNDiNOb4)qsO4TyeuA21e4qbbDRZM(F2qtwXDiGHa9WmnFwMn6kGfgjLRINM4OOo3Ikjjz72wB6X3viQJ20GY56CC9Fn9LotbSuJY1gomZVvnl1J00jurMNYQV)RwODW4Kun2Ql7qMUAzUAa06AGgKY0EBuIVY2V5NiHZPTFaaFK1xP8DXFH6FCyE5bSZ60H)CF5I=" as="script" /><script>var LPPreInit={version:"01218.3",status:0};</script><link rel="stylesheet" href="https://lp.vg/css/ds01218.3/j2HKnp0oKDOVoos8SA3Bpy3UHd7cAufta4eroYaXMYvxFuRA8ykjub9LnljwiyZ(Ho5EV7u8sDx6g)gMvHadnHlvbESIYJ1X6oeAghqHEshdvvI473HCzerwIb2juyuPKT8OTLHfuZgKateNm4TWxrNbcJF76)WXsXrqF2gAZSoyrDeFDbyj)cFCwis69h3CboX1do29vAaXKGVNqtsflqVx01a7xcrL8RpkHHFsqZwRNwD5laTCXGja1s1WPvb)I8FZ/NKGS35HhGdM28kV5Z5BArPjXoC7jBHKu(ywMVDdSW31RbPFL7nbavW)JN4lnsVeZ6SHo3qzBtwDmsyvWIIloUgbndTtTYRlwZZBJuGexDcWMA5U9FEsCbk4DBndQKcff6AxqIT4jHSfQ3vP()YshYgvKBPArMotDFLaCbz1v)kJOSJ0utGisWCgaOB)M6SEccP8pUVoCdXt4qJuB19RmMR98Zj0NlODiPkrWKRo=" /><style>html,body,#pagewidth{min-width:968px;}</style><script async src="https://www.googletagmanager.com/gtm.js?id=GTM-D86W"></script><script>var dataLayer=dataLayer||[];dataLayer.push({"gtm.start":+new Date,event:"gtm.js"});</script></head><body data-id="19256086581"><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-D86W" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><form method="post" action="/news/335225?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+LotteryNews+%28Lottery+Post%3A+Latest+Lottery+News%29" id="MainForm"><div class="aspNetHidden"><input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="uU/Jmn0nLyKW5coo+LhYL4ZvGXPiHIdhla/nVJfU/TzfQHjZ2lYUoPNpYO4jMJ3NY3vH2t3aztqqBWdHXKnodE/uEfVG7UuA98PJhytmJaIwy9gBlZ3VRAnMVvgcwbJXx+Jv99zMbupLNW3FUU2DlXRRjgawxn/gZGHgF8fLt5OVXEmQGeVNvb7cqGKIPxvshVrqIIRD9JOl8R48ilWKlN6LLyoHpDzrAQKmiRL7v7T8X+/YWY3791PawDA8E1zrHpy63aXzDW822uF8wfITyFG6jMAryLJDw4P6usqeS2OIaL67V2KMr9L87LZ2grGy09SfLe8v/KeOYCRoFrllnw+yYlRPl1Ljww1ZGz/33hr0Y3Y84Uk2LiWRP2zCI6ltS7dPG+6pRaWTBx5AMrT5w7u5IcX2RMaJlRcRrfavk/bHhBN9ck6SpplxF8iGuhVNFZIWLNDlG53dpna7itZlkUbGgRfo1cnK0f7zKdCne2YOFjfqjUpNQq19yZT7WKrGsu6luNqXykQgr46V7S4lHI3s/7frob/vy4zRTCSADg84QOZBz3b3T3Isx1OCyOXw1QgCw55dC9OBUQjC2pYnNgyHrgiRkg+yFTsHtvMzMaQpFKhKQB95hoFTSJREcCxKKLnFnXtEKyYB62yGTuzGVT2HzdXc3hGqz9YuhCPYPfFNCyiKiqqFTihqhGRMwHM4Q/zGYt4gWfj1tVRyRa2jSk7U3GXmuwd/hNG7emH5DnJlap/wo7Vha2G3pMPRE7NxaI3USpp+0G5hgM/P1orMYfIBeBOSweRPqPRXJjnF+enmHsu6dMAZyotF/zHxt1YYiQi3VTPuDHcM2AQKuffBB8+WELEnte+hsPCfl8PvvESdSgsVMrtrZsxdSrD7+SroPhkBtd8hVQl0gsNE7LO7F8E7oK889VNX58IPjenvSu4eQfut0EiDkvdewhhLaeRTijoojFe/Na3KGC4UAZfky0VTaPGPsCfQxzCXVaglqrIHiXnrveV9ZRREhDy9Ok2Slv0NDLRY6exqvTRlZ35d2IDwn2beiNIWDSCgSyLIS4M2wBvOXGqHYYd/WCxXowwAyEQcGotqo0SBQEFI6lMYGP+0CJf3z5DuxS8E0l94TwhIx1jJxsP92ssd6FZpz6lcVXDCD7TT2YHZcSw1z8XatP9rpSgVnmReKW4PaOT7nS4/Ypur33LW4aO5syrGwB5kMkWQZ9NRWz9WKdmp/D6dpkhsjuLAO4hsa9qXEnVd0B9gI/DPtu1aDODzBPfz2hSkN5ABAI33luk2AcX8Gi5sB7fn8VbiCy66dYQoE+t+2kKapMEG33C3H8zI2sT+Jzqt4sZrKsQRfE/hwW6Cl493OfuaGNw7Z1iC2iIKZCkFJG2Gj5xaSKSMOoJWWfXo6KF5VIcBGCuLM9xdLHPRJTKJ+qZfb4rRGwQPVdZIar83zP+7/CEa8m5TtcAle1sDCSBO0hJXlsLt1cSTA3XJQyIOaiPfLF9qOiU2IZMn7S1t0ToXT18kHZZOgLp9Dxo/la+Wj/2gR4tIpoQITHR51w0uUW/WYPSnjZ7ugngrYAp/OxiIRB+ATSD0Ou+L+TE+CeaQTV5plq55d9z3pNh2Urax/Twfyk3Cq7ejDStMDENeRZrWttRnxEegUgTRfGcc3brLhsN4SUDlSQgKyHsIFkYtkHw669GAs09Tk4PsoF13G4GKa0jnFFARZj1nrSDjbkpGd1xXeIkUvJpth1KRWm1gv4o/o1b8XtPJTCC24Ni5rmPq94MEPcyRnMVALHaAQzKbxl2zWmBUEQqsJ7Z7jWWLTxpaMpUSnssgep0pUADjT7YEQxJmWdADUmhcYKhao8UwOpZWSWfRgLS2oXFEiEZt/S3VISLPcpH5nsqYHyJ5j1Z2m57LEXOjegF13KfvikjdMObDQyLUv5MfLmRPe9EUbViXgxS4wC/DyllfEmXxrZ8YQaH1TFY6w9Otr4l910SZGyU3prRxFjurQ8I1I9CZton/HphfNCdTdaCSTC9KuzMbIap0nHp61jpfWo4j59Xlp8UMOY/FhL/EoQtWChbtIHMipKfBqYJJIJIQLZmuatTLjkdcjpQKKParuNcesPHqPwAC1tp1DpbVCsflOXOP+V8fZxtNswuqP4tXFk9ALgRU0a+zYsZxA4xw1Tg5bO5mv0V3/mIQJbzapHZ8TyRUriX/v8MbqDCIrc8HmhF3GIdGD7F8BEz5/YN7H082xOlDlq7F5/YuWcCfDX3T3jtQtBcyy4+zhvh7aeMQ5CUy0fD5VwbUU/CsFQoio409zw1H" /></div><div id="header"><div id="headerContent"><a class="logo" href="/"><img id="LPLogo" src="https://lp.vg/images/lp_logo.png" srcset="https://lp.vg/images/lp_logo-1.5x.png 1.5x,https://lp.vg/images/lp_logo-2x.png 2x,https://lp.vg/images/lp_logo-3x.png 3x,https://lp.vg/images/lp_logo-4x.png 4x" width="220" height="80" alt="Lottery Post" /></a><div id="AUHead" class="AU AUStandard AUSize728x90" style="width:728px;height:90px"><script>googletag.cmd.push(function(){googletag.display('AUHead')})</script></div></div></div><div id="pagewidth"><div id="loginblock"><div id="bcSearch">&nbsp;</div><strong>Welcome&nbsp;Guest</strong><img src="/b.gif" alt="" /><br /> (&nbsp;<a title="Log in to your Lottery Post membership." href="/login">Log In</a> | <a title="Sign up for a free Lottery Post membership." href="/register">Register</a>&nbsp;) </div><table id="mainframework" border="0" cellspacing="10" cellpadding="0"><tr><td id="mainframeworkleft"><div id="leftnav" class="pod withtitle"><p class="title">Quick Links</p><ul><li><a title="Lottery Post Home Page" href="/">Home</a></li><li class="lnBig"><a class="icon-memberships" title="Compare features between Lottery Post memberships" href="/memberships">Premium Memberships</a></li><li><a title="Go to the main forums page, see description of each forum" href="/forums">Forums</a></li><li><a title="Go to the Predictions main page" href="/predictions">Predictions</a></li><li><a title="View all lottery news stories, one month at a time" href="/news">News</a></li><li><a title="Go to the Lottery Results main page" href="/results">Lottery Results</a></li><li><a title="The world&#39;s most powerful lottery results search engine" href="/results/search">Search Drawings</a></li><li><a title="All the lottery systems and methods available at Lottery Post" href="/systems">Lottery Systems</a></li><li><a title="Lottery charts and data tables for Pick 3, Pick 4, and Quinto" href="/charts">Lottery Charts</a></li><li><a title="The world&#39;s best Full, Key, and Abbreviated lottery wheels, including custom (filtered) wheels" href="/wheels">Lottery Wheels</a></li><li><a title="Sorted listing of current worldwide jackpots" href="/jackpots">Worldwide Jackpots</a></li><li><a title="Generate random numbers (&quot;Quick Picks&quot;) for any lottery game" href="/quickpicks">Quick Picks</a></li><li><a title="View historical events at Lottery Post and around the world that happened on today's date" href="/onthisday">On This Day in History</a></li><li><a title="See the blogs (personal web journals) of all Lottery Post members" href="/blogs">Blogs</a></li><li><a title="Play Lottery Post&#39;s online games" href="/games">Online Games</a></li><li><a title="Contact the Lottery Post staff by e-mail" href="/contact">Contact Us</a></li><li><a title="Support Lottery Post by whitelisting lotterypost.com in your ad blocker" href="/whitelist">Whitelist Lottery Post</a></li><li><a title="View the Lottery Post forum rules" href="/rules">Rules</a></li><li class="lnBig"><a class="icon-books" title="Large selection of lottery books" href="/books">Lottery Book Store</a></li><li class="lnBig"><a class="icon-gift" title="Lottery Post Gift Shop" href="http://www.cafepress.com/lotterypost/">Lottery Post Gift Shop</a></li><li class="lnBig"><a class="icon-facebook" title="Lottery Post Facebook page" href="https://www.facebook.com/LotteryPost">Visit us on Facebook</a></li><li class="lnBig"><a class="icon-twitter" title="Lottery Post Twitter page" href="https://www.twitter.com/lotterypost">Follow us on Twitter</a></li><li class="lnBig"><a class="icon-youtube" title="Lottery Post YouTube page" href="https://www.youtube.com/lotterypost">Subscribe on YouTube</a></li></ul><a title="Powerball and Mega Millions lottery results and news" href="https://www.usamega.com/"><img src="https://lp.vg/images/usa-mega-button-2.png" class="usamega" width="140" height="97" alt="USA Mega" /></a><a class="tile140" title="Lottery Places free app for iPhone, Android, and Windows" href="https://www.lotteryplaces.com/"><img src="https://lp.vg/images/LotteryPlaces_140x375.jpg" srcset="https://lp.vg/images/LotteryPlaces_140x375_1.5x.jpg 1.5x,https://lp.vg/images/LotteryPlaces_140x375_2x.jpg 2x" width="140" height="375" alt="Lottery Places" /></a><div id="MasterAuLeft" class="masterAuLeft AU AUStandard AUSize120x600" style="width:120px;height:600px"><script>googletag.cmd.push(function(){googletag.display('MasterAuLeft')})</script></div><div id="AmazonAu"><div id="amazonAu"><a href="https://amzn.to/2xkCMe0" class="amazonLogo whiteglass" rel="external nofollow noopener"><ins></ins></a><div class="amazonContent"><a href="https://amzn.to/2wFWSCe" title="Lottery Post 2012 Lottery Results Almanac, United States Edition" rel="external noopener"><img src="https://lp.vg/images/amazon/Results2012-US-FrontCover-57x72.jpg" srcset="https://lp.vg/images/amazon/Results2012-US-FrontCover-57x72-1.5x.jpg 1.5x,https://lp.vg/images/amazon/Results2012-US-FrontCover-57x72-2x.jpg 2x" class="amazonBookIcon" width="57" height="72" alt="Lottery Post 2012 Lottery Results Almanac, United States Edition" /></a><a href="https://amzn.to/2wFWSCe" title="Lottery Post 2012 Lottery Results Almanac, United States Edition" rel="external noopener">2012 Lottery Results Almanac, USA Edition</a><br />by Todd Northrop</div><div class="amazonGoStore"><a id="" href="/books" class="CB CB-Box amazonGoStoreButton"><span>More lottery books</span></a></div></div></div><ul class="tinylist"><li><a title="Online JavaScript Compressor, featuring YUI Compressor and Microsoft Ajax Minifier" href="/js-compress.aspx">JavaScript Compressor</a></li><li><a title="Online CSS Compressor" href="/css-compress.aspx">CSS Compressor</a></li><li><a title="MyBrowserInfo.com" onclick="this.target=&#39;_blank&#39;;" rel="noopener" href="https://mybrowserinfo.com/">Browser Information</a></li></ul></div><div id="LastVisitPanel" class="leftnavbox pod"><div class="minortextwrapper">You&nbsp;last&nbsp;visited January&nbsp;13,&nbsp;2021, 10:36&nbsp;am</div></div><div class="leftnavbox pod"><div class="minortextwrapper"> All times shown are<br />Eastern Time (GMT-5:00) <div class="smallFootNote"><a title="Update your time zone" rel="nofollow" href="/control_account.asp">Update your time zone</a></div></div></div></td><td id="mainframeworkbody"><div id="breadcrumb" class="clr"><div id="bcLike" class="pageShare"><label>Recommend<br />Lottery Post</label><div><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.lotterypost.com%2F" rel="external noopener"><img src="https://lp.vg/images/facebook-share.png" width="60" height="20" alt="Recommend Lottery Post on Facebook"/></a></div></div><script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":{"@type":"Thing","@id":"https://www.lotterypost.com/"}},{"@type":"ListItem","position":2,"name":"Forums","item":{"@type":"Thing","@id":"https://www.lotterypost.com/forums"}},{"@type":"ListItem","position":3,"name":"Lottery News","item":{"@type":"Thing","@id":"https://www.lotterypost.com/forum/11"}},{"@type":"ListItem","position":4,"name":"$750 MILLION: Second-largest Mega Millions jackpot in history to be drawn Friday","item":{"@type":"Thing","@id":"https://www.lotterypost.com/news/335225"}}]}</script><ol><li><a href="/" title="Lottery Post Home Page">Home</a></li>&nbsp;&rsaquo; <li><a href="/forums" title="Forums">Forums</a></li>&nbsp;&rsaquo; <li><a href="/forum/11" title="Lottery News">Lottery News</a></li>&nbsp;&rsaquo; <li title="$750 MILLION: Second-largest Mega Millions jackpot in history to be drawn Friday">$750 MILLION: Second-largest Mega Millions jackpot in history to be drawn Friday</li></ol></div><div id="LP_NewsStory" class="newsstorywrapper"><div class="newsstory"><h1 id="LP_NewsHeadline" class="headline">$750&nbsp;MILLION: Second-largest Mega Millions jackpot in history to be drawn Friday</h1><div class="maincol"><div class="newsbyline"><p id="LP_NewsByline" class="publishdate">Jan 13, 2021, 8:01 am</p><p id="LP_NewsComments" class="newscommentslink"><a id="LP_ctl13" href="javascript:;" title="Scroll down to comments" class="CB" data-sprite="say" data-click="$.scrollTo('#newsEnd',{offset:{top:-10}});return false;"><span>8 comments</span></a></p></div><div id="LP_NewsShare" class="pageShare"><label>Recommend This</label><div><a href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fwww.lotterypost.com%2fnews%2f335225" rel="external noopener"><img src="https://lp.vg/images/facebook-share.png" width="60" height="20" alt="Share this news story on Facebook"/></a></div><div><a href="https://twitter.com/share?url=https%3a%2f%2fwww.lotterypost.com%2fnews%2f335225&text=%24750+MILLION%3a+Second-largest+Mega+Millions+jackpot+in+history+to+be+drawn+Friday&via=LotteryPost" rel="external noopener"><img src="https://lp.vg/images/twitter-tweet.png" width="60" height="20" alt="Tweet this news story on Twitter"/></a></div></div><div id="newsbody"><div id="newsQuickOptions"><img id="LP_NewsIcon" src="/images/newsicon_megamillions_335225.jpg" width="140" height="100" class="newsphoto" alt="Mega Millions" title="Mega Millions: $750 MILLION: Second-largest Mega Millions jackpot in history to be drawn Friday" /><small id="LP_NewsIconCaption">Mega Millions: $750 MILLION: Second-largest Mega Millions jackpot in history to be drawn Friday</small><ul style="margin: 10px 0 0;padding: 0;list-style-type:none;"><li><a id="LP_NewsEmail" href="/e-mail_topic.asp?tp=335225" title="E-mail this story to a friend" class="CB" data-sprite="mail" data-newwindow="1"><span>E-mail to a friend</span></a></li><li><a id="LP_NewsPrint" href="/print-topic.asp?tp=335225" title="Open a plain version of this news story that is better for printing" class="CB" data-sprite="print" data-newwindow="1"><span>Printer-friendly</span></a></li><li><a id="LP_NewsLink" href="javascript:;" title="Display the permanent link (&quot;permalink&quot;) to this news story" class="CB" data-sprite="link" data-click="return ThreadPage.showPermaLink('https://www.lotterypost.com/news/335225','%24750+MILLION%3a+Second-largest+Mega+Millions+jackpot+in+history+to+be+drawn+Friday',this);"><span>Link to this story</span></a></li></ul><span class="ratethis">Rating:</span><span id="rating335225"></span></div><div id="LP_NewsContent"><p><span style="font-size: 16px; font-family: Arial, Helvetica, FreeSans, sans-serif;"><strong>Cash value worth more than a half-billion dollars</strong></span></p><p><span style="font-size: 10px;" data-mce-mark="1">By Todd Northrop</span></p><p>After 34 drawings without a jackpot winner, the multi-state Mega Millions lottery game now boasts a swelling jackpot of three-quarters of a billion dollars that could instantly put someone among the wealthiest people on the planet.</p><p>When nobody won Tuesday night's grand prize, the Mega Millions jackpot grew to an estimated $750&nbsp;million&nbsp;&mdash; the largest since <span>a $1.5&nbsp;billion Mega Millions jackpot from an Oct. 2018 drawing was <a href="/news/325813" rel="external noopener noopener">claimed anonymously</a> by a South Carolina player.</span></p><p><span>The next Mega Millions drawing is on Friday night at 11:00 pm Eastern Time (8:00 pm Pacific).</span></p><p>Tuesday's $750&nbsp;million Mega Millions jackpot is the 2nd-largest in the game's history, and the 5th-largest United States lottery jackpot of all time (see full list below).</p><p>The lump-sum cash value of $550.6&nbsp;million is the 3rd-largest on the all-time US lottery jackpot cash value list.</p><p>The current jackpot run-up started on Sept.&nbsp;18 as a $20&nbsp;million grand prize&nbsp;&mdash; it has been 4 months since Mega Millions has had a jackpot winner.</p><p>Lottery players wondering what all the cash will look like in their bank account after federal and state taxes are taken out can see an after-tax analysis of the current Mega Millions jackpot by visiting USA Mega's <a href="https://www.usamega.com/mega-millions/jackpot/2021/1/15" rel="external noopener noopener">Jackpot Analysis</a> page.</p><p>The rush of ticket sales over the next few days likely will propel the jackpot to an even higher amount before the drawing takes place Friday. Lottery Post and USA Mega will update the jackpot tallies displayed if such an increase occurs.</p><p>In Tuesday night's Mega Millions drawing, there was no jackpot winner, but 9 lucky players matched the first 5 numbers for a $1,000,000 prize: 1 from California, 2 from Florida, 1 from Georgia, 1 from Illinois, 1 from Missouri, 1 from New Jersey, 1 from Texas, and 1 from Washington.</p><p>One of the second-prize winners from Florida purchased their ticket with the Megaplier option for an extra $1 per play, increasing their prize to $2&nbsp;million because the Megaplier number drawn was&nbsp;2.</p><p>The Megaplier option is not available in California, because the fixed nature of the prize increase offered with the Megaplier is not compatible with California's pari-mutuel payouts. By law, California awards all lottery prizes on a pari-mutuel basis, meaning the prizes will change each drawing based on the number of tickets sold and the number of tickets that won at each prize level.</p><p>Also, a total of 116 tickets matched four of the first five numbers plus the Mega Ball to win a $10,000 prize. Of those tickets, 20 were purchased with the Megaplier option, increasing the prize to $20,000, and 15 were sold in California, where the prize awarded this drawing is $8,558.</p><p>The Mega Millions winning numbers for Tuesday, January&nbsp;12,&nbsp;2021, were 12, 14, 26, 28, and 33, with Mega Ball number&nbsp;9. The Megaplier number was&nbsp;2.</p><p>The complete payout information and official drawing video for Tuesday's drawing can be found at USA Mega's <a href="https://www.usamega.com/mega-millions/drawing/2021/1/12" rel="external noopener noopener">Mega Millions Drawing Information</a> page.</p><p>Following the Tuesday drawing, the Mega Millions annuity jackpot estimate was raised $125&nbsp;million from its previous amount of $625&nbsp;million. The cash value was raised by $91.8&nbsp;million from its previous amount of $458.8&nbsp;million.</p><p>Mega Millions tickets cost $2 each. For an extra $1 per ticket players can purchase the Megaplier option, which multiplies any non-jackpot won by up to 5 times, depending on the Megaplier number drawn that evening.</p><p>Mega Millions is currently offered for sale in 45 states, plus Washington, D.C. and the U.S. Virgin Islands. Drawings are Tuesdays and Fridays at 11:00 pm Eastern Time.</p><p>To find the nearest lottery retailer to buy your tickets, head over to the <a href="https://www.lotteryplaces.com/" rel="external noopener noopener">Lottery Places</a> website to download the free app on your iOS or Android phone or Windows computer. Lottery Places is the only app on the market that will locate lottery retailers in every state and jurisdiction throughout the United States.</p><p><span>Some states offer direct online sales too.&nbsp; Michigan residents can bypass the store completely and</span> <a href="/partner/michigan_megamillions" rel="external noopener noopener">buy Mega Millions tickets</a> and <a href="/partner/michigan_powerball" rel="external noopener noopener">Powerball tickets</a> online.&nbsp; Texas residents can buy <a href="/partner/texas_megamillions" rel="external noopener noopener">Mega Millions tickets</a> and <a href="/partner/texas_powerball" rel="external noopener noopener">Powerball tickets</a> online too.&nbsp; Oregon residents have options to buy <a href="/partner/texas_megamillions" rel="external noopener noopener">Mega Millions tickets</a> and <a href="/partner/texas_powerball" rel="external noopener noopener">Powerball tickets</a> online as well.&nbsp; Note that some of these links will only work properly for residents of the states mentioned.</p><p>Players outside the USA can use a <a href="/partner/45" rel="external noopener noopener">reputable butler service</a> to buy their Mega Millions tickets.</p><p>Mega Millions lottery results are published within minutes of the drawing at USA Mega (<a href="https://www.usamega.com/" rel="external noopener noopener">www.usamega.com</a>).&nbsp; The USA Mega Web site provides lottery players in-depth information about the United States's two biggest multi-state lottery games, Mega Millions and Mega Millions.</p><p><strong>Top&nbsp;25 United States lottery jackpots of all time</strong></p><p>Friday's Mega Millions jackpot currently stands as the 5th-largest lottery jackpot of all time in the United States, and the 2nd-largest Mega Millions jackpot ever.&nbsp; Brisk sales will likely push the jackpot estimate higher by draw time.</p><p>If nobody wins Tuesday, it's anyone's guess how high it will go.</p><ol style="text-align: left;"><li>Powerball: $1.5864&nbsp;billion, Jan.&nbsp;13,&nbsp;2016 (19&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- California, Florida, Tennessee</li><li>Mega Millions: $1.537&nbsp;billion, Oct.&nbsp;23,&nbsp;2018 (25&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- South Carolina</li><li>Powerball: $768.4&nbsp;million, Mar.&nbsp;27,&nbsp;2019 (25&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- Wisconsin</li><li>Powerball: $758.7&nbsp;million, Aug.&nbsp;23,&nbsp;2017 (20&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- Massachusetts</li><li style="font-weight: bold;">Mega Millions: $750&nbsp;million, Jan.&nbsp;15,&nbsp;2021 (34&nbsp;rollovers, starting at $20&nbsp;million)&nbsp;- Preliminary estimate, not won yet</li><li>Powerball: $687.8&nbsp;million, Oct.&nbsp;27,&nbsp;2018 (21&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- Iowa, New&nbsp;York</li><li>Mega Millions: $656&nbsp;million, Mar.&nbsp;30,&nbsp;2012 (18&nbsp;rollovers, starting at $12&nbsp;million)&nbsp;- Illinois, Kansas, Maryland</li><li>Mega Millions: $636&nbsp;million, Dec.&nbsp;17,&nbsp;2013 (21&nbsp;rollovers, starting at $12&nbsp;million)&nbsp;- California, Georgia</li><li>Powerball: $590.5&nbsp;million, May&nbsp;18,&nbsp;2013 (13&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- Florida</li><li>Powerball: $587.5&nbsp;million, Nov.&nbsp;28,&nbsp;2012 (15&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- Arizona, Missouri</li><li>Powerball: $564.1&nbsp;million, Feb.&nbsp;11,&nbsp;2015 (20&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- North&nbsp;Carolina, Puerto&nbsp;Rico, Texas</li><li>Powerball: $559.7&nbsp;million, Jan.&nbsp;6,&nbsp;2018 (20&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- New&nbsp;Hampshire</li><li style="font-weight: bold;">Powerball: $550&nbsp;million, Jan.&nbsp;13,&nbsp;2021 (33&nbsp;rollovers, starting at $20&nbsp;million)&nbsp;- Preliminary estimate, not won yet</li><li>Mega Millions: $543&nbsp;million, Jul.&nbsp;24,&nbsp;2018 (22&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- California</li><li>Mega Millions: $536&nbsp;million, Jul.&nbsp;8,&nbsp;2016 (34&nbsp;rollovers, starting at $15&nbsp;million)&nbsp;- Indiana</li><li>Mega Millions: $533&nbsp;million, Mar.&nbsp;30,&nbsp;2018 (23&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- New Jersey</li><li>Mega Millions: $522&nbsp;million, Jun.&nbsp;7,&nbsp;2019 (24&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- California</li><li>Powerball: $487&nbsp;million, Jul.&nbsp;30,&nbsp;2016 (23&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- New&nbsp;Hampshire</li><li>Powerball: $456.7&nbsp;million, Mar.&nbsp;17,&nbsp;2018 (19&nbsp;rollovers, starting at $15&nbsp;million)&nbsp;- Pennsylvania</li><li>Mega Millions: $451&nbsp;million, Jan.&nbsp;5,&nbsp;2018 (23&nbsp;rollovers, starting at $15&nbsp;million)&nbsp;- Florida</li><li>Powerball: $448.4&nbsp;million, Aug.&nbsp;7,&nbsp;2013 (12&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- Minnesota, New&nbsp;Jersey&nbsp;(2)</li><li>Powerball: $447.8&nbsp;million, Jun.&nbsp;10,&nbsp;2017 (19&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- California</li><li>Powerball: $435.3&nbsp;million, Feb.&nbsp;22,&nbsp;2017 (18&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- Indiana</li><li>Powerball: $429.6&nbsp;million, May&nbsp;7,&nbsp;2016 (18&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- New Jersey</li><li>Powerball: $425.3&nbsp;million, Feb.&nbsp;19,&nbsp;2014 (15&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- California</li></ol><p>For those keeping score, the number of jackpots in the top 25, by lottery game, are:</p><ul><li>Powerball: 16</li><li>Mega Millions: 9</li></ul><p><strong>Top 25 cash value jackpots</strong></p><p>Since many lottery winners collect their winnings in cash, the lump-sum payout is an important measure of what a winning ticket could be worth.</p><p>Looking at the cash value, the upcoming Mega Millions jackpot ranks as the 6th-largest cash value in U.S. history.</p><ol style="text-align: left;"><li>Powerball: $983.5&nbsp;million cash, Jan.&nbsp;13,&nbsp;2016 ($1.5864&nbsp;billion&nbsp;annuity)&nbsp;- California, Florida, Tennessee</li><li>Mega Millions: $877.8&nbsp;million cash, Oct.&nbsp;23,&nbsp;2018 ($1.537&nbsp;billion&nbsp;annuity)&nbsp;- South Carolina</li><li style="font-weight: bold;">Mega Millions: $550.6&nbsp;million cash, Jan.&nbsp;15,&nbsp;2021 ($750&nbsp;million&nbsp;annuity)&nbsp;- Preliminary estimate, not won yet</li><li>Powerball: $480.5&nbsp;million cash, Aug.&nbsp;23,&nbsp;2017 ($758.7&nbsp;million&nbsp;annuity)&nbsp;- Massachusetts</li><li>Powerball: $476.9&nbsp;million cash, Mar.&nbsp;27,&nbsp;2019 ($768.4&nbsp;million&nbsp;annuity)&nbsp;- Wisconsin</li><li>Mega Millions: $471&nbsp;million cash, Mar.&nbsp;30,&nbsp;2012 ($656&nbsp;million&nbsp;annuity)&nbsp;- Illinois, Kansas, Maryland</li><li style="font-weight: bold;">Powerball: $411.4&nbsp;million cash, Jan.&nbsp;13,&nbsp;2021 ($550&nbsp;million&nbsp;annuity)&nbsp;- Preliminary estimate, not won yet</li><li>Powerball: $396.2&nbsp;million cash, Oct.&nbsp;27,&nbsp;2018 ($687.8&nbsp;million&nbsp;annuity)&nbsp;- Iowa, New&nbsp;York</li><li>Powerball: $384.7&nbsp;million cash, Nov.&nbsp;28,&nbsp;2012 ($587.5&nbsp;million&nbsp;annuity)&nbsp;- Arizona, Missouri</li><li>Powerball: $381.1&nbsp;million cash, Feb.&nbsp;11,&nbsp;2015 ($564.1&nbsp;million&nbsp;annuity)&nbsp;- North&nbsp;Carolina, Puerto&nbsp;Rico, Texas</li><li>Mega Millions: $378&nbsp;million cash, Jul.&nbsp;8,&nbsp;2016 ($536&nbsp;million&nbsp;annuity)&nbsp;- Indiana</li><li>Powerball: $370.9&nbsp;million cash, May&nbsp;18,&nbsp;2013 ($590.5&nbsp;million&nbsp;annuity)&nbsp;- Florida</li><li>Powerball: $352&nbsp;million cash, Jan.&nbsp;6,&nbsp;2018 ($559.7&nbsp;million&nbsp;annuity)&nbsp;- New&nbsp;Hampshire</li><li>Mega Millions: $347.6&nbsp;million cash, Dec.&nbsp;17,&nbsp;2013 ($636&nbsp;million&nbsp;annuity)&nbsp;- California, Georgia</li><li>Mega Millions: $340&nbsp;million cash, Jun.&nbsp;7,&nbsp;2019 ($522&nbsp;million&nbsp;annuity)&nbsp;- California</li><li>Powerball: $336.8&nbsp;million cash, Jul.&nbsp;30,&nbsp;2016 ($487&nbsp;million&nbsp;annuity)&nbsp;- New&nbsp;Hampshire</li><li>Mega Millions: $324&nbsp;million cash, Mar.&nbsp;30,&nbsp;2018 ($533&nbsp;million&nbsp;annuity)&nbsp;- New Jersey</li><li>Mega Millions: $320.5&nbsp;million cash, Jul.&nbsp;24,&nbsp;2018 ($543&nbsp;million&nbsp;annuity)&nbsp;- California</li><li>Mega Millions: $319.9&nbsp;million cash, Jun.&nbsp;9,&nbsp;2020 ($414&nbsp;million&nbsp;annuity)&nbsp;- Arizona</li><li>Powerball: $284&nbsp;million cash, May&nbsp;7,&nbsp;2016 ($429.6&nbsp;million&nbsp;annuity)&nbsp;- New&nbsp;Jersey</li><li>Mega Millions: $281.9&nbsp;million cash, Jan.&nbsp;5,&nbsp;2018 ($451&nbsp;million&nbsp;annuity)&nbsp;- Florida</li><li>Powerball: $279.1&nbsp;million cash, Jun.&nbsp;10,&nbsp;2017 ($447.8&nbsp;million&nbsp;annuity)&nbsp;- California</li><li>Powerball: $276.5&nbsp;million cash, Jan.&nbsp;29,&nbsp;2020 ($396.9&nbsp;million&nbsp;annuity)&nbsp;- Florida</li><li>Powerball: $273.9&nbsp;million cash, Mar.&nbsp;17,&nbsp;2018 ($456.7&nbsp;million&nbsp;annuity)&nbsp;- Pennsylvania</li><li>Powerball: $263.5&nbsp;million cash, Feb.&nbsp;22,&nbsp;2017 ($435.3&nbsp;million&nbsp;annuity)&nbsp;- Indiana</li></ol><p>The number of cash value jackpots in the top 25, by lottery game, are:</p><ul><li>Powerball: 15</li><li>Mega Millions: 10</li></ul></div></div><div id="LP_AfterNewsBody" class="clr"></div><div id="LP_RelatedLinks" class="newsbox newslinks"><p style="clear: both;font: bold 16px Arial,Helvetica,sans-serif;">Related Links</p><ul class="newslinklist"><li><ins class="sprite-16 sprite-link-ext-16"></ins><a href="https://www.usamega.com/" title="USA Mega - Home of Powerball and Mega Millions">USA Mega - Home of Powerball and Mega Millions</a></li><li><ins class="sprite-16 sprite-link-ext-16"></ins><a href="https://www.lotterypost.com/partner/45" title="Play Mega Millions online">Play Mega Millions online</a></li><li><ins class="sprite-16 sprite-link-ext-16"></ins><a href="https://www.lotterypost.com/partner/michigan_megamillions" title="Buy official Mega Millions tickets from the Michigan Lottery">Buy official Mega Millions tickets from the Michigan Lottery</a></li></ul></div><p id="LP_NewsSource" class="newssource"><ins class="sprite-16 sprite-world-16"></ins>Lottery Post Staff</p><div id="268110983"><script>_mNHandle.queue.push(function(){_mNDetails.loadTag('268110983','750x200','268110983')});</script></div><p id="LP_NewsFoot" class="newsFootOptions"><strong><ins class="sprite-32 sprite-say-32"></ins>We'd love to see your comments here!&nbsp; <a title="Sign up for a free Lottery Post membership." href="/register">Register for a FREE membership</a>&nbsp;&mdash; it takes just a few moments&nbsp;&mdash; and you'll be able to post comments here and on any of our forums. <span></span>If you're already a member, you can <a title="Log in to your Lottery Post membership." href="/login">Log In</a> to post a comment.</strong></p></div><div class="sidebar"><div class="nextprevstory"></div><div id="fontChanger" class="newsbox clr"><div class="choices styles"><label>Style:</label><ul><li><a id="fontStyle0" style="font-family:Arial,Helvetica,sans-serif;" onclick="return NewsPage?NewsPage.setFontStyle(0):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'style','Narrow');}" href="javascript:;"><span>A</span></a></li><li><a id="fontStyle1" style="font-family:Verdana,Geneva,sans-serif;" onclick="return NewsPage?NewsPage.setFontStyle(1):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'style','Normal');}" href="javascript:;"><span>A</span></a></li><li><a id="fontStyle2" style="font-family:Georgia,'Times New Roman',Times,serif;" onclick="return NewsPage?NewsPage.setFontStyle(2):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'style','Newsprint');}" href="javascript:;"><span>A</span></a></li></ul></div><div class="choices sizes" style="position:relative;"><label>Size:</label><ul><li><a id="fontSize0" style="font-size:8px;" onclick="return NewsPage?NewsPage.setFontSize(0):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'size','Small');}" href="javascript:;"><span>A</span></a></li><li><a id="fontSize1" style="font-size:11px;" onclick="return NewsPage?NewsPage.setFontSize(1):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'size','Normal');}" href="javascript:;"><span>A</span></a></li><li><a id="fontSize2" style="font-size:14px;" onclick="return NewsPage?NewsPage.setFontSize(2):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'size','Large');}" href="javascript:;"><span>A</span></a></li></ul></div></div><div id="LP_ctl05" class="newsSideAd AU AUStandard AUSize300x250" style="width:300px;height:250px"><script>googletag.cmd.push(function(){googletag.display('LP_ctl05')})</script></div><div id="LP_RelatedStories" class="sidebox relatedstories"><h1>Related Stories</h1><ul><li><a id="LP_RelatedStoryList_ctl00_0" href="/news/335210" title="Related story: Mega Millions ticket-buying frenzy forces new jackpot estimate" class="CB" data-sprite="news"><span style="white-space:normal;">Mega Millions ticket-buying frenzy forces new jackpot estimate <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Yesterday</span></span></a></li><li><a id="LP_RelatedStoryList_ctl00_1" href="/news/335199" title="Related story: Flurry of Mega Millions lottery sales prompts officials to raise jackpot estimate" class="CB" data-sprite="news"><span style="white-space:normal;">Flurry of Mega Millions lottery sales prompts officials to raise jackpot estimate <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Jan&nbsp;11,&nbsp;2021</span></span></a></li><li><a id="LP_RelatedStoryList_ctl00_2" href="/news/335168" title="Related story: $600 MILLION: Mega Millions jackpot soars after no winner Friday" class="CB" data-sprite="news"><span style="white-space:normal;">$600 MILLION: Mega Millions jackpot soars after no winner Friday <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Jan&nbsp;9,&nbsp;2021</span></span></a></li><li><a id="LP_RelatedStoryList_ctl00_3" href="/news/335154" title="Related story: Mega Millions lottery jackpot increased to $520 million on strong sales" class="CB" data-sprite="news"><span style="white-space:normal;">Mega Millions lottery jackpot increased to $520 million on strong sales <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Jan&nbsp;8,&nbsp;2021</span></span></a></li><li><a id="LP_RelatedStoryList_ctl00_4" href="/news/335117" title="Related story: Mega Millions lottery jackpot raised to $447 million on strong sales" class="CB" data-sprite="news"><span style="white-space:normal;">Mega Millions lottery jackpot raised to $447 million on strong sales <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Jan&nbsp;5,&nbsp;2021</span></span></a></li></ul></div><div id="LP_StoryTags" class="newsbox tags"><h1 class="tags"><ins class="sprite-24 sprite-globe-checklist-24"></ins>Tags for this news story</h1><ul class="tags"><li><a title="Jackpots" rel="tag" href="/tag/jackpots" style="font-size:22px;">Jackpots</a></li>&#32; <li><a title="Mega Millions" rel="tag" href="/tag/mega_millions" style="font-size:18px;">Mega Millions</a></li>&#32; <li><a title="Multi-State Game" rel="tag" href="/tag/multi-state_game" style="font-size:19px;">Multi-State Game</a></li>&#32; </ul><h2>Other Popular Tags</h2><ul class="tags clr"><li><a title="Administration" href="/tag/administration" style="font-size:13px;">Administration</a></li>&#32; <li><a title="Crime" href="/tag/crime" style="font-size:13px;">Crime</a></li>&#32; <li><a title="Financials" href="/tag/financials" style="font-size:14px;">Financials</a></li>&#32; <li><a title="Insider Buzz" href="/tag/insider_buzz" style="font-size:14px;">Insider Buzz</a></li>&#32; <li><a title="Legal" href="/tag/legal" style="font-size:14px;">Legal</a></li>&#32; <li><a title="Legislation" href="/tag/legislation" style="font-size:13px;">Legislation</a></li>&#32; <li><a title="Powerball" href="/tag/powerball" style="font-size:15px;">Powerball</a></li>&#32; <li><a title="Scratch Games" href="/tag/scratch_games" style="font-size:14px;">Scratch Games</a></li>&#32; <li><a title="Winner Stories" href="/tag/winner_stories" style="font-size:18px;">Winner Stories</a></li>&#32; <li><a title="Winning Ticket Announcement" href="/tag/winning_ticket_announcement" style="font-size:14px;">Winning Ticket Announcement</a></li>&#32; <li style="float:right; margin:5px 0 0 10px;"><a title="Display all news story tags (the &quot;Tag Cloud&quot;)" href="/tags" style="font-size:14px;">More &raquo;</a></li></ul></div><div id="LP_ctl07" class="AU AUStandard AUSize300x250" style="width:300px;height:250px"><script>googletag.cmd.push(function(){googletag.display('LP_ctl07')})</script></div></div></div></div><div id="newsEnd"><span id="LP_NewsCommentsDesc" class="commentsDesc">8 comments. Last comment 8 minutes ago by <a href="/member/138458" data-member="138458" class="popmenu platinum">noise-gate</a>.</span><div class="pagerlayout pagerlayoutinline"><table border="0" cellspacing="0" cellpadding="0"><tr><td><span style="margin-right:8px;">Page <strong>1</strong> of <strong>1</strong></span></td><td><div id="LP_PagerNews" class="pagercontrol sprite-pager sprite-pager-ddd"></div></td></tr></table></div></div><div id="message" class="pod withtitle fortext clr"><div class="titlelinks"><a id="LP_PreviousTopic" href="javascript:__doPostBack(&#39;ctl00$LP$PreviousTopic&#39;,&#39;&#39;)" title="Previous Topic" class="CB" data-sprite="back"><span>Previous Topic</span></a><a id="LP_NextTopic" href="javascript:__doPostBack(&#39;ctl00$LP$NextTopic&#39;,&#39;&#39;)" title="Next Topic" class="CB CB-ImageRight" data-sprite="next"><span>Next Topic</span></a></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6530025"></a><div class="name"><a href="/member/165401" data-member="165401" class="popmenu"><strong>Bleudog101</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank4" title="Advanced"></b></div>Simpsonville<br />United States<br />Member&nbsp;#163184<br />January 22, 2015<br />2373&nbsp;Posts<br /><span class="online">Online</span></div></td><td class="content"><div class="posthead"><div><time datetime="2021-01-13T01:06:48Z">Today, 8:06&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="3"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p><span style="font-size: 24px; color: #0000ff;">Plenty of time left to increase the jackpot!&nbsp; &nbsp;</span></p><p>&nbsp;</p><p><span style="font-size: 24px; color: #0000ff;">Thank for posting Todd.</span></p></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6530045"></a><div class="name"><a href="/member/54024" data-member="54024" class="popmenu"><strong>hearsetrax</strong></a></div><div class="memberdetailsbox"><div class="tag"><span class="delayedimage"><img id="lp0" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEAAAAALAAAAAABAAEAAAI=" width="64" height="64" alt="hearsetrax's avatar - alien on_computer.jpg" /><span class="spinner spinner0 spinner0-size16 spinner0-color3"><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i></span></span></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank6" title="Veteran"></b></div><br />United States<br />Member&nbsp;#52343<br />May 21, 2007<br />3318&nbsp;Posts<br /><span class="online">Online</span></div></td><td class="content"><div class="posthead"><div><time datetime="2021-01-13T01:56:27Z">Today, 8:56&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="2"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p><span class="delayedimage"><img id="lp1" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEAAAAALAAAAAABAAEAAAI=" border="0" alt="" width="400" height="377" /><span class="spinner spinner0 spinner0-size16 spinner0-color3"><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i></span></span></p><p><span style="font-size: 18px;">to get some more tickets&nbsp;</span></p><p>going to be a most interesting start&nbsp; 4 2021 4 the winner/s</p><div class="signature"><p><a title="~ Mystery Link ~" href="https://www.marineturbine.com/motorcycles/" rel="nofollow external noopener"><span class="delayedimage"><img id="lp2" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEAAAAALAAAAAABAAEAAAI=" border="0" alt="" width="134" height="100" caption="false" /><span class="spinner spinner0 spinner0-size16 spinner0-color3"><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i></span></span></a></p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6530048"></a><div class="name"><a href="/member/189385" data-member="189385" class="popmenu"><strong>MsBee18</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank2" title="Regular"></b></div>Florida<br />United States<br />Member&nbsp;#186825<br />January 2, 2018<br />302&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-01-13T02:10:24Z">Today, 9:10&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="2"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p>I will play my same numbers from Tuesdays draw. Good luck everyone.</p></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6530049"></a><div class="name"><a href="/member/182874" data-member="182874" class="popmenu"><strong>jjtheprince14</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank2" title="Regular"></b></div><br />United States<br />Member&nbsp;#180549<br />March 12, 2017<br />195&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-01-13T02:14:25Z">Today, 9:14&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="2"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p>I say we'll see it roll till we have about a $15-$20&nbsp;BILLION jackpot.&nbsp; We have &quot;ran out&quot; of winners.</p><div class="signature"><p>I am the Prince of Thieves!!!</p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6530066"></a><div class="name"><a href="/member/173761" data-member="173761" class="popmenu"><strong>frank0sport16</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/avatars/_Lottery-023.jpg" width="64" height="64" alt="frank0sport16's avatar - Lottery-023.jpg" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank0 rankname-top" title="New Member">New Member</b></div>Alabama<br />United States<br />Member&nbsp;#171513<br />January 9, 2016<br />13&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-01-13T03:03:20Z">Today, 10:03&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="1"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p>Incomprehensible Prediction -- After 34 no-winner draws, I predict that draw-35 will have TWENTY (20) winning tickets. <br /><br /> Hey, why not? Odds may be against it, but then sometimes the odds can be defied! <br /><br /> Thanx-A-Lot. Play Responsibly. Stay Safe and Well.</p></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6530077"></a><div class="name"><a href="/member/194387" data-member="194387" class="popmenu"><strong>EnReval</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank2" title="Regular"></b></div>Austin<br />United States<br />Member&nbsp;#191205<br />July 21, 2018<br />53&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-01-13T03:12:55Z">Today, 10:12&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="1"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p>Funny! I would like to not have a PB winner then things will get frantic! This is a good way for 2021 to start</p><p>&nbsp;</p><p>Now they should take it back to starting at $40milif it had started T $40mil, we would be over $900mil by now</p></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6530081"></a><div class="name"><a href="/member/194387" data-member="194387" class="popmenu"><strong>EnReval</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank2" title="Regular"></b></div>Austin<br />United States<br />Member&nbsp;#191205<br />July 21, 2018<br />53&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-01-13T03:14:41Z">Today, 10:14&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="1"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p>We are still in unprecedented times so you may be right!</p><p>&nbsp;</p><p>would help a lot of people</p></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6530093"></a><div class="name"><a href="/member/138458" data-member="138458" class="popmenu platinum"><strong>noise-gate</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="platinum" title="Platinum Member"></b></div><div class="tag">Chasing $ Millions.</div><div class="tag"><b class="rank rank6" title="Veteran"></b></div>White Shores- California<br />United States<br />Member&nbsp;#136473<br />December 12, 2012<br />6468&nbsp;Posts<br /><span class="online">Online</span></div></td><td class="content"><div class="posthead"><div><time datetime="2021-01-13T03:27:52Z">Today, 10:27&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="1"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p><span class="delayedimage"><img id="lp3" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEAAAAALAAAAAABAAEAAAI=" border="0" alt="Happy George Costanza GIF" /><span class="spinner spinner0 spinner0-size16 spinner0-color3"><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i></span></span><em><strong><span style="font-family: 'Trebuchet MS', Geneva, Arial, Helvetica, FreeSans, sans-serif; font-size: 16px;">Marvellous, simply marvellous!</span></strong></em></p><p>&nbsp;</p><p><em><strong><span style="font-family: 'Trebuchet MS', Geneva, Arial, Helvetica, FreeSans, sans-serif; font-size: 16px;">* Is the 4th paragraph a date typo?</span></strong></em></p><div class="signature"><p><span style="font-size: 12px;"><em><strong><span style="font-family: 'Trebuchet MS', Geneva, Arial, Helvetica, sans-serif;">&nbsp;* Voice of Reason *&nbsp; &nbsp;</span></strong></em></span></p><p>&nbsp;</p><p><span style="font-size: 12px;"><em><strong><span style="font-family: 'Trebuchet MS', Geneva, Arial, Helvetica, sans-serif;">People who say it cannot be done should not interrupt those who are doing it- George Bernard Shaw.</span></strong></em></span></p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div class="podfooter"><table border="0" class="podfooterlayout"><tr><td class="left"> &nbsp; </td><td class="center"><div class="pagerlayout pagerlayoutinline"><table border="0" cellspacing="0" cellpadding="0"><tr><td><span style="margin-right:8px;">Page <strong>1</strong> of <strong>1</strong></span></td><td><div id="LP_PagerFoot" class="pagercontrol sprite-pager sprite-pager-ddd"></div></td></tr></table></div></td><td class="right"><span class="nobr"></span></td></tr></table><div id="LP_RssFoot" class="podRssSection"><a id="LP_NewsRss" href="/rss/news/335225" title="Subscribe to the RSS feed for this news story and comments" class="CB" data-sprite="feed"><span>Subscribe to this news story</span></a></div></div></div><table class="blockAuLayout"><tr><td><div id="LP_FooterBannerAd" class="AU AUStandard AUSize468x60" style="width:468px;height:60px"><script>googletag.cmd.push(function(){googletag.display('LP_FooterBannerAd')})</script></div></td><th><div id="LP_FooterBlockAd" class="AU AUStandard AUSize300x250" style="width:300px;height:250px"><script>googletag.cmd.push(function(){googletag.display('LP_FooterBlockAd')})</script></div></th></tr></table></td></tr></table><ul id="mainMenu" class="jqMenu nonMbr" style="display:none;visibility:hidden"><li id="menuSpaceL"></li><li class="mainMenu"><a href="/forums">Forums</a><ul class="jqMenuPanel"><li><a href="/activetopics">Active Topics</a></li><li><a href="/search">Search</a></li><li><a href="/dailytopics" class="mbrOnly">Daily Topics</a></li><li class="title">General Discussion</li><li><a href="/forum/1">Lottery Discussion</a></li><li><a href="/forum/11">Lottery News</a></li><li><a href="/forum/10">Lottery Systems</a></li><li><a href="/forum/12">Mathematics</a></li><li><a href="/forum/13">Mystical</a></li><li><a href="/forum/2">Gaming</a></li><li class="title">Specific Lottery Games</li><li><a href="/forum/3">Pick 3</a></li><li><a href="/forum/4">Pick 4</a></li><li><a href="/forum/5">Pick 5</a></li><li><a href="/forum/6">Jackpot Games</a></li><li><a href="/forum/8">Instant ("Scratch-Off") Games</a></li><li class="title">Lottery Post Administration</li><li><a href="/help">Help</a></li><li><a href="/forum/7">Suggestions</a></li></ul></li><li class="mainMenu"><a href="/results">Results</a><ul class="jqMenuPanel"><li><a href="/results">Lottery Results Home Page</a></li><li class="sep"></li><li><a href="/results/search" class="mbrOnly">Search Past Results</a></li><li><a href="/results/custom" class="mbrOnly">Custom Lottery Results</a></li><li><a href="/results/daily" class="mbrOnly">Daily Numbers Games</a></li><li><a href="/results/all" class="mbrOnly">All Results on One Page</a></li><li class="sep"></li><li><a href="#">United States</a><ul class="jqMenuPanel cols3"><li><a href="/results/az">Arizona</a></li><li><a href="/results/ar">Arkansas</a></li><li><a href="/results/ca">California</a></li><li><a href="/results/co">Colorado</a></li><li><a href="/results/ct">Connecticut</a></li><li><a href="/results/de">Delaware</a></li><li><a href="/results/fl">Florida</a></li><li><a href="/results/ga">Georgia</a></li><li><a href="/results/id">Idaho</a></li><li><a href="/results/il">Illinois</a></li><li><a href="/results/in">Indiana</a></li><li><a href="/results/ia">Iowa</a></li><li><a href="/results/ks">Kansas</a></li><li><a href="/results/ky">Kentucky</a></li><li><a href="/results/la">Louisiana</a></li><li><a href="/results/me">Maine</a></li><li><a href="/results/md">Maryland</a></li><li><a href="/results/ma">Massachusetts</a></li><li><a href="/results/mi">Michigan</a></li><li><a href="/results/mn">Minnesota</a></li><li><a href="/results/ms">Mississippi</a></li><li><a href="/results/mo">Missouri</a></li><li><a href="/results/mt">Montana</a></li><li><a href="/results/ne">Nebraska</a></li><li><a href="/results/nh">New Hampshire</a></li><li><a href="/results/nj">New Jersey</a></li><li><a href="/results/nm">New Mexico</a></li><li><a href="/results/ny">New York</a></li><li><a href="/results/nc">North Carolina</a></li><li><a href="/results/nd">North Dakota</a></li><li><a href="/results/oh">Ohio</a></li><li><a href="/results/ok">Oklahoma</a></li><li><a href="/results/or">Oregon</a></li><li><a href="/results/pa">Pennsylvania</a></li><li><a href="/results/pr">Puerto Rico</a></li><li><a href="/results/ri">Rhode Island</a></li><li><a href="/results/sc">South Carolina</a></li><li><a href="/results/sd">South Dakota</a></li><li><a href="/results/tn">Tennessee</a></li><li><a href="/results/tx">Texas</a></li><li><a href="/results/vt">Vermont</a></li><li><a href="/results/va">Virginia</a></li><li><a href="/results/wa">Washington</a></li><li><a href="/results/dc">Washington, D.C.</a></li><li><a href="/results/wv">West Virginia</a></li><li><a href="/results/wi">Wisconsin</a></li><li><a href="/results/wy">Wyoming</a></li></ul></li><li><a href="#">Canada</a><ul class="jqMenuPanel"><li><a href="/results/ac">Atlantic Canada</a></li><li><a href="/results/bc">British Columbia</a></li><li><a href="/results/on">Ontario</a></li><li><a href="/results/qc">Québec</a></li><li><a href="/results/wc">Western Canada</a></li></ul></li><li><a href="#">Europe</a><ul class="jqMenuPanel"><li><a href="/results/germany">Germany</a></li><li><a href="/results/ie">Ireland</a></li><li><a href="/results/italy">Italy</a></li><li><a href="/results/uk">United Kingdom</a></li></ul></li><li><a href="#">Multi-Jurisdiction</a><ul class="jqMenuPanel"><li><a href="/results/xx">Multi-State (United States)</a></li><li><a href="/results/zz">Multi-Province (Canada)</a></li><li><a href="/results/yy">Multi-Country</a></li></ul></li><li class="sep"></li><li><a href="/jackpots">Current Lottery Jackpots</a></li><li class="sep"></li><li><a href="/gadget">Lottery Results Gadget for Windows</a></li><li><a href="/lottery-report-card.asp">State Lottery Report Card</a></li><li><a href="/petition-true-drawings.aspx">Help Eliminate Computerized Drawings</a></li></ul></li><li class="mainMenu"><a href="/predictions">Predictions</a><ul class="jqMenuPanel"><li><a href="/predictions">Predictions Home Page</a></li><li class="sep"></li><li><a href="#">United States</a><ul class="jqMenuPanel cols3"><li><a href="/predictions-state.asp?s=az">Arizona</a></li><li><a href="/predictions-state.asp?s=ar">Arkansas</a></li><li><a href="/predictions-state.asp?s=ca">California</a></li><li><a href="/predictions-state.asp?s=co">Colorado</a></li><li><a href="/predictions-state.asp?s=ct">Connecticut</a></li><li><a href="/predictions-state.asp?s=de">Delaware</a></li><li><a href="/predictions-state.asp?s=fl">Florida</a></li><li><a href="/predictions-state.asp?s=ga">Georgia</a></li><li><a href="/predictions-state.asp?s=id">Idaho</a></li><li><a href="/predictions-state.asp?s=il">Illinois</a></li><li><a href="/predictions-state.asp?s=in">Indiana</a></li><li><a href="/predictions-state.asp?s=ia">Iowa</a></li><li><a href="/predictions-state.asp?s=ks">Kansas</a></li><li><a href="/predictions-state.asp?s=ky">Kentucky</a></li><li><a href="/predictions-state.asp?s=la">Louisiana</a></li><li><a href="/predictions-state.asp?s=me">Maine</a></li><li><a href="/predictions-state.asp?s=md">Maryland</a></li><li><a href="/predictions-state.asp?s=ma">Massachusetts</a></li><li><a href="/predictions-state.asp?s=mi">Michigan</a></li><li><a href="/predictions-state.asp?s=mn">Minnesota</a></li><li><a href="/predictions-state.asp?s=ms">Mississippi</a></li><li><a href="/predictions-state.asp?s=mo">Missouri</a></li><li><a href="/predictions-state.asp?s=mt">Montana</a></li><li><a href="/predictions-state.asp?s=ne">Nebraska</a></li><li><a href="/predictions-state.asp?s=nh">New Hampshire</a></li><li><a href="/predictions-state.asp?s=nj">New Jersey</a></li><li><a href="/predictions-state.asp?s=nm">New Mexico</a></li><li><a href="/predictions-state.asp?s=ny">New York</a></li><li><a href="/predictions-state.asp?s=nc">North Carolina</a></li><li><a href="/predictions-state.asp?s=nd">North Dakota</a></li><li><a href="/predictions-state.asp?s=oh">Ohio</a></li><li><a href="/predictions-state.asp?s=ok">Oklahoma</a></li><li><a href="/predictions-state.asp?s=or">Oregon</a></li><li><a href="/predictions-state.asp?s=pa">Pennsylvania</a></li><li><a href="/predictions-state.asp?s=pr">Puerto Rico</a></li><li><a href="/predictions-state.asp?s=ri">Rhode Island</a></li><li><a href="/predictions-state.asp?s=sc">South Carolina</a></li><li><a href="/predictions-state.asp?s=sd">South Dakota</a></li><li><a href="/predictions-state.asp?s=tn">Tennessee</a></li><li><a href="/predictions-state.asp?s=tx">Texas</a></li><li><a href="/predictions-state.asp?s=vt">Vermont</a></li><li><a href="/predictions-state.asp?s=va">Virginia</a></li><li><a href="/predictions-state.asp?s=wa">Washington</a></li><li><a href="/predictions-state.asp?s=dc">Washington, D.C.</a></li><li><a href="/predictions-state.asp?s=wv">West Virginia</a></li><li><a href="/predictions-state.asp?s=wi">Wisconsin</a></li><li><a href="/predictions-state.asp?s=wy">Wyoming</a></li></ul></li><li><a href="#">Canada</a><ul class="jqMenuPanel"><li><a href="/predictions-state.asp?s=ac">Atlantic Canada</a></li><li><a href="/predictions-state.asp?s=bc">British Columbia</a></li><li><a href="/predictions-state.asp?s=on">Ontario</a></li><li><a href="/predictions-state.asp?s=qc">Québec</a></li><li><a href="/predictions-state.asp?s=wc">Western Canada</a></li></ul></li><li><a href="#">Europe</a><ul class="jqMenuPanel"><li><a href="/predictions-state.asp?s=02">Germany</a></li><li><a href="/predictions-state.asp?s=ie">Ireland</a></li><li><a href="/predictions-state.asp?s=uk">United Kingdom</a></li></ul></li><li><a href="#">Multi-Jurisdiction</a><ul class="jqMenuPanel"><li><a href="/predictions-state.asp?s=xx">Multi-State (United States)</a></li><li><a href="/predictions-state.asp?s=zz">Multi-Province (Canada)</a></li><li><a href="/predictions-state.asp?s=yy">Multi-Country</a></li></ul></li><li class="sep"></li><li><a href="/predictions-winners.asp">See Yesterday's Winners</a></li><li><a href="/predictions-statistics-top.asp">Top Predictors</a></li><li class="sep"></li><li><a href="/predictions-member.asp" class="disabled">My Predictions</a></li><li><a href="/predictions-statistics.asp" class="disabled">My Prediction Statistics</a></li><li><a href="/post-prediction-form.asp" class="mbrOnly">Post Predictions</a></li><li class="sep"></li><li><a href="/wheels">Lottery Wheels</a></li><li><a href="/deflate3.asp" class="mbrOnly">Deflate 3 Number Reduction System</a></li><li><a href="/deflate4.asp" class="mbrOnly">Deflate 4 Number Reduction System</a></li><li><a href="/deflate5.asp" class="mbrOnly">Deflate 5 Number Reduction System</a></li><li><a href="/inspector3.asp" class="mbrOnly">Inspector 3 Number Classification System</a></li><li><a href="/inspector4.asp" class="mbrOnly">Inspector 4 Number Classification System</a></li></ul></li><li class="mainMenu"><a href="/memberships">Members</a><ul class="jqMenuPanel"><li><a href="/login">Log In</a></li><li><a href="/register">Register for a Free Membership</a></li><li class="sep"></li><li><a href="/memberships">Compare Membership Features</a></li><li class="sep"></li><li><a href="/memberlist" class="mbrOnly">Member List</a></li><li class="sep"></li><li><a href="/member/profile" class="disabled">My Profile</a></li><li><a href="/member/recentposts" class="disabled">My Recent Posts</a></li><li><a href="/member/favorites" class="disabled">My Favorites</a></li><li><a href="/control_subs.asp" class="disabled">My Subscriptions</a></li><li><a href="/blocklist.aspx" class="disabled">My Block List</a></li><li><a href="/imagemanager.aspx" class="disabled">My Images (Image Manager)</a></li><li class="sep">&nbsp;</li><li><a href="/blogs">Blogs Home Page</a></li><li><a href="/blog" class="disabled">My Blog</a></li><li><a href="/new-blog.aspx" class="mbrOnly">Post New Blog Entry</a></li><li><a href="/search/blogs">Search Blogs</a></li><li><a href="/control_blog.asp" class="mbrOnly">Premium Blog Settings</a></li><li class="sep"></li><li><a href="/features.asp">Premium Features</a></li><li><a href="/buy-membership.asp">Buy/Renew Membership</a></li></ul></li><li class="mainMenu"><a href="/systems">Systems</a><ul class="jqMenuPanel"><li><a href="/systems">Lottery Systems Home page</a></li><li class="sep"></li><li><a href="/deflate3.asp" class="mbrOnly">Deflate 3 Number Set Reduction</a></li><li><a href="/deflate4.asp" class="mbrOnly">Deflate 4 Number Set Reduction</a></li><li><a href="/deflate5.asp" class="mbrOnly">Deflate 5 Number Set Reduction</a></li><li><a href="/inspector3.asp" class="mbrOnly">Inspector 3 Number Set Analysis</a></li><li><a href="/inspector4.asp" class="mbrOnly">Inspector 4 Number Set Analysis</a></li><li class="sep"></li><li><a href="/reports/combinations">Combinations Analysis for Pick 3 and Pick 4</a></li><li><a href="/reports/pairs">Pairs Analysis for Pick 3 and Pick 4</a></li><li class="sep"></li><li><a href="/system-lucky-tracker.aspx">Lucky's Daily Tracker</a></li><li><a href="/system-lucky-followers.aspx">Lucky's Followers System</a></li><li><a href="/system-lucky-1up1down.asp">Lucky's 1-Up 1-Down System</a></li><li class="sep"></li><li><a href="/vtracs">VTracs Home Page</a></li><li><a href="/vtracs/results" class="mbrOnly">VTrac Lottery Results</a></li><li><a href="/vtracs/search" class="mbrOnly">VTracs Search Engine</a></li><li><a href="#">VTrac Charts</a><ul class="jqMenuPanel"><li><a href="/vtracs/mirrors/pick3">VTrac Pick 3 Mirror Combinations</a></li><li><a href="/vtracs/mirrors/pick4">VTrac Pick 4 Mirror Combinations</a></li><li><a href="/vtracs/mirrors/quinto">VTrac Quinto Mirror Combinations</a></li></ul></li><li class="sep"></li><li><a href="/wheels">Lottery Wheels Home Page</a></li><li><a href="/wheels/positional" class="mbrOnly">Positional Wheels for Pick 3, Pick 4, and Quinto</a></li><li><a href="/wheels/pick5" class="mbrOnly">Pick 5 Wheels</a></li><li><a href="/wheels/pick6" class="mbrOnly">Pick 6 Wheels</a></li><li class="sep"></li><li><a href="/quickpicks">Quick Picks Generator</a></li><li><a href="/words-to-numbers">Convert Words and Phrases to Lottery Numbers</a></li><li><a href="/combinations">Lottery Combinations Generator</a></li></ul></li><li class="mainMenu"><a href="#">Resources</a><ul class="jqMenuPanel"><li><a href="/search">Search for something</a></li><li class="sep"></li><li><a href="/news">Lottery News</a></li><li><a href="/tags">Lottery News Story Tags ("Tag Cloud")</a></li><li><a href="/rss">Syndicated RSS 2.0 Feeds</a></li><li class="sep"></li><li><a href="/onthisday">On This Day in History</a></li><li><a href="/calendar">Event Calendar</a></li><li><a href="/lunarcalendar">Lunar Calendar</a></li><li><a href="#">Lottery Charts</a><ul class="jqMenuPanel"><li><a href="/charts">Lottery Charts Main Page</a></li><li class="sep"></li><li><a href="/charts/pick3/combinations">Pick 3 Straight and Box Combinations</a></li><li><a href="/charts/pick3/sums">Pick 3 Sums</a></li><li><a href="/charts/pick3/rootsums">Pick 3 Root Sums</a></li><li><a href="/charts/pick3/sumlastdigit">Pick 3 Sum Last Digit</a></li><li><a href="/vtracs/mirrors/pick3">VTrac Pick 3 Mirror Combinations</a></li><li class="sep"></li><li><a href="/charts/pick4/combinations">Pick 4 Straight and Box Combinations</a></li><li><a href="/charts/pick4/sums">Pick 4 Sums</a></li><li><a href="/charts/pick4/rootsums">Pick 4 Root Sums</a></li><li><a href="/charts/pick4/sumlastdigit">Pick 4 Sum Last Digit</a></li><li><a href="/vtracs/mirrors/pick4">VTrac Pick 4 Mirror Combinations</a></li><li class="sep"></li><li><a href="/charts/quinto/combinations">Quinto Straight and Box Combinations</a></li><li><a href="/charts/quinto/sums">Quinto Sums</a></li><li><a href="/charts/quinto/rootsums">Quinto Root Sums</a></li><li><a href="/charts/quinto/sumlastdigit">Quinto Sum Last Digit</a></li><li><a href="/vtracs/mirrors/quinto">VTrac Quinto Mirror Combinations</a></li><li class="sep"></li><li><a href="/charts/mystical/lacharada">La Charada</a></li></ul></li><li><a href="/quickpicks">Quick Picks Generator</a></li><li><a href="/combinations">Lottery Combinations Generator</a></li><li><a href="/odds">Lottery Odds Calculator</a></li><li class="sep"></li><li><a href="/activeusers" class="mbrOnly">Who's Online</a></li><li><a href="/activity" class="mbrOnly">Monitor Site Activity</a></li><li class="sep"></li><li><a href="/contact">Contact Us</a></li><li><a href="#">About Us</a><ul class="jqMenuPanel"><li><a href="/about">About Lottery Post</a></li><li><a href="/changelog">Web Site Change Log</a></li><li><a href="/sitemap">Site Map</a></li><li class="sep"></li><li><a href="/rules">Forum Rules</a></li><li><a href="/privacy">Privacy Statement</a></li><li><a href="/copyright">Copyright Notice</a></li><li><a href="/terms.aspx">Terms and Conditions of Use</a></li><li><a href="/linkpolicy.aspx">Link Policy</a></li></ul></li><li class="sep"></li><li><a href="#">Online Games</a><ul class="jqMenuPanel"><li><a href="/games">Games Main Page</a></li><li class="sep"></li><li><a href="/2048">Play 2048</a></li><li><a href="/sudoku">Play Sudoku</a></li></ul></li><li><a href="/books">Lottery Book Store</a></li><li><a href="http://www.cafepress.com/lotterypost/" rel="external noopener">Lottery Post Gift Shop</a></li><li><a href="/links">Lottery Links</a></li><li><a href="https://www.usamega.com/" rel="external noopener">USA Mega (Powerball/Mega Millions)</a></li><li class="sep"></li><li><a href="/browsertest">Browser Compatibility Test</a></li></ul></li><li class="mainMenu"><a href="#">Options</a><ul class="jqMenuPanel"><li><a href="/control.asp" class="disabled">Control Panel Home page</a></li><li class="sep"></li><li><a href="/control_profile.asp" class="disabled">Edit Profile</a></li><li><a href="/edit-signature.aspx" class="disabled">Create/Edit Signature</a></li><li><a href="/change-avatar.aspx" class="disabled">Add or Change Avatar</a></li><li class="sep"></li><li><a href="/control_account.asp" class="disabled">Account Settings</a></li><li><a href="/control_blog.asp" class="disabled">Premium Blog Settings</a></li><li><a href="/control_email.asp" class="disabled">E-mail Settings</a></li><li><a href="/control_favorites.asp" class="disabled">Favorites Settings</a></li><li><a href="/control_changeemail.asp" class="disabled">Change E-mail Address</a></li><li><a href="/changepassword">Change Password</a></li><li class="sep"></li><li><a href="/whitelist">Whitelist Lottery Post</a></li><li><a href="/DeleteCookies.aspx">Delete cookies set by Lottery Post</a></li><li class="sep"></li><li><a href="/login">Log In</a></li><li><a href="/register">Register for a Free Membership</a></li></ul></li><li id="menuSpaceR"></li></ul></div><div id="footer"><div id="footerContent"><div id="footerCols"><div class="col1"><div class="colContent"><label>First Time?</label><p>If you haven't already, check out the <a title="About Lottery Post" href="/about">About Us</a> page that explains the main features of our site.</p><p>Also, please take a few moments and review the <a title="Rules for posting at Lottery Post" href="/rules">rules</a> for posting at Lottery Post.</p><p>Any time you see a <samp title="This is an example of a popup menu link. You would click it to reveal a popup menu of options.">gray-underlined link</samp>, you can click the link to see a popup menu of options.</p><p><strong>Popular features:</strong></p><ul><li><a title="Lottery results (winning numbers)" href="/results">Lottery Results</a></li><li><a title="Lottery discussion forums" href="/forums">Discussion Forums</a></li><li><a title="Lottery predictions" href="/predictions">Predictions Board</a></li><li><a title="Lottery methods, systems, and wheels" href="/systems">Lottery Systems and Wheels</a></li><li><a title="Quality, hand-picked selection of lottery and dream books" href="/books">Book Store - lottery &amp; dream books</a></li><li><a title="Lottery Results Gadget for Windows" href="/gadget">Lottery Results Gadget</a></li></ul></div></div><div class="col2"><div class="colContent"><label>Need Help?</label><p>We try to include instructions on each page. Check for help content on the page that's giving you trouble.</p><p>The next place to seek help is our dedicated <a title="See Lottery Post's dedicated help forum" href="/help">Help forum</a> that contains detailed assistance for frequently requested topics.</p><p>If something isn't working properly, our automated <a title="Use the automated Browser Compatibility Test" href="/browsertest">Browser Test</a> page can quickly identify common problems.</p><p>Finally, the <a title="Contact Lottery Post" href="/contact">Contact Us</a> page has an incredible wealth of self-help material that answers 95% of the questions we are asked.</p><p>We always welcome <a title="Send us your feedback" href="/contact/site">feedback</a> and <a title="Send us your suggestions" href="/contact/suggest">suggestions</a>.</p></div></div><div class="col3"><div class="colContent"><label>About Lottery Post</label><p><a title="About Lottery Post" href="/about">About Us</a>&nbsp;&bull; <a title="Lottery Post Site Map" href="/sitemap">Site Map</a>&nbsp;&bull; <a title="Comparison chart of membership features" href="/memberships">Membership Features</a>&nbsp;&bull; <a title="Inquire about advertising at Lottery Post" href="/contact/ads">Advertising Opportunities</a>&nbsp;&bull; <a title="DMCA" href="/dmca">DMCA</a>&nbsp;&bull; <a title="See Lottery Post's journal of Web site changes" href="/changelog">Change Log</a>&nbsp;&bull; <a title="Rules for posting at Lottery Post" href="/rules">Rules</a>&nbsp;&bull; <a title="Lottery Post's Privacy Statement" href="/privacy">Privacy</a>&nbsp;&bull; <a title="See Lottery Post's Link Policy" href="/linkpolicy.aspx">Linking to Lottery Post</a></p><label>RSS Feeds</label><p><a title="Lottery Post's main index of RSS feeds" href="/rss">Index of Feeds</a>&nbsp;&bull; <a title="RSS feed of lottery news stories" href="http://feeds.lotterypost.com/LotteryNews">Lottery News</a>&nbsp;&bull; <a title="RSS feed of events" href="http://feeds.lotterypost.com/LotteryPostEventCalendar">Event Calendar</a>&nbsp;&bull; <a title="RSS feed of the latest posts on the discussion forums" href="http://feeds.lotterypost.com/LotteryPostActiveTopics">Latest Forum Posts</a>&nbsp;&bull; <a title="RSS feed of Lottery Post's journal of Web site changes" href="http://feeds.lotterypost.com/LotteryPostChangeLog">Web Site Change Log</a></p><label>Search Lottery Post</label><p>Search the news, forums, blogs, and even your private messages at our <a title="Search for something at Lottery Post" href="/search">Search</a> page.</p></div></div></div><div class="col4"><div class="colContent"><p>This page was generated in 0.1648 seconds.<br /><a href="/copyright">Copyright</a> &copy; 1999-2021 <a href="https://www.speednet.biz/">Speednet Group</a>.&nbsp; All rights reserved.</p></div></div></div></div><script src="https://lp.vg/script/advert.js"></script><script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"></script><div id="PagerMenuPanel"></div><div class="aspNetHidden"><input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="6E8D4450" /><input type="hidden" name="__VIEWSTATEENCRYPTED" id="__VIEWSTATEENCRYPTED" value="" /></div><script src="https://lp.vg/js/ds01218.3/MwtGFZn69uAwUEBU1xQNAHR7FoSyGDVA6BzbcVg6aEZjnjKKk9Rrt8egtyaKSMzNkICrg4d5Ke3NoOtwS(DCOHQzmBP4wqL5veCYtyspv2G4oJ(GmxykoLR3upAk3jTVdPDBW3)eWVULWUdXqyPlPo5XO3Sw59KQ9KsazSqMcavoZum1EbsJt4aEoh8LduaYVHw1t4noRQqJbz0RYqRmuHkkUQy7qdpzIpr8K17s5RmjTbzMB8D)AW2)WxOiEiAyAev7/fT63e2l0(w57RziKWEWnZGXkx5o8VFdgMeuNDiNOb4)qsO4TyeuA21e4qbbDRZM(F2qtwXDiGHa9WmnFwMn6kGfgjLRINM4OOo3Ikjjz72wB6X3viQJ20GY56CC9Fn9LotbSuJY1gomZVvnl1J00jurMNYQV)RwODW4Kun2Ql7qMUAzUAa06AGgKY0EBuIVY2V5NiHZPTFaaFK1xP8DXFH6FCyE5bSZ60H)CF5I="></script><script>$(function(){window.setTimeout(function(){$('#mainMenu').jqMenu({rightAlignElement:'#pagewidth',rightAlignOffset:316,rightAlignPopupLimit:true,recalcPositionOnFontLoad:'Oswald'});},1);});var mL={138458:[138458,'noise-gate','','',0],165401:[165401,'Bleudog101','','',0],54024:[54024,'hearsetrax','','',0],189385:[189385,'MsBee18','','',0],182874:[182874,'jjtheprince14','','',0],173761:[173761,'frank0sport16','','https://frankosite2020.com',0],194387:[194387,'EnReval','','',0]};var gL={};$.ratingDefaults({servicePath:'/services/Callback.asmx',viewServiceMethod:'GetTopicRatings',saveServiceMethod:'SetTopicRating',deleteServiceMethod:'DeleteTopicRating',spinner:'<p><span class="spinner spinner0 spinner0-size16" style="vertical-align:middle;"><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i></span> Loading...</p>'});ThreadPage.initialize(335225,6530093,0,false,0,null);$('#rating335225').rating({ratedTargetID:335225,memberID:0,ratingMember:0,ratingCurrent:5,ratingCount:3});LP.delayedImages={"lp0":"https://earthchangepredictions.com/images/alien_on_computer.jpg","lp1":"https://media.giphy.com/media/CjmvTCZf2U3p09Cn0h/giphy.gif","lp2":"https://lpimg.com/http://4.bp.blogspot.com/_Hc8XpoGUAGI/TMDhr7qyXwI/AAAAAAAABkU/3i9Ix-Mi2F0/s1600/TWILIGHT_ZONE_SEASON_5_DISC_4-6.bmp","lp3":"https://media2.giphy.com/media/BlVnrxJgTGsUw/giphy.gif?cid=ecf05e478tfeqroyg40sd5er1jxzsya1robhs5j8tptdalhn&amp;rid=giphy.gif"};$($.wired(NewsPage, NewsPage.initialize));</script></form><script type="application/ld+json">{"@context":"https://schema.org/","@id":"https://www.lotterypost.com/#organization","@type":"Organization","name":"Lottery Post","url":"https://www.lotterypost.com/","logo":{"@type":"ImageObject","url":"https://www.lotterypost.com/images/lp_icon_310.png"},"founder":{"@type":"Person","name":"Todd Northrop"},"description":"Lottery Post is a popular website for lottery players to get the latest lottery results, prizes, and jackpots, and to discuss, share, and discover anything and everything about official government lottery games around the world.","sameAs":["https://www.youtube.com/LotteryPost","https://www.facebook.com/LotteryPost","https://twitter.com/LotteryPost","https://www.instagram.com/LotteryPost/"]}</script></body></html> 