Welcome Guest
( Log In | Register )
The time is now 4:21 am
You last visited September 18, 2020, 2:19 am
All times shown are
Eastern Time (GMT-5:00)

Fixed nasty bug in Image Manager

Published:

I'm sure Gold and Platinum members have been cursing their computer screens every time that warning message about "String can't be converted to Boolean" appears just before the text editor comes on the screen.

I know I have — for the last week now! Mad

The good news is that I have finally found and fixed the bug.

Just to find the stupid thing, let alone fix it, did not happen until today.  Several times over the past week I thought I had found and fixed it, only to see it reappear again.  Grrrrr....

This morning I finally narrowed the problem down to the Image Manager, which is why only Gold and Platinum members ever saw the error. 

(Image Manager is only available to premium members.  It is software that allows members to upload images to the Lottery Post server, manage them in folders you create, edit them, and post them on the forums, in the blogs, as an avatar, and anywhere else you can post an image.)

After narrowing down the component causing the problem, I traced all the data being sent to a web browser from that component, and eventually found the exact piece of code that was triggering the error.

Then I spent a few hours wrestling with the code trying to work around the problem, and even at one point purchased the latest version of the Image Manager software, hoping it have the bug fixed.

No dice.

The authentication — the part that verifies that the person using the software is indeed a premium member — just would not work without giving the error.

So in order to fix it, I completely re-wrote the authentication module from scratch, and that is what finally fixed the problem fr good.

Despite the tremendous difficulty and heartache this kind of thing causes, there is almost always a silver lining.

In this case, the good news is that the new authentication module I wrote is much more reliable that the module that came packaged with the software, and nobody should ever run into the error caused when your browser "times out" and displays an error message in the Image Manager window. 

(That error would happen if you opened the editor, didn't move from that page for about 20 minutes, and then attempted to open Image Manager.)

Now I have to catch up on all the things that I have put off while trying to fix this thing!  (I apologize if I have been slow to get back to anyone, but now you know what I've been doing.)

Entry #438

Comments

1.
x1kosmicComment by x1kosmic - August 4, 2008, 5:21 pm
I know it was probably wrong to do so, but as a Standard member, is that why my Avitar, recently dissapeared on me? It wasn't a LP Avitar.(but I'm ok with them). I was trying to clear my cache and Bam...gone
2.
TenajComment by Tenaj - August 4, 2008, 5:46 pm
I never did get that message but thanks for fixing it.
3.
ToddComment by Todd - August 4, 2008, 10:02 pm
@x1kosmic: No, it would not have anything to do with that, and it's just fine to use an external avatar. It usually happens when the web site hosting the image either moves it, deletes it, or blocks it from being leeched. See the following link for more info: http://www.lotterypost.com/thread/131640 (bottom of the page).
4.
ToddComment by Todd - August 4, 2008, 10:02 pm
@Tenaj: You're fortunate.
5.
Comment by pacattack05 - August 5, 2008, 8:59 am
In your explanation above, you sounded like Scotty on Star Trek....lol

The Dialithium crystals were burning too fast captain...I'm an engineer, not a doctor....For god sakes Jim.
6.
ToddComment by Todd - August 5, 2008, 9:33 am
@Pac: Yeah, I felt like I was running into that huge spinning disk at the edge of the galaxy, preventing the ship from leaving the galaxy.

You must be a Lottery Post member to post comments to a Blog.

Register for a FREE membership, or if you're already a member please Log In.