<!DOCTYPE html>
<html lang="en"><head><meta charset="utf-8" />

<!--	Lottery Post® (https://www.lotterypost.com)
	Author: Todd Northrop
	E-mail: webmaster (at) lotterypost (dot) com
	Copyright © 1999-2020. All Rights Reserved.
	Reproduction in whole or in part in any form or medium without express written permission of the Author is prohibited. See https://www.lotterypost.com/copyright
	Lottery Post and the Lottery Post logo are registered trademarks of Speednet Group, and may not be used without express written permission.
- - - - - - - - - - - - - - - - - - - - - - - - - - - -->

<title>Idaho ends Powerball in state, fearing foreign participation | Lottery Post</title><meta name="application-name" content="Lottery Post" /><meta name="format-detection" content="telephone=no" /><meta name="msapplication-starturl" content="/" /><meta name="theme-color" content="#bcceff" /><meta name="viewport" content="width=968" /><meta name="title" content="Idaho ends Powerball in state, fearing foreign participation" /><meta name="keywords" content="lottery,news,Powerball,UK National Lottery,Idaho,Australia,Government,Multi-State Game" /><meta name="description" content="Idaho lawmakers fearing foreign participation in the Powerball lottery killed legislation on Wednesday that would have allowed the game with huge jackpots to continue in the state after a run of more than 30 years." /><meta property="og:title" content="Idaho ends Powerball in state, fearing foreign participation | Lottery Post" /><meta property="og:type" content="article" /><meta property="og:url" content="https://www.lotterypost.com/news/335976" /><meta property="og:description" content="Idaho lawmakers fearing foreign participation in the Powerball lottery killed legislation on Wednesday that would have allowed the game with huge jackpots to continue in the state after a run of more than 30 years." /><meta property="og:image" content="https://lp.vg/images/newsicon_powerball.jpg" /><meta property="og:image:width" content="280" /><meta property="og:image:height" content="200" /><meta property="og:image:alt" content="Powerball" /><meta property="og:site_name" content="Lottery Post" /><meta property="article:published_time" content="2021-03-11T06:25:59-05:00" /><meta property="article:tag" content="Lottery" /><meta property="article:tag" content="Powerball" /><meta property="article:tag" content="UK National Lottery" /><meta property="article:tag" content="Idaho" /><meta property="article:tag" content="Australia" /><meta property="article:tag" content="Government" /><meta property="article:tag" content="Multi-State Game" /><meta name="twitter:card" content="summary" /><meta name="twitter:title" content="Idaho ends Powerball in state, fearing foreign participation | Lottery Post" /><meta name="twitter:url" content="https://www.lotterypost.com/news/335976" /><meta name="twitter:description" content="Idaho lawmakers fearing foreign participation in the Powerball lottery killed legislation on Wednesday that would have allowed the game with huge jackpots to continue in the state after a run of more than 30 years." /><meta name="twitter:site" content="@LotteryPost" /><meta name="twitter:image" content="https://lp.vg/images/newsicon_powerball.jpg" /><link rel="canonical" href="https://www.lotterypost.com/news/335976" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:400,700" /><link rel="manifest" href="/manifest.webmanifest" /><link rel="shortcut icon" href="/images/theme/icon-lponly-48.ico" type="image/vnd.microsoft.icon" sizes="16x16 32x32 48x48" /><link rel="icon" href="/images/theme/icon-lp-192.png" type="image/png" sizes="192x192" /><link rel="apple-touch-icon" href="/images/theme/icon-lp-180.png" sizes="180x180" /><link rel="mask-icon" href="/images/svg/lp-mask.svg" color="#aa6500" /><link rel="search" href="/xml/SearchProviderForums.xml" type="application/opensearchdescription+xml" title="Lottery Post Search" /><link rel="preload" href="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js" as="script" /><link rel="next" href="/news/335976/2" /><link rel="prerender" href="https://www.lotterypost.com/news/335976/2" /><link rel="alternate" href="https://www.lotterypost.com/rss/news/335976" type="application/rss+xml" title="Subscribe to &quot;Idaho ends Powerball in state, fearing foreign participation&quot;" /><link rel="alternate" href="https://m.lotterypost.com/news/335976" media="only screen and (max-width: 640px)" /><script async src="https://www.googletagservices.com/tag/js/gpt.js"></script><script async src="https://c.amazon-adsystem.com/aax2/apstag.js"></script><script async src="https://lp.vg/js/f1/pb3.21.0.js"></script><script>var googletag=googletag||{};googletag.cmd=googletag.cmd||[];!function(g){g.cmd.push(function(){g.defineSlot('/13070090/LP_728x90',[728,90],'AUHead').addService(g.pubads());g.defineSlot('/13070090/LP_120x600',[120,600],'MasterAuLeft').addService(g.pubads());g.defineSlot('/13070090/LP_300x250_Primary',[300,250],'LP_ctl05').addService(g.pubads());g.defineSlot('/13070090/LP_300x250_Secondary',[300,250],'LP_ctl07').addService(g.pubads());g.defineSlot('/13070090/LP_468x60_Text',[468,60],'LP_FooterBannerAd').addService(g.pubads());g.defineSlot('/13070090/LP_300x250_Primary',[300,250],'LP_FooterBlockAd').addService(g.pubads());try{var i,e=document.getElementsByTagName('link'),l=e.length;for(i=0;i<l;i++){if(e[i].rel==='canonical'){g.pubads().set('page_url',e[i].href);i=l}}}catch(r){}g.pubads().setTargeting('Device','Computer');g.pubads().setTargeting('Content','Restrict');g.pubads().setTargeting('Category','News');g.pubads().disableInitialLoad();g.pubads().enableSingleRequest();g.pubads().collapseEmptyDivs();g.pubads().enableLazyLoad({fetchMarginPercent:500,renderMarginPercent:200,mobileScaling:2.0});g.enableServices()})}(googletag);var pbBds=function(n,t,i,r,u,f,e,o){var s={code:n,mediaTypes:{banner:{sizes:t}},bids:[]},h;if(i&&s.bids.push({bidder:"appnexus",params:{placementId:i,reserve:.01}}),r)for(h=0;h<t.length;h++)s.bids.push({bidder:"ix",params:{siteId:r,size:t[h]}});return u&&s.bids.push({bidder:"medianet",params:{cid:"8CUCSJ2Y7",crid:u,bidfloor:.01}}),f&&s.bids.push({bidder:"pubmatic",params:{publisherId:"157856",adSlot:f,kadfloor:".01"}}),e&&s.bids.push({bidder:"sortable",params:{tagId:e,floor:.01}}),o&&s.bids.push({bidder:"sovrn",params:{tagid:o,bidfloor:.01}}),s},pbjs=pbjs||{};pbjs.que=pbjs.que||[];pbjs.que.push(function(){pbjs.setConfig({bidderTimeout:900,priceGranularity:{buckets:[{min:0,max:3,increment:.01},{min:3,max:8,increment:.05},{min:8,max:10,increment:.1},{min:10,max:20,increment:.5},{min:20,max:30,increment:1}]},sortable:{siteId:'lotterypost.com'},userSync:{filterSettings:{iframe:{bidders:'*',filter:'include'}},syncDelay:6000,syncsPerBidder:3}})});var pbSlots=[pbBds('AUHead',[[728,90]],'14442905','341167','332319712','LP_728x90','AUHead','594224'),pbBds('MasterAuLeft',[[120,600]],'14442905','341162','795217702','LP_120x600','MasterAuLeft','594228'),pbBds('LP_ctl05',[[300,250]],'14442905','341164','251633185','LP_300x250_Primary','LP_ctl05','594225'),pbBds('LP_ctl07',[[300,250]],'14442905','341164','251633185','LP_300x250_Secondary','LP_ctl07','594225'),pbBds('LP_FooterBlockAd',[[300,250]],'14442905','341164','251633185','LP_300x250_Primary','LP_FooterBlockAd','594225')];var apstag=apstag||{q:function(n,t){apstag._Q.push([n,t])},init:function(){apstag.q('i',arguments)},fetchBids:function(){apstag.q('f',arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};apstag.init({pubID:'c6915d94-7b34-4363-b9a6-c45dfdb5e581',adServer:'googletag',bidTimeout:900});var a9Slots=[{slotID:'AUHead',slotName:'/13070090/LP_728x90',sizes:[[728,90]]},{slotID:'MasterAuLeft',slotName:'/13070090/LP_120x600',sizes:[[120,600]]},{slotID:'LP_ctl05',slotName:'/13070090/LP_300x250_Primary',sizes:[[300,250]]},{slotID:'LP_ctl07',slotName:'/13070090/LP_300x250_Secondary',sizes:[[300,250]]},{slotID:'LP_FooterBlockAd',slotName:'/13070090/LP_300x250_Primary',sizes:[[300,250]]}];!function(n,t){function e(){for(var n in i)if(i[n])return!1;return!0}function u(n){r||(i[n]=!1,e()&&f())}function f(){r||window.aNotOK||(r=!0,googletag.cmd.push(function(){try{n&&apstag.setDisplayBids()}catch(i){}try{t&&pbjs.setTargetingForGPTAsync()}catch(i){}googletag.pubads().refresh()}))}function o(){t&&pbjs.que.push(function(){pbjs.addAdUnits(pbSlots);pbjs.requestBids({bidsBackHandler:function(){u("prebid")}})});n&&apstag.fetchBids({slots:a9Slots},function(){u("a9")})}var i={a9:n,prebid:t},r=!1;t||n?(o(),window.setTimeout(f,1500)):googletag.pubads().refresh()}(!0,!0);</script><script type="application/ld+json">{"@context":"https://schema.org/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.lotterypost.com/news/335976"},"description":"Idaho lawmakers fearing foreign participation in the Powerball lottery killed legislation on Wednesday that would have allowed the game with huge jackpots to continue in the state after a run of more than 30 years.","commentCount":"18","datePublished":"2021-03-11T06:25:59-05:00","dateModified":"2021-03-11T06:25:59-05:00","headline":"Idaho ends Powerball in state, fearing foreign participation","keywords":"lottery,Powerball,UK National Lottery,Idaho,Australia,Government,Multi-State Game","image":["https://lp.vg/images/newsicon_powerball.jpg"],"thumbnailUrl":"https://lp.vg/images/newsicon_powerball.jpg","dateline":"BOISE, Idaho","author":{"@type":"Organization","name":"AP"},"isAccessibleForFree":true,"publisher":{"@type":"Organization","name":"Lottery Post","logo":{"@type":"ImageObject","url":"https://www.lotterypost.com/images/lp_icon_310.png"}}}</script><script>var _mNHandle=_mNHandle||{},medianet_versionId='3121199';_mNHandle.queue=_mNHandle.queue||[];</script><script async src="https://contextual.media.net/dmedianet.js?cid=8CU2OF2D5"></script><link rel="preload" href="https://lp.vg/js/ds01218.3/MwtGFZn69uAwUEBU1xQNAHR7FoSyGDVA6BzbcVg6aEZjnjKKk9Rrt8egtyaKSMzNkICrg4d5Ke3NoOtwS(DCOHQzmBP4wqL5veCYtyspv2G4oJ(GmxykoLR3upAk3jTVdPDBW3)eWVULWUdXqyPlPo5XO3Sw59KQ9KsazSqMcavoZum1EbsJt4aEoh8LduaYVHw1t4noRQqJbz0RYqRmuHkkUQy7qdpzIpr8K17s5RmjTbzMB8D)AW2)WxOiEiAyAev7/fT63e2l0(w57RziKWEWnZGXkx5o8VFdgMeuNDiNOb4)qsO4TyeuA21e4qbbDRZM(F2qtwXDiGHa9WmnFwMn6kGfgjLRINM4OOo3Ikjjz72wB6X3viQJ20GY56CC9Fn9LotbSuJY1gomZVvnl1J00jurMNYQV)RwODW4Kun2Ql7qMUAzUAa06AGgKY0EBuIVY2V5NiHZPTFaaFK1xP8DXFH6FCyE5bSZ60H)CF5I=" as="script" /><script>var LPPreInit={version:"01218.3",status:0};</script><link rel="stylesheet" href="https://lp.vg/css/ds01218.3/j2HKnp0oKDOVoos8SA3Bpy3UHd7cAufta4eroYaXMYvxFuRA8ykjub9LnljwiyZ(Ho5EV7u8sDx6g)gMvHadnHlvbESIYJ1X6oeAghqHEshdvvI473HCzerwIb2juyuPKT8OTLHfuZgKateNm4TWxrNbcJF76)WXsXrqF2gAZSoyrDeFDbyj)cFCwis69h3CboX1do29vAaXKGVNqtsflqVx01a7xcrL8RpkHHFsqZwRNwD5laTCXGja1s1WPvb)I8FZ/NKGS35HhGdM28kV5Z5BArPjXoC7jBHKu(ywMVDdSW31RbPFL7nbavW)JN4lnsVeZ6SHo3qzBtwDmsyvWIIloUgbndTtTYRlwZZBJuGexDcWMA5U9FEsCbk4DBndQKcff6AxqIT4jHSfQ3vP()YshYgvKBPArMotDFLaCbz1v)kJOSJ0utGisWCgaOB)M6SEccP8pUVoCdXt4qJuB19RmMR98Zj0NlODiPkrWKRo=" /><style>html,body,#pagewidth{min-width:968px;}</style><script async src="https://www.googletagmanager.com/gtm.js?id=GTM-D86W"></script><script>var dataLayer=dataLayer||[];dataLayer.push({"gtm.start":+new Date,event:"gtm.js"});</script></head><body data-id="4930161057028"><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-D86W" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><form method="post" action="/news/335976" id="MainForm"><div class="aspNetHidden"><input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" /></div><div id="header"><div id="headerContent"><a class="logo" href="/"><img id="LPLogo" src="https://lp.vg/images/lp_logo.png" srcset="https://lp.vg/images/lp_logo-1.5x.png 1.5x,https://lp.vg/images/lp_logo-2x.png 2x,https://lp.vg/images/lp_logo-3x.png 3x,https://lp.vg/images/lp_logo-4x.png 4x" width="220" height="80" alt="Lottery Post" /></a><div id="AUHead" class="AU AUStandard AUSize728x90" style="width:728px;height:90px"><script>googletag.cmd.push(function(){googletag.display('AUHead')})</script></div></div></div><div id="pagewidth"><div id="loginblock"><div id="bcSearch">&nbsp;</div><strong>Welcome&nbsp;Guest</strong><img src="/b.gif" alt="" /><br /> (&nbsp;<a title="Log in to your Lottery Post membership." href="/login">Log In</a> | <a title="Sign up for a free Lottery Post membership." href="/register">Register</a>&nbsp;) </div><table id="mainframework" border="0" cellspacing="10" cellpadding="0"><tr><td id="mainframeworkleft"><div id="leftnav" class="pod withtitle"><p class="title">Quick Links</p><ul><li><a title="Lottery Post Home Page" href="/">Home</a></li><li class="lnBig"><a class="icon-memberships" title="Compare features between Lottery Post memberships" href="/memberships">Premium Memberships</a></li><li><a title="Go to the main forums page, see description of each forum" href="/forums">Forums</a></li><li><a title="Go to the Predictions main page" href="/predictions">Predictions</a></li><li><a title="View all lottery news stories, one month at a time" href="/news">News</a></li><li><a title="Go to the Lottery Results main page" href="/results">Lottery Results</a></li><li><a title="The world&#39;s most powerful lottery results search engine" href="/results/search">Search Drawings</a></li><li><a title="All the lottery systems and methods available at Lottery Post" href="/systems">Lottery Systems</a></li><li><a title="Lottery charts and data tables for Pick 3, Pick 4, and Quinto" href="/charts">Lottery Charts</a></li><li><a title="The world&#39;s best Full, Key, and Abbreviated lottery wheels, including custom (filtered) wheels" href="/wheels">Lottery Wheels</a></li><li><a title="Sorted listing of current worldwide jackpots" href="/jackpots">Worldwide Jackpots</a></li><li><a title="Generate random numbers (&quot;Quick Picks&quot;) for any lottery game" href="/quickpicks">Quick Picks</a></li><li><a title="View historical events at Lottery Post and around the world that happened on today's date" href="/onthisday">On This Day in History</a></li><li><a title="See the blogs (personal web journals) of all Lottery Post members" href="/blogs">Blogs</a></li><li><a title="Play Lottery Post&#39;s online games" href="/games">Online Games</a></li><li><a title="Contact the Lottery Post staff by e-mail" href="/contact">Contact Us</a></li><li><a title="Support Lottery Post by whitelisting lotterypost.com in your ad blocker" href="/whitelist">Whitelist Lottery Post</a></li><li><a title="View the Lottery Post forum rules" href="/rules">Rules</a></li><li class="lnBig"><a class="icon-books" title="Large selection of lottery books" href="/books">Lottery Book Store</a></li><li class="lnBig"><a class="icon-gift" title="Lottery Post Gift Shop" href="http://www.cafepress.com/lotterypost/">Lottery Post Gift Shop</a></li><li class="lnBig"><a class="icon-facebook" title="Lottery Post Facebook page" href="https://www.facebook.com/LotteryPost">Visit us on Facebook</a></li><li class="lnBig"><a class="icon-twitter" title="Lottery Post Twitter page" href="https://www.twitter.com/lotterypost">Follow us on Twitter</a></li><li class="lnBig"><a class="icon-youtube" title="Lottery Post YouTube page" href="https://www.youtube.com/lotterypost">Subscribe on YouTube</a></li></ul><a title="Powerball and Mega Millions lottery results and news" href="https://www.usamega.com/"><img src="https://lp.vg/images/usa-mega-button-2.png" class="usamega" width="140" height="97" alt="USA Mega" /></a><a class="tile140" title="Lottery Places free app for iPhone, Android, and Windows" href="https://www.lotteryplaces.com/"><img src="https://lp.vg/images/LotteryPlaces_140x375.jpg" srcset="https://lp.vg/images/LotteryPlaces_140x375_1.5x.jpg 1.5x,https://lp.vg/images/LotteryPlaces_140x375_2x.jpg 2x" width="140" height="375" alt="Lottery Places" /></a><div id="MasterAuLeft" class="masterAuLeft AU AUStandard AUSize120x600" style="width:120px;height:600px"><script>googletag.cmd.push(function(){googletag.display('MasterAuLeft')})</script></div><div id="AmazonAu"><div id="amazonAu"><a href="https://amzn.to/2xkCMe0" class="amazonLogo whiteglass" rel="external nofollow noopener"><ins></ins></a><div class="amazonContent"><a href="https://amzn.to/2wFWSCe" title="Lottery Post 2012 Lottery Results Almanac, United States Edition" rel="external noopener"><img src="https://lp.vg/images/amazon/Results2012-US-FrontCover-57x72.jpg" srcset="https://lp.vg/images/amazon/Results2012-US-FrontCover-57x72-1.5x.jpg 1.5x,https://lp.vg/images/amazon/Results2012-US-FrontCover-57x72-2x.jpg 2x" class="amazonBookIcon" width="57" height="72" alt="Lottery Post 2012 Lottery Results Almanac, United States Edition" /></a><a href="https://amzn.to/2wFWSCe" title="Lottery Post 2012 Lottery Results Almanac, United States Edition" rel="external noopener">2012 Lottery Results Almanac, USA Edition</a><br />by Todd Northrop</div><div class="amazonGoStore"><a id="" href="/books" class="CB CB-Box amazonGoStoreButton"><span>More lottery books</span></a></div></div></div><ul class="tinylist"><li><a title="Online JavaScript Compressor, featuring YUI Compressor and Microsoft Ajax Minifier" href="/js-compress.aspx">JavaScript Compressor</a></li><li><a title="Online CSS Compressor" href="/css-compress.aspx">CSS Compressor</a></li><li><a title="MyBrowserInfo.com" onclick="this.target=&#39;_blank&#39;;" rel="noopener" href="https://mybrowserinfo.com/">Browser Information</a></li></ul></div><div id="LastVisitPanel" class="leftnavbox pod"><div class="minortextwrapper">You&nbsp;last&nbsp;visited March&nbsp;11,&nbsp;2021, 6:52&nbsp;pm</div></div><div class="leftnavbox pod"><div class="minortextwrapper"> All times shown are<br />Eastern Time (GMT-5:00) <div class="smallFootNote"><a title="Update your time zone" rel="nofollow" href="/control_account.asp">Update your time zone</a></div></div></div></td><td id="mainframeworkbody"><div id="breadcrumb" class="clr"><div id="bcLike" class="pageShare"><label>Recommend<br />Lottery Post</label><div><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.lotterypost.com%2F" rel="external noopener"><img src="https://lp.vg/images/facebook-share.png" width="60" height="20" alt="Recommend Lottery Post on Facebook"/></a></div></div><script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":{"@type":"Thing","@id":"https://www.lotterypost.com/"}},{"@type":"ListItem","position":2,"name":"Forums","item":{"@type":"Thing","@id":"https://www.lotterypost.com/forums"}},{"@type":"ListItem","position":3,"name":"Lottery News","item":{"@type":"Thing","@id":"https://www.lotterypost.com/forum/11"}},{"@type":"ListItem","position":4,"name":"Idaho ends Powerball in state, fearing foreign participation","item":{"@type":"Thing","@id":"https://www.lotterypost.com/news/335976"}}]}</script><ol><li><a href="/" title="Lottery Post Home Page">Home</a></li>&nbsp;&rsaquo; <li><a href="/forums" title="Forums">Forums</a></li>&nbsp;&rsaquo; <li><a href="/forum/11" title="Lottery News">Lottery News</a></li>&nbsp;&rsaquo; <li title="Idaho ends Powerball in state, fearing foreign participation">Idaho ends Powerball in state, fearing foreign participation</li></ol></div><div id="LP_NewsStory" class="newsstorywrapper"><div class="newsstory"><h1 id="LP_NewsHeadline" class="headline">Idaho ends Powerball in state, fearing foreign participation</h1><div class="maincol"><div class="newsbyline"><p id="LP_NewsByline" class="publishdate">Mar 11, 2021, 6:25 am</p><p id="LP_NewsComments" class="newscommentslink"><a id="LP_ctl13" href="javascript:;" title="Scroll down to comments" class="CB" data-sprite="say" data-click="$.scrollTo('#newsEnd',{offset:{top:-10}});return false;"><span>18 comments</span></a></p></div><div id="LP_NewsShare" class="pageShare"><label>Recommend This</label><div><a href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fwww.lotterypost.com%2fnews%2f335976" rel="external noopener"><img src="https://lp.vg/images/facebook-share.png" width="60" height="20" alt="Share this news story on Facebook"/></a></div><div><a href="https://twitter.com/share?url=https%3a%2f%2fwww.lotterypost.com%2fnews%2f335976&text=Idaho+ends+Powerball+in+state%2c+fearing+foreign+participation&via=LotteryPost" rel="external noopener"><img src="https://lp.vg/images/twitter-tweet.png" width="60" height="20" alt="Tweet this news story on Twitter"/></a></div></div><div id="newsbody"><div id="newsQuickOptions"><img id="LP_NewsIcon" src="/images/newsicon_powerball_335976.jpg" width="140" height="100" class="newsphoto" alt="Powerball" title="Powerball: Idaho ends Powerball in state, fearing foreign participation" /><small id="LP_NewsIconCaption">Powerball: Idaho ends Powerball in state, fearing foreign participation</small><ul style="margin: 10px 0 0;padding: 0;list-style-type:none;"><li><a id="LP_NewsEmail" href="/e-mail_topic.asp?tp=335976" title="E-mail this story to a friend" class="CB" data-sprite="mail" data-newwindow="1"><span>E-mail to a friend</span></a></li><li><a id="LP_NewsPrint" href="/print-topic.asp?tp=335976" title="Open a plain version of this news story that is better for printing" class="CB" data-sprite="print" data-newwindow="1"><span>Printer-friendly</span></a></li><li><a id="LP_NewsLink" href="javascript:;" title="Display the permanent link (&quot;permalink&quot;) to this news story" class="CB" data-sprite="link" data-click="return ThreadPage.showPermaLink('https://www.lotterypost.com/news/335976','Idaho+ends+Powerball+in+state%2c+fearing+foreign+participation',this);"><span>Link to this story</span></a></li></ul><span class="ratethis">Rating:</span><span id="rating335976"></span></div><div id="LP_NewsContent"><p><span itemprop="dateline">BOISE, Idaho</span>&nbsp;&mdash; Idaho lawmakers fearing foreign participation in the Powerball lottery killed legislation on Wednesday that would have allowed the game with huge jackpots to continue in the state after a run of more than 30 years.</p><p>The move came after Idaho Lottery officials sought a change in state law because Powerball is expanding to include Australia in 2021 and Britain in&nbsp;2022. But current Idaho law only allows lotteries in the state played by people in the U.S. and Canada.</p><p>Idaho was one of the first states to join Powerball in the 1990s. The lottery has since grown to include 45 states, two U.S. territories and Washington, D.C. The Multi-State Lottery Association runs the game.</p><p>Idaho's Legislature is dominated by Republicans, but objections to the change also emerged from Democrats. The killing of the bill by a 10-4 vote by the Legislature's House State Affairs Committee means that the state's last Powerball drawing will be in August.</p><p>Republican Rep. Heather Scott worried that when Australia joins Powerball, the country's officials might use revenue generated for government coffers to back causes she opposes.</p><p>Scott expressed concern that could happen &quot;in Australia anti-gun causes, which they see as good and we see as not good.&quot;</p><p>Democratic Rep. Chris Mathias said the Powerball in Idaho has been good for business and that the state took millions for public education, but had concerns that more countries might be added to the Powerball participation roster.</p><p>&quot;My concern is the delegation of authority, and essentially turning over our sovereignty to this Multi-State Lottery Association,&quot; he said. &quot;I think we should be concerned that they could be persuaded, they could be lobbied heavily by countries that we are not particularly friendly with.&quot;</p><p>Mathias wanted the bill amended to reflect those concerns, and voted with another Democratic representative and two Republicans against killing the legislation.</p><p>Idaho lottery officials have said the game generates about $28&nbsp;million in sales annually in the state, with schools receiving about $14&nbsp;million per year.</p><p>Money generated from Powerball ticket sales is held in trust until there's a winner. The addition of two new countries and more players is expected to increase jackpot sizes.</p><p>&quot;This is a big jackpot game, so players like to have big jackpots,&quot; Jeff Anderson, director of the Idaho Lottery, told lawmakers. &quot;One of the ways to do that is to have more players in the game.&quot;</p><p>Idaho's biggest Powerball winner was a resident of the small southwestern city of Star, who won $220&nbsp;million in&nbsp;2005.</p><p>Some Idaho lawmakers said they feared that the odds of an Idaho resident winning would be reduced with more players.</p><p>But the odds remain the same no matter how many players take part because the odds are not based on the number of players, but the chances of particular numbers being selected. If there are multiple winners, jackpots are split.</p><p>Anderson tried to convince lawmakers to make the change in state law by assuring them that a country like China &mdash; with a different legal system than the the U.S., Australia and Britain &mdash; would never be allowed to join.</p><p>Republican Rep. Bruce Skaug said he was troubled about the $3&nbsp;million annually that is spent on advertising to convince people to play Powerball. He proposed the motion that killed the legislation.</p><p>&quot;What we've got is 32 years of Idahoans being able to participate voluntarily in a lottery game of their choice,&quot; Anderson said after the vote. &quot;Thirty-two years it's been OK, now it's not. It's very troubling.&quot;</p><p>Anderson said that Powerball will end in Idaho on Aug.&nbsp;23 because of the vote.</p><p>He warned that besides the money that Idaho schools will lose, the state will face &quot;untold amounts in expenses to unwind all the advertising commitments we have for billboards and point-of-sale materials and everything else. This is going to be very expensive for the people of Idaho.&quot;</p><p>Officials at the Multi-State Lottery Association in an email declined comment about the Idaho Powerball decision.</p></div></div><div id="LP_AfterNewsBody" class="clr"></div><div id="LP_RelatedLinks" class="newsbox newslinks"><p style="clear: both;font: bold 16px Arial,Helvetica,sans-serif;">Related Links</p><ul class="newslinklist"><li><ins class="sprite-16 sprite-link-ext-16"></ins><a href="https://www.usamega.com/" title="USA Mega - Home of Powerball and Mega Millions">USA Mega - Home of Powerball and Mega Millions</a></li><li><ins class="sprite-16 sprite-link-ext-16"></ins><a href="https://www.lotterypost.com/partner/4" title="Play Powerball online">Play Powerball online</a></li></ul></div><p id="LP_NewsSource" class="newssource"><ins class="sprite-16 sprite-world-16"></ins>AP</p><div id="268110983"><script>_mNHandle.queue.push(function(){_mNDetails.loadTag('268110983','750x200','268110983')});</script></div><p id="LP_NewsFoot" class="newsFootOptions"><strong><ins class="sprite-32 sprite-say-32"></ins>We'd love to see your comments here!&nbsp; <a title="Sign up for a free Lottery Post membership." href="/register">Register for a FREE membership</a>&nbsp;&mdash; it takes just a few moments&nbsp;&mdash; and you'll be able to post comments here and on any of our forums. <span></span>If you're already a member, you can <a title="Log in to your Lottery Post membership." href="/login">Log In</a> to post a comment.</strong></p></div><div class="sidebar"><div class="nextprevstory"></div><div id="fontChanger" class="newsbox clr"><div class="choices styles"><label>Style:</label><ul><li><a id="fontStyle0" style="font-family:Arial,Helvetica,sans-serif;" onclick="return NewsPage?NewsPage.setFontStyle(0):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'style','Narrow');}" href="javascript:;"><span>A</span></a></li><li><a id="fontStyle1" style="font-family:Verdana,Geneva,sans-serif;" onclick="return NewsPage?NewsPage.setFontStyle(1):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'style','Normal');}" href="javascript:;"><span>A</span></a></li><li><a id="fontStyle2" style="font-family:Georgia,'Times New Roman',Times,serif;" onclick="return NewsPage?NewsPage.setFontStyle(2):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'style','Newsprint');}" href="javascript:;"><span>A</span></a></li></ul></div><div class="choices sizes" style="position:relative;"><label>Size:</label><ul><li><a id="fontSize0" style="font-size:8px;" onclick="return NewsPage?NewsPage.setFontSize(0):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'size','Small');}" href="javascript:;"><span>A</span></a></li><li><a id="fontSize1" style="font-size:11px;" onclick="return NewsPage?NewsPage.setFontSize(1):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'size','Normal');}" href="javascript:;"><span>A</span></a></li><li><a id="fontSize2" style="font-size:14px;" onclick="return NewsPage?NewsPage.setFontSize(2):false;" onmouseover="if(NewsPage){NewsPage.fontChangeHover(this,'size','Large');}" href="javascript:;"><span>A</span></a></li></ul></div></div><div id="LP_ctl05" class="newsSideAd AU AUStandard AUSize300x250" style="width:300px;height:250px"><script>googletag.cmd.push(function(){googletag.display('LP_ctl05')})</script></div><div id="LP_RelatedStories" class="sidebox relatedstories"><h1>Related Stories</h1><ul><li><a id="LP_RelatedStoryList_ctl00_0" href="/news/335744" title="Related story: New Michigan bill would allow multi-state lottery winners to remain anonymous" class="CB" data-sprite="news"><span style="white-space:normal;">New Michigan bill would allow multi-state lottery winners to remain anonymous <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Feb&nbsp;14,&nbsp;2021</span></span></a></li><li><a id="LP_RelatedStoryList_ctl00_1" href="/news/335300" title="Related story: Alabama residents cross state lines in droves to play lottery as jackpots soar" class="CB" data-sprite="news"><span style="white-space:normal;">Alabama residents cross state lines in droves to play lottery as jackpots soar <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Jan&nbsp;18,&nbsp;2021</span></span></a></li><li><a id="LP_RelatedStoryList_ctl00_2" href="/news/330898" title="Related story: Former Iowa Gov. Tom Vilsack wins $150,000 lottery prize" class="CB" data-sprite="news"><span style="white-space:normal;">Former Iowa Gov. Tom Vilsack wins $150,000 lottery prize <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Feb&nbsp;11,&nbsp;2020</span></span></a></li><li><a id="LP_RelatedStoryList_ctl00_3" href="/news/326452" title="Related story: Powerball winner-turned lawmaker opposes anonymity for lottery prizewinners" class="CB" data-sprite="news"><span style="white-space:normal;">Powerball winner-turned lawmaker opposes anonymity for lottery prizewinners <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Apr&nbsp;11,&nbsp;2019</span></span></a></li><li><a id="LP_RelatedStoryList_ctl00_4" href="/news/313616" title="Related story: Maine loses Powerball, Mega Millions during state closure" class="CB" data-sprite="news"><span style="white-space:normal;">Maine loses Powerball, Mega Millions during state closure <span style="margin-left:6px;white-space: nowrap;font-size: 90%;color: #888;">Jul&nbsp;2,&nbsp;2017</span></span></a></li></ul></div><div id="LP_StoryTags" class="newsbox tags"><h1 class="tags"><ins class="sprite-24 sprite-globe-checklist-24"></ins>Tags for this news story</h1><ul class="tags"><li><a title="Australia" rel="tag" href="/tag/australia" style="font-size:14px;">Australia</a></li>&#32; <li><a title="Government" rel="tag" href="/tag/government" style="font-size:16px;">Government</a></li>&#32; <li><a title="Idaho" rel="tag" href="/tag/idaho" style="font-size:14px;">Idaho</a></li>&#32; <li><a title="Multi-State Game" rel="tag" href="/tag/multi-state_game" style="font-size:19px;">Multi-State Game</a></li>&#32; <li><a title="Powerball" rel="tag" href="/tag/powerball" style="font-size:19px;">Powerball</a></li>&#32; <li><a title="UK National Lottery" rel="tag" href="/tag/uk_national_lottery" style="font-size:15px;">UK National Lottery</a></li>&#32; </ul><h2>Other Popular Tags</h2><ul class="tags clr"><li><a title="Crime" href="/tag/crime" style="font-size:13px;">Crime</a></li>&#32; <li><a title="Financials" href="/tag/financials" style="font-size:14px;">Financials</a></li>&#32; <li><a title="Insider Buzz" href="/tag/insider_buzz" style="font-size:14px;">Insider Buzz</a></li>&#32; <li><a title="Jackpots" href="/tag/jackpots" style="font-size:17px;">Jackpots</a></li>&#32; <li><a title="Legal" href="/tag/legal" style="font-size:14px;">Legal</a></li>&#32; <li><a title="Legislation" href="/tag/legislation" style="font-size:13px;">Legislation</a></li>&#32; <li><a title="Mega Millions" href="/tag/mega_millions" style="font-size:14px;">Mega Millions</a></li>&#32; <li><a title="Scratch Games" href="/tag/scratch_games" style="font-size:14px;">Scratch Games</a></li>&#32; <li><a title="Winner Stories" href="/tag/winner_stories" style="font-size:18px;">Winner Stories</a></li>&#32; <li><a title="Winning Ticket Announcement" href="/tag/winning_ticket_announcement" style="font-size:14px;">Winning Ticket Announcement</a></li>&#32; <li style="float:right; margin:5px 0 0 10px;"><a title="Display all news story tags (the &quot;Tag Cloud&quot;)" href="/tags" style="font-size:14px;">More &raquo;</a></li></ul></div><div id="LP_ctl07" class="AU AUStandard AUSize300x250" style="width:300px;height:250px"><script>googletag.cmd.push(function(){googletag.display('LP_ctl07')})</script></div></div></div></div><div id="newsEnd"><span id="LP_NewsCommentsDesc" class="commentsDesc">18 comments. Last comment 18 seconds ago by <a href="/member/32034" data-member="32034" class="popmenu gold">Coin Toss</a>.</span><div class="pagerlayout pagerlayoutinline"><table border="0" cellspacing="0" cellpadding="0"><tr><td><span style="margin-right:8px;">Page <strong>1</strong> of <strong>2</strong></span></td><td><div id="LP_PagerNews" class="pagercontrol sprite-pager sprite-pager-dnn"><a href="/news/335976/2" class="pagerhs pagerhsnext" data-id="LP_PagerNews" data-enter="dhn" data-down="dan" data-leave="dnn" title="Forward"></a><a href="javascript:;" class="pagerhs pagerhsmenu" data-id="LP_PagerNews" data-panelid="PagerMenuPanel" data-enter="dnh" data-down="dna" data-leave="dnn" title="Go to Page" onclick="return false"></a></div></td></tr></table></div></div><div id="message" class="pod withtitle fortext clr"><div class="titlelinks"><a id="LP_PreviousTopic" href="javascript:__doPostBack(&#39;ctl00$LP$PreviousTopic&#39;,&#39;&#39;)" title="Previous Topic" class="CB" data-sprite="back"><span>Previous Topic</span></a><a id="LP_NextTopic" href="javascript:__doPostBack(&#39;ctl00$LP$NextTopic&#39;,&#39;&#39;)" title="Next Topic" class="CB CB-ImageRight" data-sprite="next"><span>Next Topic</span></a></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6582766"></a><div class="name"><a href="/member/164645" data-member="164645" class="popmenu platinum"><strong>DELotteryPlyr</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="platinum" title="Platinum Member"></b></div><div class="tag"><b class="rank rank5" title="Senior"></b></div>Maryland<br />United States<br />Member&nbsp;#162429<br />January 2, 2015<br />2480&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T11:57:39Z">Today, 6:57&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="4"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p><span style="font-family: 'Comic Sans MS', 'Comic Sans', Chalkboard, ChalkboardSE-Regular, TSCu_Comic, sans-serif; font-size: 16px;">WOW, very interesting that Powerball is going international.&nbsp; Not sure what to think about it - yet.&nbsp; Wonder how it will be received in those countries.</span></p><div class="signature"><p><span style="font-family: 'Comic Sans MS', 'Comic Sans', Chalkboard, ChalkboardSE-Regular, TSCu_Comic, sans-serif; font-size: 16px;">Money <span style="color: #00ff00;"><em><strong>WON</strong></em></span> is twice as good as money earned <img src="/emoticons/thumbsup.gif" border="0" alt="Thumbs Up" title="Thumbs Up" width="25" height="18" /></span></p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6582797"></a><div class="name"><a href="/member/1" data-member="1" class="popmenu platinum"><strong>Todd</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="https://members.lotterypost.com/todd/images/avatar/Cylon-200.jpg" width="100" height="100" alt="Todd's avatar - Cylon 200.jpg" /></div><div class="tag"><b class="platinum" title="Platinum Member"></b></div><div class="tag"><b class="role admin" title="Lottery Post Administrator"></b></div><div class="tag"><b class="role topposter" title="Top 50 Poster"><i>50</i></b></div><div class="tag">Chief Bottle Washer</div><div class="tag"><b class="rank rank8" title="Elite"></b></div>New Jersey<br />United States<br />Member&nbsp;#1<br />May 31, 2000<br />26116&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T12:25:26Z">Today, 7:25&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="4"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p>I agree DELotteryPlyr, that's the big news here for me too.&nbsp; Many people complain about jackpots being won in other states &mdash; I wonder how they will feel when the jackpot is won by someone in another <strong>country</strong>.</p><p>Edit: To be clear, the Powerball states have been debating going international with the game for many years.&nbsp; They also got close to <a href="/news/84496" rel="external noopener">starting a new international game</a> run by MUSL in&nbsp;2004.&nbsp; But now we apparently have target dates set, and things have progressed to the point that the states are deciding whether or not to stay in the game.</p><div class="signature"><div style="position: relative; margin: 10px 0;"><p style="margin: 0px; width: 52px; background: url('https://lp.vg/images/theme/icon-reportcard-48.png') no-repeat 48% top; float: left; height: 48px;">&nbsp;</p><p style="padding-top: 6px; font-size: 12px;"><a style="border-bottom: #008000 1px dotted; font-family: Comic Sans MS,Comic Sans,Chalkboard,ChalkboardSE-Regular,TSCu_Comic,sans-serif; text-decoration: none;" href="/lottery-report-card.asp" rel="external noopener noopener"><span style="color: #008000;">Check the State Lottery Report Card</span></a><br /><strong style="font-family: Segoe Print,Comic Sans MS,Comic Sans,Chalkboard,ChalkboardSE-Regular,TSCu_Comic,sans-serif; color: #000065;">What grade did your lottery earn?</strong></p><p style="clear: left; margin: 0px; width: 52px; background: url('https://lp.vg/images/theme/icon-clipboardcheck-32.png') no-repeat 48% 15%; float: left; height: 48px;">&nbsp;</p><p style="padding-top: 2px; font-size: 12px;"><a style="border-bottom: #008000 1px dotted; font-family: Comic Sans MS,Comic Sans,Chalkboard,ChalkboardSE-Regular,TSCu_Comic,sans-serif; text-decoration: none;" href="/petition-true-drawings.aspx" rel="external noopener noopener"><span style="color: #008000;">Sign the Petition for&nbsp;True Lottery Drawings</span></a><br /><strong style="font-family: Segoe Print,Comic Sans MS,Comic Sans,Chalkboard,ChalkboardSE-Regular,TSCu_Comic,sans-serif; color: #000065;">Help eliminate computerized drawings!</strong></p></div></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6582821"></a><div class="name"><a href="/member/195079" data-member="195079" class="popmenu"><strong>Big Joey</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank3" title="Experienced"></b></div>Louisiana<br />United States<br />Member&nbsp;#191895<br />August 27, 2018<br />715&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T12:55:30Z">Today, 7:55&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="3"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p><span style="font-family: Tahoma, Kalimati, Arial, Helvetica, sans-serif; font-size: 18px;">Should there be a spin off called International Powerball, alongside the regular Powerball that the states now have? Two versions of Powerball, same Matrix, just the International Powerball has International players playing with the state players.</span></p><div class="signature"><p><strong>All number sets are contenders until the drawing occurs.</strong></p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6582843"></a><div class="name"><a href="/member/34230" data-member="34230" class="popmenu platinum"><strong>Stack47</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="platinum" title="Platinum Member"></b></div><div class="tag"><b class="rank rank7" title="Guru"></b></div>Kentucky<br />United States<br />Member&nbsp;#32651<br />February 14, 2006<br />9100&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T01:41:16Z">Today, 8:41&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="0"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p>Found <a href="https://www.stltoday.com/news/local/govt-and-politics/with-jackpots-down-powerball-looking-to-expand-lottery-game-to-australia/article_acec874e-625a-58e5-8eaa-fd8fa83bede0.html" rel="nofollow external noopener">this article</a> saying PB foreign expansion is still in the discussion stage. Wonder how many other states have laws that restrict joining out of country lottery games.&nbsp;</p><p>Making PB worldwide would certainly boost jackpots and of course sales, but can't imagine what will be said after a series of foreign jackpot winners.</p><div class="signature"><p>It's not my fault! I voted for Amy.</p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6582845"></a><div class="name"><a href="/member/196369" data-member="196369" class="popmenu"><strong>andl</strong></a></div><div class="memberdetailsbox"><div class="tag"><span class="delayedimage"><img id="lp0" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEAAAAALAAAAAABAAEAAAI=" width="64" height="64" alt="andl's avatar - hSk1nCp" /><span class="spinner spinner0 spinner0-size16 spinner0-color3"><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i></span></span></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank1" title="Rookie"></b></div><br />United States<br />Member&nbsp;#193182<br />October 22, 2018<br />20&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T01:41:39Z">Today, 8:41&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="0"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p>Add another Power Ball like Euro Millions does. I want&nbsp; to see billion dollar jackpots every few months.</p></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6582853"></a><div class="name"><a href="/member/151592" data-member="151592" class="popmenu"><strong>ieatdirt</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank2" title="Regular"></b></div><br />United States<br />Member&nbsp;#149390<br />November 30, 2013<br />64&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T02:04:44Z">Today, 9:04&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="1"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p class="p1"><span class="s1">Hmm so let me see if I understand this correctly:<span class="Apple-converted-space">&nbsp;</span> you&rsquo;re concerned that other countries might use their proceeds (in their own country) for political purposes you &ldquo;might not agree with&rdquo; so you use your political power to take away the game entirely.<span class="Apple-converted-space">&nbsp;</span> Makes perfect sense to me.<span class="Apple-converted-space">&nbsp;</span></span></p><p class="p1"><span class="s1">Not to mention that they don&rsquo;t seem to understand that the number of entries has nothing to do with the odds of winning.<span class="Apple-converted-space">&nbsp;</span> Come on, it&rsquo;s not a raffle people.<span class="Apple-converted-space">&nbsp;</span></span></p><p class="p1"><span class="s1">Sounds like the voters of Idaho need to elect a little more intelligent legislators.</span></p></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6582868"></a><div class="name"><a href="/member/19333" data-member="19333" class="popmenu"><strong>Raven62</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/avatars/binary.png" width="64" height="64" alt="Raven62's avatar - binary" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="role topposter" title="Top 25 Poster"><i>25</i></b></div><div class="tag"><b class="rank rank8" title="Elite"></b></div>New Jersey<br />United States<br />Member&nbsp;#17842<br />June 28, 2005<br />140045&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T02:19:02Z">Today, 9:19&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="3"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p><span style="font-size:16px;">Who owns the lottery in USA?</span><br /><br /><span style="font-size:16px;">The Multi-State Lottery Association (MUSL) is an American non-profit, government-benefit association owned and operated by agreement of its 34-member lotteries. MUSL was created to facilitate the operation of multi-jurisdictional lottery games, most notably Powerball.</span></p><div class="signature"><p>A mind once stretched by a new idea never returns to its original dimensions! <br /><br /> Catch-22: A dilemma or difficult circumstance from which there is no escape because of mutually conflicting or dependent conditions. <br /><br /> Corruptissima re publica plurimae leges: When the republic is at its most corrupt the laws are most numerous.</p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6582910"></a><div class="name"><a href="/member/138458" data-member="138458" class="popmenu platinum"><strong>noise-gate</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="platinum" title="Platinum Member"></b></div><div class="tag">Chasing $ Millions.</div><div class="tag"><b class="rank rank6" title="Veteran"></b></div>White Shores- California<br />United States<br />Member&nbsp;#136473<br />December 12, 2012<br />6533&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T04:01:46Z">Today, 11:01&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="1"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p><em><strong><span style="font-family: 'Trebuchet MS', Geneva, Arial, Helvetica, FreeSans, sans-serif; font-size: 16px;">Does this mean we get to play in their lotteries at some point in the future?</span></strong></em></p><div class="signature"><p><span style="font-size: 12px;"><em><strong><span style="font-family: 'Trebuchet MS', Geneva, Arial, Helvetica, sans-serif;">&nbsp;* Voice of Reason *&nbsp; &nbsp;</span></strong></em></span></p><p>&nbsp;</p><p><span style="font-size: 12px;"><em><strong><span style="font-family: 'Trebuchet MS', Geneva, Arial, Helvetica, sans-serif;">People who say it cannot be done should not interrupt those who are doing it- George Bernard Shaw.</span></strong></em></span></p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6582912"></a><div class="name"><a href="/member/172108" data-member="172108" class="popmenu"><strong>travelintrucker</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/avatars/morph.jpg" width="64" height="64" alt="travelintrucker's avatar - morph" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank2" title="Regular"></b></div>Greenville, SC<br />United States<br />Member&nbsp;#169866<br />November 4, 2015<br />387&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T04:02:26Z">Today, 11:02&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="6"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p>I don't like this at all. I'm surprised that Canadians can play in U.S. lotteries.</p><div class="signature"><p><span style="font-size: 16px;"><em><span style="font-family: Lucida Console,Consolas,Courier New,Courier,monospace;">May the balls bounce in your favor!</span> <span style="font-family: Lucida Console,Consolas,Courier New,Courier,monospace;"><br /></span></em></span></p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6582939"></a><div class="name"><a href="/member/29945" data-member="29945" class="popmenu"><strong>paneagle</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank6" title="Veteran"></b></div>florida<br />United States<br />Member&nbsp;#28392<br />December 15, 2005<br />4492&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T04:58:53Z">Today, 11:58&nbsp;am</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="2"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p>LOTTERY TAXATION and the LAW OF MONOPOLY&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; as Idaho points out how the winners are more likely to come from outside and even internationally</p><p>Okay first we need to see THE BIG PICTURE, not just our own small view, because&nbsp;1) LOTTERY IS A Tax FUN'd Raiser for the Government</p><p>2) Lottery is not intended to make winners, and the greater pool means bigger ocean, thus greater chance of loss per person, even less chance to win&nbsp;</p><p>3) LOTTERY is by far the worst gambling choice, with the chances of winning are already ridiculous and the payouts hideously small compared to the rate of win.&nbsp;</p><p>&nbsp;INTERNATIONAL RISK REWARD is increased on both sides, because 4) foreign players outside of chosen countries can win and 5) players rate of win per dollar lost</p><p>These problems exist anyway, despite what local states may do, generally making or pointing the real problem with lottery is GREED and MANIPULATION</p><p>Therefore, THE REALLY BIG IDEA is this : What is really needed is a complete overhaul of lottery, making it an investment to really help people and nations get out of monopoly conditions, which mostly only benefit the lottery or nation organizers, (government) and turning it into a true ALTRUISM that should be mutually inclusive and cooperative, such as funds for charity and organizations that create real BENEFITS,</p><p>THis could be achieved most likely by decreasing the huge prizes but increasing the amount of winners in the middle class spectrum (60K approximately).. But because the greed and law of monopoly is the operating principle, this does not occur, and much of the BALLYHOO about paying for education is hardly equal to the cost and loss to the people.</p><p>FOR THE PEOPLE BY THE PEOPLE, I recall is an originating principle, IS IT NOT?&nbsp; &nbsp; &nbsp;It is time all of you woke up, and see the THORNS in all the ROSEBUDS.</p><p>I am paneagle and am giving away SOLARIS winning numbers daily on lotterypost.com with really true and great lists for PLAYERS of any race or nation or opinion.&nbsp; The reason is because TRUE ALTRUISM is being shared and expressed for the NU AGEIS is here now, this year the first in the 2100 cycle.&nbsp;</p><p>Galactician blogspot will show you more&nbsp; &nbsp;and videos&nbsp; on lottery are included by HEY from the treasure Tree by PANEAGLESONG smile</p></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6582981"></a><div class="name"><a href="/member/19333" data-member="19333" class="popmenu"><strong>Raven62</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/avatars/binary.png" width="64" height="64" alt="Raven62's avatar - binary" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="role topposter" title="Top 25 Poster"><i>25</i></b></div><div class="tag"><b class="rank rank8" title="Elite"></b></div>New Jersey<br />United States<br />Member&nbsp;#17842<br />June 28, 2005<br />140045&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T05:51:54Z">Today, 12:51&nbsp;pm</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="3"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><div class="quote"><label><strong>Quote:</strong> Originally posted by <a href="/member/19333" data-member="19333" class="popmenu">Raven62</a> on March 11, 2021</label><div class="quotebody"><p><span style="font-size:16px;">Who owns the lottery in USA?</span><br /><br /><span style="font-size:16px;">The Multi-State Lottery Association (MUSL) is an American non-profit, government-benefit association owned and operated by agreement of its 34-member lotteries. MUSL was created to facilitate the operation of multi-jurisdictional lottery games, most notably Powerball.</span></p></div></div><p><span style="font-family:Courier New, Courier, monospace;"><span style="font-size:16px;">Members (38): <br /><br /> Arizona Lottery <br /> Arkansas Lottery <br /> Colorado Lottery <br /> Connecticut Lottery Corporation <br /> D.C. Lottery &amp; CGCB <br /> Delaware State Lottery <br /> Florida Lottery <br /> Hoosier Lottery <br /> Idaho Lottery <br /> Iowa Lottery <br /> Kansas Lottery <br /> Kentucky Lottery Corporation <br /> Louisiana Lottery Corporation <br /> Maine Lottery <br /> Minnesota State Lottery <br /> Mississippi Lottery Corporation <br /> Missouri Lottery <br /> Montana Lottery <br /> Nebraska Lottery <br /> New Hampshire Lottery Commission <br /> New Mexico Lottery Authority <br /> New York Lottery <br /> North Carolina Education Lottery <br /> North Dakota Lottery <br /> Oklahoma Lottery <br /> Oregon Lottery <br /> Pennsylvania Lottery <br /> Loteria Electronica de Puerto Rico <br /> Rhode Island Lottery <br /> South Carolina Education Lottery <br /> South Dakota Lottery <br /> Tennessee Education Lottery <br /> Texas Lottery <br /> Vermont Lottery <br /> U.S. Virgin Islands Lottery <br /> Wisconsin Lottery <br /> West Virginia Lottery <br /> Wyoming Lottery</span></span></p><div class="signature"><p>A mind once stretched by a new idea never returns to its original dimensions! <br /><br /> Catch-22: A dilemma or difficult circumstance from which there is no escape because of mutually conflicting or dependent conditions. <br /><br /> Corruptissima re publica plurimae leges: When the republic is at its most corrupt the laws are most numerous.</p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6583052"></a><div class="name"><a href="/member/22053" data-member="22053" class="popmenu"><strong>Think</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/avatars/lightbulb.jpg" width="64" height="64" alt="Think's avatar - lightbulb" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank3" title="Experienced"></b></div>Marquette, MI<br />United States<br />Member&nbsp;#20540<br />August 20, 2005<br />925&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T06:58:00Z">Today, 1:58&nbsp;pm</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="2"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p>Hmmm... &quot;5-eye&quot; Powerball? <br /><br /> I already have stopped playing as often as I used to because of the terrible odds.&nbsp; I might play once just before $150&nbsp;Million and then wait until the cash amount is over a certain amount in the hundreds of millions just because the odds really are awful and nobody ever wins. <br /><br /> When the odds get upped again I will quit totally. <br /><br /> If Mega Millions is smart they will go back to 175 million to 1 odds and&nbsp; go with a $3 tik/ $2 plier ($5) ticket that people actually win on with jackpots up to $650-$700&nbsp;million and great second prizes raining down all over every state.&nbsp; There is little hope of that however. <br /><br /> I don't understand why Idaho doesn't like sending money overseas when there are some states right here in the U.S. which they also probably really object to sending money to.&nbsp; It really does not make much sense and indicates a lack of depth of analysis on their part.</p></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6583053"></a><div class="name"><a href="/member/83566" data-member="83566" class="popmenu platinum"><strong>sully16</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/avatars/sharan.png" width="64" height="64" alt="sully16's avatar - sharan" /></div><div class="tag"><b class="platinum" title="Platinum Member"></b></div><div class="tag"><b class="role topposter" title="Top 25 Poster"><i>25</i></b></div><div class="tag">Dr.President Elect</div><div class="tag"><b class="rank rank8" title="Elite"></b></div>Michigan<br />United States<br />Member&nbsp;#81738<br />October 28, 2009<br />82199&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T06:58:28Z">Today, 1:58&nbsp;pm</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="5"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p><span style="font-size: 16px;">Idaho has many great games, I think the gamblers would support those games, plus the odds are better.</span></p><p><span style="font-size: 16px;"><img src="/emoticons/coffee.gif" border="0" alt="Coffee" title="Coffee" width="32" height="32" /></span></p><div class="signature"><p><img src="/emoticons/type.gif" border="0" alt="Type" title="Type" width="40" height="15" /> hehehehehehe.</p></div></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div><table class="threadframework" border="0"><tr><td class="memberinfo"><a id="i6583101"></a><div class="name"><a href="/member/208489" data-member="208489" class="popmenu"><strong>PHIL85</strong></a></div><div class="memberdetailsbox"><div class="tag"><img src="/images/theme/icon-avatar-64.png" width="64" height="64" class="avatar" alt="Avatar" /></div><div class="tag"><b class="standard" title="Standard Member"></b></div><div class="tag"><b class="rank rank1" title="Rookie"></b></div><br />United States<br />Member&nbsp;#205225<br />March 19, 2020<br />23&nbsp;Posts<br />Offline</div></td><td class="content"><div class="posthead"><div><time datetime="2021-03-11T08:01:26Z">Today, 3:01&nbsp;pm</time></div><div><a href="javascript:;" class="upvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Upvote" role="button" aria-label="Upvote">&#9650;</a><i class="score" title="3"></i><a href="javascript:;" class="downvote CB CB-Symbol" data-click="return ThreadPage.scoreNA();" title="Downvote" role="button" aria-label="Downvote">&#9660;</a></div><div></div></div><div class="lpThreadContent"><p>I would be completely opposed to the Powerball game adding additional countries. If I'm playing the game [which I do consistently] trying to win the jackpot and it was won by someone in another country I would be very upset. Even if I'm not the winner at least I can take solace in the fact the taxes and spending would benefit a neighboring state.</p><p>Bottom line - if other countries join I will permanently cease playing Powerball.</p></div></td></tr><tr><td class="memberinfo"><!-- --></td><td class="content"><ul class="ForumPostStatistics"></ul></td></tr></table></div><div class="podseparator"></div><div class="podfooter"><table border="0" class="podfooterlayout"><tr><td class="left"> &nbsp; </td><td class="center"><div class="pagerlayout pagerlayoutinline"><table border="0" cellspacing="0" cellpadding="0"><tr><td><span style="margin-right:8px;">Page <strong>1</strong> of <strong>2</strong></span></td><td><div id="LP_PagerFoot" class="pagercontrol sprite-pager sprite-pager-dnn"><a href="/news/335976/2" class="pagerhs pagerhsnext" data-id="LP_PagerFoot" data-enter="dhn" data-down="dan" data-leave="dnn" title="Forward"></a><a href="javascript:;" class="pagerhs pagerhsmenu" data-id="LP_PagerFoot" data-panelid="PagerMenuPanel" data-enter="dnh" data-down="dna" data-leave="dnn" title="Go to Page" onclick="return false"></a></div></td></tr></table></div></td><td class="right"><span class="nobr"></span></td></tr></table><div id="LP_RssFoot" class="podRssSection"><a id="LP_NewsRss" href="/rss/news/335976" title="Subscribe to the RSS feed for this news story and comments" class="CB" data-sprite="feed"><span>Subscribe to this news story</span></a></div></div></div><table class="blockAuLayout"><tr><td><div id="LP_FooterBannerAd" class="AU AUStandard AUSize468x60" style="width:468px;height:60px"><script>googletag.cmd.push(function(){googletag.display('LP_FooterBannerAd')})</script></div></td><th><div id="LP_FooterBlockAd" class="AU AUStandard AUSize300x250" style="width:300px;height:250px"><script>googletag.cmd.push(function(){googletag.display('LP_FooterBlockAd')})</script></div></th></tr></table></td></tr></table><ul id="mainMenu" class="jqMenu nonMbr" style="display:none;visibility:hidden"><li id="menuSpaceL"></li><li class="mainMenu"><a href="/forums">Forums</a><ul class="jqMenuPanel"><li><a href="/activetopics">Active Topics</a></li><li><a href="/search">Search</a></li><li><a href="/dailytopics" class="mbrOnly">Daily Topics</a></li><li class="title">General Discussion</li><li><a href="/forum/1">Lottery Discussion</a></li><li><a href="/forum/11">Lottery News</a></li><li><a href="/forum/10">Lottery Systems</a></li><li><a href="/forum/12">Mathematics</a></li><li><a href="/forum/13">Mystical</a></li><li><a href="/forum/2">Gaming</a></li><li class="title">Specific Lottery Games</li><li><a href="/forum/3">Pick 3</a></li><li><a href="/forum/4">Pick 4</a></li><li><a href="/forum/5">Pick 5</a></li><li><a href="/forum/6">Jackpot Games</a></li><li><a href="/forum/8">Instant ("Scratch-Off") Games</a></li><li class="title">Lottery Post Administration</li><li><a href="/help">Help</a></li><li><a href="/forum/7">Suggestions</a></li></ul></li><li class="mainMenu"><a href="/results">Results</a><ul class="jqMenuPanel"><li><a href="/results">Lottery Results Home Page</a></li><li class="sep"></li><li><a href="/results/search" class="mbrOnly">Search Past Results</a></li><li><a href="/results/custom" class="mbrOnly">Custom Lottery Results</a></li><li><a href="/results/daily" class="mbrOnly">Daily Numbers Games</a></li><li><a href="/results/all" class="mbrOnly">All Results on One Page</a></li><li class="sep"></li><li><a href="#">United States</a><ul class="jqMenuPanel cols3"><li><a href="/results/az">Arizona</a></li><li><a href="/results/ar">Arkansas</a></li><li><a href="/results/ca">California</a></li><li><a href="/results/co">Colorado</a></li><li><a href="/results/ct">Connecticut</a></li><li><a href="/results/de">Delaware</a></li><li><a href="/results/fl">Florida</a></li><li><a href="/results/ga">Georgia</a></li><li><a href="/results/id">Idaho</a></li><li><a href="/results/il">Illinois</a></li><li><a href="/results/in">Indiana</a></li><li><a href="/results/ia">Iowa</a></li><li><a href="/results/ks">Kansas</a></li><li><a href="/results/ky">Kentucky</a></li><li><a href="/results/la">Louisiana</a></li><li><a href="/results/me">Maine</a></li><li><a href="/results/md">Maryland</a></li><li><a href="/results/ma">Massachusetts</a></li><li><a href="/results/mi">Michigan</a></li><li><a href="/results/mn">Minnesota</a></li><li><a href="/results/ms">Mississippi</a></li><li><a href="/results/mo">Missouri</a></li><li><a href="/results/mt">Montana</a></li><li><a href="/results/ne">Nebraska</a></li><li><a href="/results/nh">New Hampshire</a></li><li><a href="/results/nj">New Jersey</a></li><li><a href="/results/nm">New Mexico</a></li><li><a href="/results/ny">New York</a></li><li><a href="/results/nc">North Carolina</a></li><li><a href="/results/nd">North Dakota</a></li><li><a href="/results/oh">Ohio</a></li><li><a href="/results/ok">Oklahoma</a></li><li><a href="/results/or">Oregon</a></li><li><a href="/results/pa">Pennsylvania</a></li><li><a href="/results/pr">Puerto Rico</a></li><li><a href="/results/ri">Rhode Island</a></li><li><a href="/results/sc">South Carolina</a></li><li><a href="/results/sd">South Dakota</a></li><li><a href="/results/tn">Tennessee</a></li><li><a href="/results/tx">Texas</a></li><li><a href="/results/vt">Vermont</a></li><li><a href="/results/va">Virginia</a></li><li><a href="/results/wa">Washington</a></li><li><a href="/results/dc">Washington, D.C.</a></li><li><a href="/results/wv">West Virginia</a></li><li><a href="/results/wi">Wisconsin</a></li><li><a href="/results/wy">Wyoming</a></li></ul></li><li><a href="#">Canada</a><ul class="jqMenuPanel"><li><a href="/results/ac">Atlantic Canada</a></li><li><a href="/results/bc">British Columbia</a></li><li><a href="/results/on">Ontario</a></li><li><a href="/results/qc">Québec</a></li><li><a href="/results/wc">Western Canada</a></li></ul></li><li><a href="#">Europe</a><ul class="jqMenuPanel"><li><a href="/results/germany">Germany</a></li><li><a href="/results/ie">Ireland</a></li><li><a href="/results/italy">Italy</a></li><li><a href="/results/uk">United Kingdom</a></li></ul></li><li><a href="#">Multi-Jurisdiction</a><ul class="jqMenuPanel"><li><a href="/results/xx">Multi-State (United States)</a></li><li><a href="/results/zz">Multi-Province (Canada)</a></li><li><a href="/results/yy">Multi-Country</a></li></ul></li><li class="sep"></li><li><a href="/jackpots">Current Lottery Jackpots</a></li><li class="sep"></li><li><a href="/gadget">Lottery Results Gadget for Windows</a></li><li><a href="/lottery-report-card.asp">State Lottery Report Card</a></li><li><a href="/petition-true-drawings.aspx">Help Eliminate Computerized Drawings</a></li></ul></li><li class="mainMenu"><a href="/predictions">Predictions</a><ul class="jqMenuPanel"><li><a href="/predictions">Predictions Home Page</a></li><li class="sep"></li><li><a href="#">United States</a><ul class="jqMenuPanel cols3"><li><a href="/predictions-state.asp?s=az">Arizona</a></li><li><a href="/predictions-state.asp?s=ar">Arkansas</a></li><li><a href="/predictions-state.asp?s=ca">California</a></li><li><a href="/predictions-state.asp?s=co">Colorado</a></li><li><a href="/predictions-state.asp?s=ct">Connecticut</a></li><li><a href="/predictions-state.asp?s=de">Delaware</a></li><li><a href="/predictions-state.asp?s=fl">Florida</a></li><li><a href="/predictions-state.asp?s=ga">Georgia</a></li><li><a href="/predictions-state.asp?s=id">Idaho</a></li><li><a href="/predictions-state.asp?s=il">Illinois</a></li><li><a href="/predictions-state.asp?s=in">Indiana</a></li><li><a href="/predictions-state.asp?s=ia">Iowa</a></li><li><a href="/predictions-state.asp?s=ks">Kansas</a></li><li><a href="/predictions-state.asp?s=ky">Kentucky</a></li><li><a href="/predictions-state.asp?s=la">Louisiana</a></li><li><a href="/predictions-state.asp?s=me">Maine</a></li><li><a href="/predictions-state.asp?s=md">Maryland</a></li><li><a href="/predictions-state.asp?s=ma">Massachusetts</a></li><li><a href="/predictions-state.asp?s=mi">Michigan</a></li><li><a href="/predictions-state.asp?s=mn">Minnesota</a></li><li><a href="/predictions-state.asp?s=ms">Mississippi</a></li><li><a href="/predictions-state.asp?s=mo">Missouri</a></li><li><a href="/predictions-state.asp?s=mt">Montana</a></li><li><a href="/predictions-state.asp?s=ne">Nebraska</a></li><li><a href="/predictions-state.asp?s=nh">New Hampshire</a></li><li><a href="/predictions-state.asp?s=nj">New Jersey</a></li><li><a href="/predictions-state.asp?s=nm">New Mexico</a></li><li><a href="/predictions-state.asp?s=ny">New York</a></li><li><a href="/predictions-state.asp?s=nc">North Carolina</a></li><li><a href="/predictions-state.asp?s=nd">North Dakota</a></li><li><a href="/predictions-state.asp?s=oh">Ohio</a></li><li><a href="/predictions-state.asp?s=ok">Oklahoma</a></li><li><a href="/predictions-state.asp?s=or">Oregon</a></li><li><a href="/predictions-state.asp?s=pa">Pennsylvania</a></li><li><a href="/predictions-state.asp?s=pr">Puerto Rico</a></li><li><a href="/predictions-state.asp?s=ri">Rhode Island</a></li><li><a href="/predictions-state.asp?s=sc">South Carolina</a></li><li><a href="/predictions-state.asp?s=sd">South Dakota</a></li><li><a href="/predictions-state.asp?s=tn">Tennessee</a></li><li><a href="/predictions-state.asp?s=tx">Texas</a></li><li><a href="/predictions-state.asp?s=vt">Vermont</a></li><li><a href="/predictions-state.asp?s=va">Virginia</a></li><li><a href="/predictions-state.asp?s=wa">Washington</a></li><li><a href="/predictions-state.asp?s=dc">Washington, D.C.</a></li><li><a href="/predictions-state.asp?s=wv">West Virginia</a></li><li><a href="/predictions-state.asp?s=wi">Wisconsin</a></li><li><a href="/predictions-state.asp?s=wy">Wyoming</a></li></ul></li><li><a href="#">Canada</a><ul class="jqMenuPanel"><li><a href="/predictions-state.asp?s=ac">Atlantic Canada</a></li><li><a href="/predictions-state.asp?s=bc">British Columbia</a></li><li><a href="/predictions-state.asp?s=on">Ontario</a></li><li><a href="/predictions-state.asp?s=qc">Québec</a></li><li><a href="/predictions-state.asp?s=wc">Western Canada</a></li></ul></li><li><a href="#">Europe</a><ul class="jqMenuPanel"><li><a href="/predictions-state.asp?s=02">Germany</a></li><li><a href="/predictions-state.asp?s=ie">Ireland</a></li><li><a href="/predictions-state.asp?s=uk">United Kingdom</a></li></ul></li><li><a href="#">Multi-Jurisdiction</a><ul class="jqMenuPanel"><li><a href="/predictions-state.asp?s=xx">Multi-State (United States)</a></li><li><a href="/predictions-state.asp?s=zz">Multi-Province (Canada)</a></li><li><a href="/predictions-state.asp?s=yy">Multi-Country</a></li></ul></li><li class="sep"></li><li><a href="/predictions-winners.asp">See Yesterday's Winners</a></li><li><a href="/predictions-statistics-top.asp">Top Predictors</a></li><li class="sep"></li><li><a href="/predictions-member.asp" class="disabled">My Predictions</a></li><li><a href="/predictions-statistics.asp" class="disabled">My Prediction Statistics</a></li><li><a href="/post-prediction-form.asp" class="mbrOnly">Post Predictions</a></li><li class="sep"></li><li><a href="/wheels">Lottery Wheels</a></li><li><a href="/deflate3.asp" class="mbrOnly">Deflate 3 Number Reduction System</a></li><li><a href="/deflate4.asp" class="mbrOnly">Deflate 4 Number Reduction System</a></li><li><a href="/deflate5.asp" class="mbrOnly">Deflate 5 Number Reduction System</a></li><li><a href="/inspector3.asp" class="mbrOnly">Inspector 3 Number Classification System</a></li><li><a href="/inspector4.asp" class="mbrOnly">Inspector 4 Number Classification System</a></li></ul></li><li class="mainMenu"><a href="/memberships">Members</a><ul class="jqMenuPanel"><li><a href="/login">Log In</a></li><li><a href="/register">Register for a Free Membership</a></li><li class="sep"></li><li><a href="/memberships">Compare Membership Features</a></li><li class="sep"></li><li><a href="/memberlist" class="mbrOnly">Member List</a></li><li class="sep"></li><li><a href="/member/profile" class="disabled">My Profile</a></li><li><a href="/member/recentposts" class="disabled">My Recent Posts</a></li><li><a href="/member/favorites" class="disabled">My Favorites</a></li><li><a href="/control_subs.asp" class="disabled">My Subscriptions</a></li><li><a href="/blocklist.aspx" class="disabled">My Block List</a></li><li><a href="/imagemanager.aspx" class="disabled">My Images (Image Manager)</a></li><li class="sep">&nbsp;</li><li><a href="/blogs">Blogs Home Page</a></li><li><a href="/blog" class="disabled">My Blog</a></li><li><a href="/new-blog.aspx" class="mbrOnly">Post New Blog Entry</a></li><li><a href="/search/blogs">Search Blogs</a></li><li><a href="/control_blog.asp" class="mbrOnly">Premium Blog Settings</a></li><li class="sep"></li><li><a href="/features.asp">Premium Features</a></li><li><a href="/buy-membership.asp">Buy/Renew Membership</a></li></ul></li><li class="mainMenu"><a href="/systems">Systems</a><ul class="jqMenuPanel"><li><a href="/systems">Lottery Systems Home page</a></li><li class="sep"></li><li><a href="/deflate3.asp" class="mbrOnly">Deflate 3 Number Set Reduction</a></li><li><a href="/deflate4.asp" class="mbrOnly">Deflate 4 Number Set Reduction</a></li><li><a href="/deflate5.asp" class="mbrOnly">Deflate 5 Number Set Reduction</a></li><li><a href="/inspector3.asp" class="mbrOnly">Inspector 3 Number Set Analysis</a></li><li><a href="/inspector4.asp" class="mbrOnly">Inspector 4 Number Set Analysis</a></li><li class="sep"></li><li><a href="/reports/combinations">Combinations Analysis for Pick 3 and Pick 4</a></li><li><a href="/reports/pairs">Pairs Analysis for Pick 3 and Pick 4</a></li><li class="sep"></li><li><a href="/system-lucky-tracker.aspx">Lucky's Daily Tracker</a></li><li><a href="/system-lucky-followers.aspx">Lucky's Followers System</a></li><li><a href="/system-lucky-1up1down.asp">Lucky's 1-Up 1-Down System</a></li><li class="sep"></li><li><a href="/vtracs">VTracs Home Page</a></li><li><a href="/vtracs/results" class="mbrOnly">VTrac Lottery Results</a></li><li><a href="/vtracs/search" class="mbrOnly">VTracs Search Engine</a></li><li><a href="#">VTrac Charts</a><ul class="jqMenuPanel"><li><a href="/vtracs/mirrors/pick3">VTrac Pick 3 Mirror Combinations</a></li><li><a href="/vtracs/mirrors/pick4">VTrac Pick 4 Mirror Combinations</a></li><li><a href="/vtracs/mirrors/quinto">VTrac Quinto Mirror Combinations</a></li></ul></li><li class="sep"></li><li><a href="/wheels">Lottery Wheels Home Page</a></li><li><a href="/wheels/positional" class="mbrOnly">Positional Wheels for Pick 3, Pick 4, and Quinto</a></li><li><a href="/wheels/pick5" class="mbrOnly">Pick 5 Wheels</a></li><li><a href="/wheels/pick6" class="mbrOnly">Pick 6 Wheels</a></li><li class="sep"></li><li><a href="/quickpicks">Quick Picks Generator</a></li><li><a href="/words-to-numbers">Convert Words and Phrases to Lottery Numbers</a></li><li><a href="/combinations">Lottery Combinations Generator</a></li></ul></li><li class="mainMenu"><a href="#">Resources</a><ul class="jqMenuPanel"><li><a href="/search">Search for something</a></li><li class="sep"></li><li><a href="/news">Lottery News</a></li><li><a href="/tags">Lottery News Story Tags ("Tag Cloud")</a></li><li><a href="/rss">Syndicated RSS 2.0 Feeds</a></li><li class="sep"></li><li><a href="/onthisday">On This Day in History</a></li><li><a href="/calendar">Event Calendar</a></li><li><a href="/lunarcalendar">Lunar Calendar</a></li><li><a href="#">Lottery Charts</a><ul class="jqMenuPanel"><li><a href="/charts">Lottery Charts Main Page</a></li><li class="sep"></li><li><a href="/charts/pick3/combinations">Pick 3 Straight and Box Combinations</a></li><li><a href="/charts/pick3/sums">Pick 3 Sums</a></li><li><a href="/charts/pick3/rootsums">Pick 3 Root Sums</a></li><li><a href="/charts/pick3/sumlastdigit">Pick 3 Sum Last Digit</a></li><li><a href="/vtracs/mirrors/pick3">VTrac Pick 3 Mirror Combinations</a></li><li class="sep"></li><li><a href="/charts/pick4/combinations">Pick 4 Straight and Box Combinations</a></li><li><a href="/charts/pick4/sums">Pick 4 Sums</a></li><li><a href="/charts/pick4/rootsums">Pick 4 Root Sums</a></li><li><a href="/charts/pick4/sumlastdigit">Pick 4 Sum Last Digit</a></li><li><a href="/vtracs/mirrors/pick4">VTrac Pick 4 Mirror Combinations</a></li><li class="sep"></li><li><a href="/charts/quinto/combinations">Quinto Straight and Box Combinations</a></li><li><a href="/charts/quinto/sums">Quinto Sums</a></li><li><a href="/charts/quinto/rootsums">Quinto Root Sums</a></li><li><a href="/charts/quinto/sumlastdigit">Quinto Sum Last Digit</a></li><li><a href="/vtracs/mirrors/quinto">VTrac Quinto Mirror Combinations</a></li><li class="sep"></li><li><a href="/charts/mystical/lacharada">La Charada</a></li></ul></li><li><a href="/quickpicks">Quick Picks Generator</a></li><li><a href="/combinations">Lottery Combinations Generator</a></li><li><a href="/odds">Lottery Odds Calculator</a></li><li class="sep"></li><li><a href="/activeusers" class="mbrOnly">Who's Online</a></li><li><a href="/activity" class="mbrOnly">Monitor Site Activity</a></li><li class="sep"></li><li><a href="/contact">Contact Us</a></li><li><a href="#">About Us</a><ul class="jqMenuPanel"><li><a href="/about">About Lottery Post</a></li><li><a href="/changelog">Web Site Change Log</a></li><li><a href="/sitemap">Site Map</a></li><li class="sep"></li><li><a href="/rules">Forum Rules</a></li><li><a href="/privacy">Privacy Statement</a></li><li><a href="/copyright">Copyright Notice</a></li><li><a href="/terms.aspx">Terms and Conditions of Use</a></li><li><a href="/linkpolicy.aspx">Link Policy</a></li></ul></li><li class="sep"></li><li><a href="#">Online Games</a><ul class="jqMenuPanel"><li><a href="/games">Games Main Page</a></li><li class="sep"></li><li><a href="/2048">Play 2048</a></li><li><a href="/sudoku">Play Sudoku</a></li></ul></li><li><a href="/books">Lottery Book Store</a></li><li><a href="http://www.cafepress.com/lotterypost/" rel="external noopener">Lottery Post Gift Shop</a></li><li><a href="/links">Lottery Links</a></li><li><a href="https://www.usamega.com/" rel="external noopener">USA Mega (Powerball/Mega Millions)</a></li><li class="sep"></li><li><a href="/browsertest">Browser Compatibility Test</a></li></ul></li><li class="mainMenu"><a href="#">Options</a><ul class="jqMenuPanel"><li><a href="/control.asp" class="disabled">Control Panel Home page</a></li><li class="sep"></li><li><a href="/control_profile.asp" class="disabled">Edit Profile</a></li><li><a href="/edit-signature.aspx" class="disabled">Create/Edit Signature</a></li><li><a href="/change-avatar.aspx" class="disabled">Add or Change Avatar</a></li><li class="sep"></li><li><a href="/control_account.asp" class="disabled">Account Settings</a></li><li><a href="/control_blog.asp" class="disabled">Premium Blog Settings</a></li><li><a href="/control_email.asp" class="disabled">E-mail Settings</a></li><li><a href="/control_favorites.asp" class="disabled">Favorites Settings</a></li><li><a href="/control_changeemail.asp" class="disabled">Change E-mail Address</a></li><li><a href="/changepassword">Change Password</a></li><li class="sep"></li><li><a href="/whitelist">Whitelist Lottery Post</a></li><li><a href="/DeleteCookies.aspx">Delete cookies set by Lottery Post</a></li><li class="sep"></li><li><a href="/login">Log In</a></li><li><a href="/register">Register for a Free Membership</a></li></ul></li><li id="menuSpaceR"></li></ul></div><div id="footer"><div id="footerContent"><div id="footerCols"><div class="col1"><div class="colContent"><label>First Time?</label><p>If you haven't already, check out the <a title="About Lottery Post" href="/about">About Us</a> page that explains the main features of our site.</p><p>Also, please take a few moments and review the <a title="Rules for posting at Lottery Post" href="/rules">rules</a> for posting at Lottery Post.</p><p>Any time you see a <samp title="This is an example of a popup menu link. You would click it to reveal a popup menu of options.">gray-underlined link</samp>, you can click the link to see a popup menu of options.</p><p><strong>Popular features:</strong></p><ul><li><a title="Lottery results (winning numbers)" href="/results">Lottery Results</a></li><li><a title="Lottery discussion forums" href="/forums">Discussion Forums</a></li><li><a title="Lottery predictions" href="/predictions">Predictions Board</a></li><li><a title="Lottery methods, systems, and wheels" href="/systems">Lottery Systems and Wheels</a></li><li><a title="Quality, hand-picked selection of lottery and dream books" href="/books">Book Store - lottery &amp; dream books</a></li><li><a title="Lottery Results Gadget for Windows" href="/gadget">Lottery Results Gadget</a></li></ul></div></div><div class="col2"><div class="colContent"><label>Need Help?</label><p>We try to include instructions on each page. Check for help content on the page that's giving you trouble.</p><p>The next place to seek help is our dedicated <a title="See Lottery Post's dedicated help forum" href="/help">Help forum</a> that contains detailed assistance for frequently requested topics.</p><p>If something isn't working properly, our automated <a title="Use the automated Browser Compatibility Test" href="/browsertest">Browser Test</a> page can quickly identify common problems.</p><p>Finally, the <a title="Contact Lottery Post" href="/contact">Contact Us</a> page has an incredible wealth of self-help material that answers 95% of the questions we are asked.</p><p>We always welcome <a title="Send us your feedback" href="/contact/site">feedback</a> and <a title="Send us your suggestions" href="/contact/suggest">suggestions</a>.</p></div></div><div class="col3"><div class="colContent"><label>About Lottery Post</label><p><a title="About Lottery Post" href="/about">About Us</a>&nbsp;&bull; <a title="Lottery Post Site Map" href="/sitemap">Site Map</a>&nbsp;&bull; <a title="Comparison chart of membership features" href="/memberships">Membership Features</a>&nbsp;&bull; <a title="Inquire about advertising at Lottery Post" href="/contact/ads">Advertising Opportunities</a>&nbsp;&bull; <a title="DMCA" href="/dmca">DMCA</a>&nbsp;&bull; <a title="See Lottery Post's journal of Web site changes" href="/changelog">Change Log</a>&nbsp;&bull; <a title="Rules for posting at Lottery Post" href="/rules">Rules</a>&nbsp;&bull; <a title="Lottery Post's Privacy Statement" href="/privacy">Privacy</a>&nbsp;&bull; <a title="See Lottery Post's Link Policy" href="/linkpolicy.aspx">Linking to Lottery Post</a></p><label>RSS Feeds</label><p><a title="Lottery Post's main index of RSS feeds" href="/rss">Index of Feeds</a>&nbsp;&bull; <a title="RSS feed of lottery news stories" href="http://feeds.lotterypost.com/LotteryNews">Lottery News</a>&nbsp;&bull; <a title="RSS feed of events" href="http://feeds.lotterypost.com/LotteryPostEventCalendar">Event Calendar</a>&nbsp;&bull; <a title="RSS feed of the latest posts on the discussion forums" href="http://feeds.lotterypost.com/LotteryPostActiveTopics">Latest Forum Posts</a>&nbsp;&bull; <a title="RSS feed of Lottery Post's journal of Web site changes" href="http://feeds.lotterypost.com/LotteryPostChangeLog">Web Site Change Log</a></p><label>Search Lottery Post</label><p>Search the news, forums, blogs, and even your private messages at our <a title="Search for something at Lottery Post" href="/search">Search</a> page.</p></div></div></div><div class="col4"><div class="colContent"><p>This page was generated in 0.0745 seconds.<br /><a href="/copyright">Copyright</a> &copy; 1999-2021 <a href="https://www.speednet.biz/">Speednet Group</a>.&nbsp; All rights reserved.</p></div></div></div></div><script src="https://lp.vg/script/advert.js"></script><script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"></script><div id="PagerMenuPanel" class="pagermenu"><div class="pagermenuinner"><a href="/news/335976/1" class="currentpage"><ins class="sprite-pager-menu sprite-pager-menu-current"></ins>1 - Current Page</a><a href="/news/335976/2"><ins class="sprite-pager-menu sprite-pager-menu-last"></ins>2 - Last Page</a></div></div><div class="aspNetHidden"><input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="6E8D4450" /><input type="hidden" name="__VIEWSTATEENCRYPTED" id="__VIEWSTATEENCRYPTED" value="" /><input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="K3zrTJdNiCnj4bL4/lEK5QWqpm8vsn2CBcbdwcJho/InFJYJbRsaJa3WbhdpHniHN6mh9flTVoHD+LyFNw0L8g0X8vu5V0u8qoElpKNT1EvMvx192YEteGQ7Zn/kkVxyo1kylJwRw4DJod9giFBl85yJ3JsdbyGkRFWDx4y89RTd8qC4B5fbqtXJtozU7Rs1" /></div><script src="https://lp.vg/js/ds01218.3/MwtGFZn69uAwUEBU1xQNAHR7FoSyGDVA6BzbcVg6aEZjnjKKk9Rrt8egtyaKSMzNkICrg4d5Ke3NoOtwS(DCOHQzmBP4wqL5veCYtyspv2G4oJ(GmxykoLR3upAk3jTVdPDBW3)eWVULWUdXqyPlPo5XO3Sw59KQ9KsazSqMcavoZum1EbsJt4aEoh8LduaYVHw1t4noRQqJbz0RYqRmuHkkUQy7qdpzIpr8K17s5RmjTbzMB8D)AW2)WxOiEiAyAev7/fT63e2l0(w57RziKWEWnZGXkx5o8VFdgMeuNDiNOb4)qsO4TyeuA21e4qbbDRZM(F2qtwXDiGHa9WmnFwMn6kGfgjLRINM4OOo3Ikjjz72wB6X3viQJ20GY56CC9Fn9LotbSuJY1gomZVvnl1J00jurMNYQV)RwODW4Kun2Ql7qMUAzUAa06AGgKY0EBuIVY2V5NiHZPTFaaFK1xP8DXFH6FCyE5bSZ60H)CF5I="></script><script>$(function(){window.setTimeout(function(){$('#mainMenu').jqMenu({rightAlignElement:'#pagewidth',rightAlignOffset:316,rightAlignPopupLimit:true,recalcPositionOnFontLoad:'Oswald'});},1);});var mL={32034:[32034,'Coin Toss','','',0],164645:[164645,'DELotteryPlyr','','',0],1:[1,'Todd','todd','https://www.speednet.biz/',0],195079:[195079,'Big Joey','','https://www.paypal.com/paypalme2/looneymaninthemoon?locale.x=en_US',0],34230:[34230,'Stack47','','',0],196369:[196369,'andl','','',0],151592:[151592,'ieatdirt','','',0],19333:[19333,'Raven62','','',0],138458:[138458,'noise-gate','','',0],172108:[172108,'travelintrucker','','',0],29945:[29945,'paneagle','','http://solastrology.blogspot.com',0],22053:[22053,'Think','','',0],83566:[83566,'sully16','sully16','',0],208489:[208489,'PHIL85','','',0]};var gL={};$.ratingDefaults({servicePath:'/services/Callback.asmx',viewServiceMethod:'GetTopicRatings',saveServiceMethod:'SetTopicRating',deleteServiceMethod:'DeleteTopicRating',spinner:'<p><span class="spinner spinner0 spinner0-size16" style="vertical-align:middle;"><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i><i></i></span> Loading...</p>'});ThreadPage.initialize(335976,6583250,0,false,0,null);$('#rating335976').rating({ratedTargetID:335976,memberID:0,ratingMember:0,ratingCurrent:5,ratingCount:2});LP.delayedImages={"lp0":"https://i.imgur.com/hSk1nCp.png"};$($.wired(NewsPage, NewsPage.initialize));</script></form><script defer src='https://static.cloudflareinsights.com/beacon.min.js' data-cf-beacon='{"token": "4e005c87e74b483495dfcefce5e30c48"}'></script><script type="application/ld+json">{"@context":"https://schema.org/","@id":"https://www.lotterypost.com/#organization","@type":"Organization","name":"Lottery Post","url":"https://www.lotterypost.com/","logo":{"@type":"ImageObject","url":"https://www.lotterypost.com/images/lp_icon_310.png"},"founder":{"@type":"Person","name":"Todd Northrop"},"description":"Lottery Post is a popular website for lottery players to get the latest lottery results, prizes, and jackpots, and to discuss, share, and discover anything and everything about official government lottery games around the world.","sameAs":["https://www.youtube.com/LotteryPost","https://www.facebook.com/LotteryPost","https://twitter.com/LotteryPost","https://www.instagram.com/LotteryPost/"]}</script></body></html> 