<!DOCTYPE html>
<html lang="en"><head><meta charset="utf-8" />

<!--
	Lottery Post® (https://www.lotterypost.com)
	Author: Todd Northrop
	Contact: https://www.lotterypost.com/contact
	Copyright © 1999-2022. All Rights Reserved.
	Reproduction in whole or in part in any form or medium without express written permission of the Author is prohibited. See https://www.lotterypost.com/copyright
	Lottery Post and the Lottery Post logo are registered trademarks of Speednet Group, and may not be used without express written permission.
- - - - - - - - - - - - - - - - - - - - - - - - - - - -->

	<title>$1.9 BILLION POWERBALL JACKPOT SETS WORLD RECORD OF UNIMAGINABLE WEALTH | Lottery Post</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	<meta name="application-name" content="Lottery Post" />
	<meta name="format-detection" content="telephone=no" />
	<meta name="keywords" content="lottery,news,Powerball,Jackpots,Record,Multi-State Game" />
	<meta name="description" content="Last night Powerball didn&#x27;t just set a new lottery jackpot record, it crushed the old record, putting the concept of a $2 billion lottery jackpot within reach." />
	<meta name="apple-mobile-web-app-title" content="Lottery Post" />
	<meta property="og:site_name" content="Lottery Post" />
	<meta property="og:title" content="$1.9 BILLION POWERBALL JACKPOT SETS WORLD RECORD OF UNIMAGINABLE WEALTH" />
	<meta property="og:description" content="Last night Powerball didn&#x27;t just set a new lottery jackpot record, it crushed the old record, putting the concept of a $2 billion lottery jackpot within reach." />
	<meta property="og:image" content="https://www.lotterypost.com/images/newsicons/newsicon_powerball.jpg" />
	<meta property="og:type" content="website" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:site" content="@LotteryPost" />
	<meta name="theme-color" content="#bcceff" />
	<meta property="og:url" content="https://www.lotterypost.com/news/343144" />
	<link rel="canonical" href="https://www.lotterypost.com/news/343144" />
	<link rel="alternate" href="https://www.lotterypost.com/rss/news/343144" type="application/rss+xml" title="Subscribe to &quot;$1.9 BILLION POWERBALL JACKPOT SETS WORLD RECORD OF UNIMAGINABLE WEALTH&quot;" />
	<link rel="icon" href="/favicon.ico" sizes="any">
	<link rel="icon" href="/favicon.svg" type="image/svg+xml">
	<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png" />
	<link rel="manifest" href="/site.webmanifest">
	<link rel="preload" as="font" type="font/woff2" href="/fonts/NotoSans-Regular.woff2" />
	<link rel="preload" as="font" type="font/woff2" href="/fonts/NotoSans-Italic.woff2" />
	<link rel="preload" as="font" type="font/woff2" href="/fonts/NotoSans-Bold.woff2" />
	<link rel="preload" as="font" type="font/woff2" href="/fonts/NotoSans-BoldItalic.woff2" />
	<link rel="preload" as="font" type="font/woff2" href="/lib/fa/webfonts/fa-solid-900.woff2" />
	<link rel="preload" as="font" type="font/woff2" href="/lib/fa/webfonts/fa-brands-400.woff2" />
	<link rel="stylesheet" href="/lib/fa/css/all.min.css?v=cpCCrLFdFQDBm5Tm4jhvrpyrflM54ZawRJISyyRq04Q" />
	<link rel="stylesheet" href="/css/site.min.css?v=yrcCLABsE83OHDY7gjJ1xHFHCg4eauiKEjmhJVNLz24" />
		<link rel="stylesheet" href="/css/newsstory.min.css?v=iIBJlmuvLPQ1-QQhenBYdVjgJJN5Pn9p_DDStD-S2Sk" />

	<script>var LPInit={menuVersion:'34',status:0,lastUsername:''};</script>
	<base href="/" />
</head>
<body class="newsstory">
	<header>
		<div id="menuicon" class="icn"><i></i></div>
		<div id="refreshicon" class="icn"><i class="fas fa-redo"></i></div>
		<div id="backicon" class="icn"><i class="fas fa-arrow-left"></i></div>
		<a id="HeaderLogo" href="/" title="Lottery Post"><img src="/images/lotterypost.svg" width="190" height="50" alt="Lottery Post" /></a>
		<div id="searchicon" class="icn"><i class="fas fa-search"></i></div>
<div id="shareicon" class="icn"></div>		<div id="usericon" class="icn"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path d="M224 256a128 128 0 100-256 128 128 0 000 256zm89.6 32h-16.7a174.3 174.3 0 01-145.8 0h-16.7A134.4 134.4 0 000 422.4V464a48 48 0 0048 48h352a48 48 0 0048-48v-41.6c0-74.2-60.2-134.4-134.4-134.4z"></path></svg></div>
	</header>
	<nav>
		<div id="menuicon2container">
			<div id="menuicon2" class="icn"><i></i></div>
		</div>
		<div id="menu">
			<ul>
				<li><a href="/forums"><i class="fas fa-comment"></i>Forums</a></li>
				<li><a href="/results"><i class="fas fa-check-circle"></i>Results</a></li>
				<li><a href="/predictions"><i class="fas fa-bullseye"></i>Predictions</a></li>
				<li><a href="/members"><i class="fas fa-user"></i>Members</a></li>
				<li><a href="/systems"><i class="fas fa-chart-line"></i>Systems</a></li>
				<li><a href="/resources"><i class="fas fa-info-circle"></i>Resources</a></li>
			</ul>
		</div>
		<div id="auxcommand">
			<div id="search">
				<div><input type="text" id="mainSearchInput" maxlength="250" placeholder="Search Lottery Post" /><i id="mainSearchSubmit" class="fas fa-search fa-fw"></i></div>
			</div>
			<div id="userinfo">
					<strong>Welcome Guest</strong> ( <a href="#" class="trigger-login">Log In</a> | <a href="/register">Register</a> )
			</div>
		</div>
	</nav>
<div id="content">
	<div id="quick">
		<div id="quick-content">
			<div id="quick-logo"><img src="/images/lotterypost.svg" width="100" height="26" alt="Lottery Post" /></div>
			<ul>
				<li><a href="/">Home</a></li>
				<li><a href="/memberships"><i class="fas fa-star std"></i> Premium Memberships</a></li>
				<li><a href="/results">Lottery Results</a></li>
				<li><a href="/forums">Forums</a></li>
				<li><a href="/predictions">Predictions</a></li>
				<li><a href="/videos">Lottery Post Videos</a></li>
				<li><a href="/news">News</a></li>
				<li><a href="/results/search">Search Drawings</a></li>
				<li><a href="/search">Search Lottery Post</a></li>
				<li><a href="/systems">Lottery Systems</a></li>
				<li><a href="/charts">Lottery Charts</a></li>
				<li><a href="/wheels">Lottery Wheels</a></li>
				<li><a href="/jackpots">Worldwide Jackpots</a></li>
				<li><a href="/quickpicks">Quick Picks</a></li>
				<li><a href="/onthisday">On This Day in History</a></li>
				<li><a href="/blogs">Blogs</a></li>
				<li><a href="/games">Online Games</a></li>
				<li><a href="/features">Premium Features</a></li>
				<li><a href="/contact">Contact Us</a></li>
				<li><a href="/whitelist">Whitelist Lottery Post</a></li>
				<li><a href="/rules">Rules</a></li>
				<li><a href="/books"><i class="fas fa-book std"></i> Lottery Book Store</a></li>
				<li><a href="https://shop.lotterypost.com/"><i class="fas fa-gift std"></i> Lottery Post Gift Shop</a></li>
			</ul>
			<p class="socialmedia"><a href="https://www.facebook.com/LotteryPost" title="Facebook"><i class="fab fa-facebook"></i></a><a href="https://www.twitter.com/lotterypost" title="Twitter"><i class="fab fa-twitter"></i></a><a href="https://www.instagram.com/lotterypost" title="Instagram"><i class="fab fa-instagram"></i></a><a href="https://www.youtube.com/lotterypost" title="YouTube"><i class="fab fa-youtube"></i></a></p>
			<a href="https://www.usamega.com" title="Powerball and Mega Millions lottery results and news"><img src="/images/usa-mega-button-2.png" class="usamega" width="140" height="97" alt="USA Mega"></a>
			<div id="audmenu" class="aud autall"></div>
			<p><a title="Lottery Places free app for iPhone, Android, and Windows" href="https://www.lotteryplaces.com/"><img src="/images/LotteryPlaces_140x375_2x.jpg" width="140" height="375" alt="Lottery Places"></a></p>
			<ul>
				<li><a href="/js-compress">JavaScript Compressor</a></li>
				<li><a href="/css-compress">CSS Compressor</a></li>
				<li><a href="https://mybrowserinfo.com/" rel="external">Browser Information</a></li>
			</ul>
			<div class="timesummary">
				<p>The time is now 3:10&nbsp;pm</p>
					<p>You last visited<br />November&nbsp;6,&nbsp;2022, 3:10&nbsp;pm</p>
				<p>All times shown are<br />Eastern Time (GMT-5:00)</p>
			</div>
		</div>
	</div>
	<main>
<img src="/b.gif" alt=""/>		<div class="aum auhoriz"></div>
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":{"@type":"Thing","@id":"/"}},{"@type":"ListItem","position":2,"name":"Lottery News","item":{"@type":"Thing","@id":"/news"}},{"@type":"ListItem","position":3,"name":"$1.9 BILLION POWERBALL JACKPOT SETS WORLD RECORD OF UNIMAGINABLE WEALTH","item":{"@type":"Thing","@id":"/news/343144"}}]}</script><div class="breadcrumb"><a href="/">Home</a>&nbsp;&rsaquo; <a href="/news">Lottery News</a>&nbsp;&rsaquo; $1.9 BILLION POWERBALL JACKPOT SETS WORLD RECORD OF UNIMAGINABLE WEALTH</div>
<h1 class="main">$1.9 BILLION POWERBALL JACKPOT SETS WORLD RECORD OF UNIMAGINABLE WEALTH</h1>
<p class="pubinfo">Nov 6, 2022, 7:36 am (<a href="#" onclick="return LP.scrollTo('#newscomments');">39 comments</a>)<span class="social"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.lotterypost.com%2Fnews%2F343144" class="iconlink bold inline"><i class="fab fa-facebook std"></i>Share</a><a href="https://twitter.com/share?url=https%3A%2F%2Fwww.lotterypost.com%2Fnews%2F343144&text=%241.9&#x2B;BILLION&#x2B;POWERBALL&#x2B;JACKPOT&#x2B;SETS&#x2B;WORLD&#x2B;RECORD&#x2B;OF&#x2B;UNIMAGINABLE&#x2B;WEALTH" class="iconlink bold inline"><i class="fab fa-twitter std"></i>Tweet</a><a href="#" class="storylink iconlink bold inline" data-clipboard-text="https://www.lotterypost.com/news/343144"><i class="fas fa-copy std"></i>Copy Link</a> </span></p>
<article>
	<img src="/images/newsicons/newsicon_powerball.jpg" width="140" height="100" class="articleicon" alt="Powerball" />
	<p style="font-size: 125%; font-weight: bold;">Jaw-dropping prize money on the line for Monday drawing</p>

<p style="font-size: 115%; font-weight: bold;">Cash option nearly $1&nbsp;billion</p>

<p><span style="font-size: 10px;">By Todd Northrop</span></p>

<p>Last night Powerball didn't just set a new lottery jackpot record, it <em>crushed</em> the old record, putting the concept of a $2&nbsp;billion lottery jackpot within reach.</p>

<p>When the 40th drawing of the current Powerball jackpot run was conducted last night, it produced a combination of numbers that most lottery players typically wouldn't choose on their own: All the numbers except one were greater than the &quot;birthday number&quot; range (31), and the Powerball was a lower number than all of the first five.</p>

<p>It was the kind of numbers that USA Mega owner Todd Northrop <a href="https://www.newsweek.com/powerball-drawing-can-increase-odds-winning-1-point-6-billion-jackpot-1757113" rel="external">recommended to Newsweek</a> Friday.</p>

<p>And true to form, nobody had selected those numbers &mdash; not even a lottery terminal's quick picks generated those numbers among the hundreds of millions of tickets printed.&nbsp;</p>

<p>In the early morning hours Sunday, the lotteries finally determined that nobody has matched all the numbers drawn, and that a new world record would be established.</p>

<p>The new annuity jackpot record of $1.9&nbsp;billion is accompanied by a cash value of $929.1&nbsp;million &mdash; nearly a billion dollars in cash! That's enough to make it the second-highest cash value in history.&nbsp;</p>

<p>To get to this size, the jackpot has been growing since it started on Aug.&nbsp;6 as a $20&nbsp;million prize &mdash; now 40 consecutive drawings without a winner.</p>

<p>Lottery players dreaming what all the cash will look like in their bank account after federal and state taxes are taken out can see an after-tax analysis of the current Powerball jackpot by visiting USA Mega's <a href="https://www.usamega.com/powerball/jackpot/2022/11/7" rel="external">Powerball Jackpot Analysis</a> page. Rather than simply showing the initial withholdings a lottery winner would face like other &quot;copy cat&quot; websites, the Jackpot Analysis page also includes the additional taxes that will be due after the initial withholdings, and will even allow players to see the taxes due under different filing statuses.</p>

<p>The rush of ticket sales over the next few days may propel the jackpot to an even higher amount before the drawing takes place Monday. Lottery Post and USA Mega will update the jackpot tallies displayed if such an increase occurs.</p>

<p>The quickest way to find the winning numbers after the drawing Monday will be by visiting USA Mega (<a href="https://www.usamega.com/" rel="external">www.usamega.com</a>) at 10:59 pm Eastern Time (7:59 pm Pacific), when the winning numbers will be published live as they are drawn.</p>

<p>Players looking for the nearest official lottery retailer&nbsp;&mdash; or maybe just a different store without such a long line&nbsp;&mdash; are urged to use the free <a href="https://www.lotteryplaces.com/" rel="external">Lottery Places</a> app available for iOS, Android, and Windows. The app can find lottery stores in every Powerball state and can search across state lines&nbsp;&mdash; something even official state lotteries can't do.</p>

<div id="aumhoriz" class="aum auhoriz"></div><p>Some states offer direct online sales, allowing players to bypass the store and purchase tickets from home. States that offer this ability include Colorado (<a href="/partner/colorado_megamillions" rel="external">Mega Millions</a>&nbsp;and&nbsp;<a href="/partner/colorado_powerball" rel="external">Powerball</a>), Michigan (<a href="/partner/michigan_megamillions" rel="external">Mega Millions</a>&nbsp;and&nbsp;<a href="/partner/michigan_powerball" rel="external">Powerball</a>), Minnesota (<a href="/partner/minnesota_megamillions" rel="external">Mega Millions</a>&nbsp;and&nbsp;<a href="/partner/minnesota_powerball" rel="external">Powerball</a>), Oregon (<a href="/partner/oregon_megamillions" rel="external">Mega Millions</a>&nbsp;and&nbsp;<a href="/partner/oregon_powerball" rel="external">Powerball</a>), Texas (<a href="/partner/texas_megamillions" rel="external">Mega Millions</a>&nbsp;and&nbsp;<a href="/partner/texas_powerball" rel="external">Powerball</a>), and Virginia (<a href="/partner/virginia_megamillions" rel="external">Mega Millions</a>&nbsp;and&nbsp;<a href="/partner/virginia_powerball" rel="external">Powerball</a>). Note that some of these links will only work properly for residents of the states mentioned.</p>

<p>Players outside the USA can use a reputable&nbsp;<a href="/partner/4" rel="external">butler service</a>, which provides scanned copies of the purchased lottery tickets securely held on behalf of the customer. In the past, the&nbsp;<a href="/partner/4" rel="external">lottery ticket service</a>&nbsp;was used by people out side the USA to win big jackpots in&nbsp;<a href="/news/296905" rel="external">Oregon</a>&nbsp;and&nbsp;<a href="/news/314991" rel="external">Florida</a>.</p>

<p>In Saturday night's Powerball drawing, there was no jackpot winner, but 17 lucky players matched the first 5 numbers for a $1,000,000 prize: 3 from California, 2 from Colorado, 1 from Florida, 1 from Georgia, 2 from Kentucky, 1 from Massachusetts, 1 from Michigan, 1 from Missouri, 1 from New Jersey, 1 from New York, 2 from Pennsylvania, and 1 from South Dakota.&nbsp;</p>

<p>The California second-prize winners will be awarded $1,120,390 each instead of the fixed $1&nbsp;million prize awarded in the other states. By law, California awards all lottery prizes on a pari-mutuel basis, meaning the prizes will change each drawing based on the number of tickets sold within California and the number of tickets that won at each prize level in the state.</p>

<p>Out of all the second-prize tickets, only the one sold in Kentucky was purchased with the Power Play option, doubling their prize to $2&nbsp;million.</p>

<p>When a Powerball ticket is purchased with the Power Play option for an extra $1 per ticket, a second-prize win is doubled and any other non-jackpot prize is multplied by the Power Play number drawn that evening. A complete list of prizes available for matching various numbers can be found on the&nbsp;<a href="https://www.usamega.com/powerball/drawing/2022/11/5" rel="external">Powerball Drawing Detail</a>&nbsp;page at USA&nbsp;Mega, as well as on the&nbsp;<a href="/results/xx/powerball/prizes/2022/11/5" rel="external">Powerball Prize Payouts</a>&nbsp;and the&nbsp;<a href="/results/xx/powerballdoubleplay/prizes/2022/11/5" rel="external">Powerball Double Play Prize Payouts</a>&nbsp;pages at Lottery Post.</p>

<p>The Power Play option is not available in California, because the fixed nature of the prize increase offered with the Power Play&nbsp;is not compatible with California's pari-mutuel payouts.</p>

<p>Also, a total of 270 tickets matched four of the first five numbers plus the Powerball to win a $50,000 prize. Of those tickets, 51 were purchased with the Power Play option, increasing the prize to $150,000, and 43 were sold in California, where the prize awarded this drawing is $20,010.</p>

<p>The Powerball winning numbers for Saturday, November&nbsp;5,&nbsp;2022, were 28, 45, 53, 56, and 69, with Mega Ball number&nbsp;20. The Power Play number was&nbsp;3.</p>

<p>The Saturday Double Play drawing results were 4, 23, 27, 31, and 56, with Powerball number&nbsp;15. Double Play is a game option currently available in 14 states that lets you play your numbers in a second drawing for an extra $1 per play, with a chance to win up to $10&nbsp;million in cash. See <a href="https://www.usamega.com/powerball/how-to-play" rel="external">How to Play Powerball</a> at USA Mega for more information about Double Play.</p>

<p>Following the Saturday drawing, the Powerball annuity jackpot estimate was raised $243.2&nbsp;million from its previous amount of $1.6568&nbsp;billion. The cash value was raised by $146.7&nbsp;million from its previous amount of $782.4&nbsp;million.</p>

<p>Powerball is currently offered for sale in 45 states, plus Washington, D.C., Puerto Rico, and the U.S. Virgin Islands. Drawings are Mondays, Wednesdays, and Saturdays at 10:59 pm Eastern Time. Tickets cost $2 each.</p>

<p style="font-size: 110%; font-weight: bold; margin-top: 1.4em;">Top&nbsp;25 United States lottery jackpots of all time</p>

<div id="aumhoriz" class="aum auhoriztall"></div><p>Monday's Powerball jackpot currently stands as the largest lottery jackpot in world history.</p>

<ol style="text-align: left;">
<li style="font-weight: bold;">Powerball: $1.9&nbsp;billion, Nov.&nbsp;7,&nbsp;2022 (40&nbsp;rollovers, starting at $20&nbsp;million)&nbsp;- Prelimiary estimate, not won yet</li>

<li>Powerball: $1.5864&nbsp;billion, Jan.&nbsp;13,&nbsp;2016 (19&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- California, Florida, Tennessee</li>

<li>Mega Millions: $1.537&nbsp;billion, Oct.&nbsp;23,&nbsp;2018 (25&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- South Carolina</li>

<li>Mega Millions: $1.337&nbsp;billion, Jul.&nbsp;29,&nbsp;2022 (29&nbsp;rollovers, starting at $20&nbsp;million)&nbsp;- Illinois</li>

<li>Mega Millions: $1.05&nbsp;billion, Jan.&nbsp;22,&nbsp;2021 (36&nbsp;rollovers, starting at $20&nbsp;million)&nbsp;- Michigan</li>

<li>Powerball: $768.4&nbsp;million, Mar.&nbsp;27,&nbsp;2019 (25&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- Wisconsin</li>

<li>Powerball: $758.7&nbsp;million, Aug.&nbsp;23,&nbsp;2017 (20&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- Massachusetts</li>

<li>Powerball: $731.1&nbsp;million, Jan.&nbsp;20,&nbsp;2021 (35&nbsp;rollovers, starting at $20&nbsp;million)&nbsp;- Maryland</li>

<li>Powerball: $699.8&nbsp;million, Oct.&nbsp;4,&nbsp;2021 (40&nbsp;rollovers, starting at $20&nbsp;million)&nbsp;- California</li>

<li>Powerball: $687.8&nbsp;million, Oct.&nbsp;27,&nbsp;2018 (21&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- Iowa, New&nbsp;York</li>

<li>Mega Millions: $656&nbsp;million, Mar.&nbsp;30,&nbsp;2012 (18&nbsp;rollovers, starting at $12&nbsp;million)&nbsp;- Illinois, Kansas, Maryland</li>

<li>Mega Millions: $648&nbsp;million, Dec.&nbsp;17,&nbsp;2013 (21&nbsp;rollovers, starting at $12&nbsp;million)&nbsp;- California, Georgia</li>

<li>Powerball: $632.6&nbsp;million, Jan&nbsp;5,&nbsp;2022 (39&nbsp;rollovers, starting at $20&nbsp;million)&nbsp;- California, Wisconsin</li>

<li>Powerball: $590.5&nbsp;million, May&nbsp;18,&nbsp;2013 (13&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- Florida</li>

<li>Powerball: $587.5&nbsp;million, Nov.&nbsp;28,&nbsp;2012 (15&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- Arizona, Missouri</li>

<li>Powerball: $564.1&nbsp;million, Feb.&nbsp;11,&nbsp;2015 (20&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- North&nbsp;Carolina, Puerto&nbsp;Rico, Texas</li>

<li>Powerball: $559.7&nbsp;million, Jan.&nbsp;6,&nbsp;2018 (20&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- New&nbsp;Hampshire</li>

<li>Mega Millions: $543&nbsp;million, Jul.&nbsp;24,&nbsp;2018 (22&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- California</li>

<li>Mega Millions: $536&nbsp;million, Jul.&nbsp;8,&nbsp;2016 (34&nbsp;rollovers, starting at $15&nbsp;million)&nbsp;- Indiana</li>

<li>Mega Millions: $533&nbsp;million, Mar.&nbsp;30,&nbsp;2018 (23&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- New Jersey</li>

<li>Mega Millions: $522&nbsp;million, Jun.&nbsp;7,&nbsp;2019 (24&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- California</li>

<li>Mega Millions: $516&nbsp;million, May&nbsp;21,&nbsp;2021 (26&nbsp;rollovers, starting at $20&nbsp;million)&nbsp;- Pennsylvania</li>

<li>Mega Millions: $502&nbsp;million, Oct.&nbsp;14,&nbsp;2022 (21&nbsp;rollovers, starting at $20&nbsp;million)&nbsp;- California, Florida</li>

<li>Powerball: $487&nbsp;million, Jul.&nbsp;30,&nbsp;2016 (23&nbsp;rollovers, starting at $40&nbsp;million)&nbsp;- New&nbsp;Hampshire</li>

<li>Powerball: $473.1&nbsp;million, Apr.&nbsp;27,&nbsp;2022 (30&nbsp;rollovers, starting at $20&nbsp;million)&nbsp;- Arizona</li>
</ol>

<p>For those keeping score, the number of jackpots in the top 25, by lottery game, are:</p>

<ul>
<li>Powerball: 14</li>

<li>Mega Millions: 11</li>
</ul>

<p style="font-size: 110%; font-weight: bold; margin-top: 1.4em;">Top 25 cash value jackpots</p>

<p>Since many lottery winners collect their winnings in cash, the lump-sum payout is an important measure of what a winning ticket could be worth.</p>

<p>Looking at the cash value, the upcoming Powerball jackpot ranks as the 2nd-largest cash value in world history.</p>

<ol style="text-align: left;">
<li>Powerball: $983.5&nbsp;million cash, Jan.&nbsp;13,&nbsp;2016 ($1.5864&nbsp;billion&nbsp;annuity)&nbsp;- California, Florida, Tennessee</li>

<li style="font-weight: bold;">Powerball: $929.1&nbsp;million cash, Nov.&nbsp;7,&nbsp;2022 ($1.9&nbsp;billion&nbsp;annuity)&nbsp;- Prelimiary estimate, not won yet</li>

<li>Mega Millions: $877.8&nbsp;million cash, Oct.&nbsp;23,&nbsp;2018 ($1.537&nbsp;billion&nbsp;annuity)&nbsp;- South Carolina</li>

<li>Mega Millions: $780.5&nbsp;million cash, Jul.&nbsp;29,&nbsp;2022 ($1.337&nbsp;billion&nbsp;annuity)&nbsp;- Illinois</li>

<li>Mega Millions: $776.6&nbsp;million cash, Jan.&nbsp;22,&nbsp;2021 ($1.05&nbsp;billion&nbsp;annuity)&nbsp;- Michigan</li>

<li>Powerball: $546.8&nbsp;million cash, Jan.&nbsp;20,&nbsp;2021 ($731.1&nbsp;million&nbsp;annuity)&nbsp;- Maryland</li>

<li>Powerball: $496&nbsp;million cash, Oct.&nbsp;4,&nbsp;2021 ($699.8&nbsp;million&nbsp;annuity)&nbsp;- California</li>

<li>Powerball: $480.5&nbsp;million cash, Aug.&nbsp;23,&nbsp;2017 ($758.7&nbsp;million&nbsp;annuity)&nbsp;- Massachusetts</li>

<li>Powerball: $477&nbsp;million cash, Mar.&nbsp;27,&nbsp;2019 ($768.4&nbsp;million&nbsp;annuity)&nbsp;- Wisconsin</li>

<li>Mega Millions: $471&nbsp;million cash, Mar.&nbsp;30,&nbsp;2012 ($656&nbsp;million&nbsp;annuity)&nbsp;- Illinois, Kansas, Maryland</li>

<li>Powerball: $450.2&nbsp;million cash, Jan.&nbsp;5,&nbsp;2022 ($632.6&nbsp;million&nbsp;annuity)&nbsp;- California, Wisconsin</li>

<li>Powerball: $396.2&nbsp;million cash, Oct.&nbsp;27,&nbsp;2018 ($687.8&nbsp;million&nbsp;annuity)&nbsp;- Iowa, New&nbsp;York</li>

<li>Powerball: $384.7&nbsp;million cash, Nov.&nbsp;28,&nbsp;2012 ($587.5&nbsp;million&nbsp;annuity)&nbsp;- Arizona, Missouri</li>

<li>Powerball: $381.1&nbsp;million cash, Feb.&nbsp;11,&nbsp;2015 ($564.1&nbsp;million&nbsp;annuity)&nbsp;- North&nbsp;Carolina, Puerto&nbsp;Rico, Texas</li>

<li>Mega Millions: $378&nbsp;million cash, Jul.&nbsp;8,&nbsp;2016 ($536&nbsp;million&nbsp;annuity)&nbsp;- Indiana</li>

<li>Powerball: $370.9&nbsp;million cash, May&nbsp;18,&nbsp;2013 ($590.5&nbsp;million&nbsp;annuity)&nbsp;- Florida</li>

<li>Powerball: $352&nbsp;million cash, Jan.&nbsp;6,&nbsp;2018 ($559.7&nbsp;million&nbsp;annuity)&nbsp;- New&nbsp;Hampshire</li>

<li>Mega Millions: $349.3&nbsp;million cash, May&nbsp;21,&nbsp;2021 ($516&nbsp;million&nbsp;annuity)&nbsp;- Pennsylvania</li>

<li>Mega Millions: $347.6&nbsp;million cash, Dec.&nbsp;17,&nbsp;2013 ($648&nbsp;million&nbsp;annuity)&nbsp;- California, Georgia</li>

<li>Powerball: $341.7&nbsp;million cash, Jul.&nbsp;30,&nbsp;2016 ($487&nbsp;million&nbsp;annuity)&nbsp;- New&nbsp;Hampshire</li>

<li>Mega Millions: $340&nbsp;million cash, Jun.&nbsp;7,&nbsp;2019 ($522&nbsp;million&nbsp;annuity)&nbsp;- California</li>

<li>Mega Millions: $324&nbsp;million cash, Mar.&nbsp;30,&nbsp;2018 ($533&nbsp;million&nbsp;annuity)&nbsp;- New Jersey</li>

<li>Mega Millions: $320.5&nbsp;million cash, Jul.&nbsp;24,&nbsp;2018 ($543&nbsp;million&nbsp;annuity)&nbsp;- California</li>

<li>Mega Millions: $319.9&nbsp;million cash, Jun.&nbsp;9,&nbsp;2020 ($414&nbsp;million&nbsp;annuity)&nbsp;- Arizona</li>

<li>Mega Millions: $314.4&nbsp;million cash, Sep.&nbsp;21,&nbsp;2021 ($431&nbsp;million&nbsp;annuity)&nbsp;- New York</li>
</ol>

<p>The number of cash value jackpots in the top 25, by lottery game, are:</p>

<ul>
<li>Mega Millions: 13</li>

<li>Powerball: 12</li></ul>
</article>
	<p><i class="fas fa-globe"></i> Lottery Post Staff</p>
<div class="aum auhoriz"></div>
<div class="relatedinfo">
	<div>
		<div class="relatedlinks">
			<h1>Related links</h1>
				<p><a href="https://www.usamega.com/">USA Mega - Home of Powerball and Mega Millions</a></p>
				<p><a href="/partner/4">Play Powerball online</a></p>
				<p><a href="/partner/colorado_powerball">Buy official Powerball tickets from the Colorado Lottery</a></p>
				<p><a href="/partner/michigan_powerball">Buy official Powerball tickets from the Michigan Lottery</a></p>
				<p><a href="/partner/minnesota_powerball">Buy official Powerball tickets from the Minnesota Lottery</a></p>
				<p><a href="/partner/oregon_powerball">Buy official Powerball tickets from the Oregon Lottery</a></p>
				<p><a href="/partner/texas_powerball">Buy official Powerball tickets from the Texas Lottery</a></p>
				<p><a href="/partner/virginia_powerball">Buy official Powerball tickets from the Virginia Lottery</a></p>
		</div>
		<div class="relatednewsstories">
			<h1>Related news stories</h1>
				<p><a href="/news/343126">$1.6 BILLION: Powerball jackpot sets all-time record as ticket sales surge across the USA</a><span>Nov 4, 2022</span></p>
				<p><a href="/news/305190">California co-winners of $1.6B Powerball jackpot finally come forward</a><span>Jul 19, 2016</span></p>
				<p><a href="/news/298363">Record $1.6 billion Powerball jackpot won by 3 tickets</a><span>Jan 14, 2016</span></p>
				<p><a href="/news/298318">Tennessee Lottery chief retrofits Powerball billboard to &#x27;Billion&#x27;</a><span>Jan 13, 2016</span></p>
				<p><a href="/news/298270">$1.5 BILLION: Wednesday Powerball record jackpot still rising</a><span>Jan 12, 2016</span></p>
		</div>
	</div>
	<div>
		<h1>Tags for this story</h1>
		<ul class="tags">
			<li><a href="/search/tag?q=jackpots" rel="tag" style="font-size:22px;" title="Jackpots">Jackpots</a></li>&#32;
			<li><a href="/search/tag?q=multi-state_game" rel="tag" style="font-size:19px;" title="Multi-State Game">Multi-State Game</a></li>&#32;
			<li><a href="/search/tag?q=powerball" rel="tag" style="font-size:19px;" title="Powerball">Powerball</a></li>&#32;
			<li><a href="/search/tag?q=record" rel="tag" style="font-size:15px;" title="Record">Record</a></li>&#32;
		</ul>
		<h2>Other popular tags</h2>
		<ul class="tags clr">
			<li><a href="/search/tag?q=crime" rel="tag" style="font-size:13px;" title="Crime">Crime</a></li>&#32;
			<li><a href="/search/tag?q=financials" rel="tag" style="font-size:14px;" title="Financials">Financials</a></li>&#32;
			<li><a href="/search/tag?q=insider_buzz" rel="tag" style="font-size:14px;" title="Insider Buzz">Insider Buzz</a></li>&#32;
			<li><a href="/search/tag?q=legal" rel="tag" style="font-size:14px;" title="Legal">Legal</a></li>&#32;
			<li><a href="/search/tag?q=legislation" rel="tag" style="font-size:13px;" title="Legislation">Legislation</a></li>&#32;
			<li><a href="/search/tag?q=mega_millions" rel="tag" style="font-size:14px;" title="Mega Millions">Mega Millions</a></li>&#32;
			<li><a href="/search/tag?q=retailer" rel="tag" style="font-size:13px;" title="Retailer">Retailer</a></li>&#32;
			<li><a href="/search/tag?q=scratch_games" rel="tag" style="font-size:14px;" title="Scratch Games">Scratch Games</a></li>&#32;
			<li><a href="/search/tag?q=winner_stories" rel="tag" style="font-size:18px;" title="Winner Stories">Winner Stories</a></li>&#32;
			<li><a href="/search/tag?q=winning_ticket_announcement" rel="tag" style="font-size:13px;" title="Winning Ticket Announcement">Winning Ticket Announcement</a></li>&#32;
			<li style="float:right; margin:5px 0 0 10px;"><a href="/tags" style="font-size:14px;" ToolTip="Display all news story tags (the &quot;Tag Cloud&quot;)">More &raquo;</a></li>
		</ul>
	</div>
</div>
<div id="audhoriz" class="aud auhoriz"></div>
<h1>Comments</h1>
<div id="newscomments"></div>
<!--Blazor:{"sequence":0,"type":"server","prerenderId":"a2fd4e7899c0425f900b9ea7228f057c","descriptor":"CfDJ8LHtg3RRLv5BlQ0anQ9VofNuiRuTDQ8oTIQBE0JRQWr4kCRRLLhN71fU6U/jXYS1KPN3qbQy5rmJU0ELovYn8VX\u002By\u002BFqz3sTk7cgYKEgGs04eAKE3OEzqqECx96HC9PUCNW2nA6eMr35vIbwn\u002BvtW7yX\u002BQBa6Ks4rASjENktN6ymvnkTCmsC7DvbH4bkdFG9hSdnDWRAVOvDwpmHDdp3eKvFAUNJP3ynPetA84ROdlBo4mA5ZmPrd0/9an9whR7q/3XTsDFbxfulj/gCqERCa6/EEHqQtR5LZGpGP\u002BQnh60CnOu165i55iedhycZjhLqMFIQTPZT8yO8dQOvEHb8I98nwZuuP5vvTqrS40I4UR6sV4rJbfw6V17RZku/ZQ7TTDCT5KZG5SsC2mMU45UlplJvs\u002BZT9rdzOgmddAwvoqC4\u002BGwhAv7gMjkRw63WhEIhCRxnOVDhekoRKTeUc3H1ao6QWc8skfvuK1LBUzxThZr4Y0qZhKnhymVC5XmOTtofOjoxift1eQSUQFLvj1H6SCRe6pGConpPa9gmqMJ513694SabDq1nV8QKRmJbgvDgrkoD2mgSaAM2iwUIo7UGJEryjDqXRhC4AiDbs8WFFsSC3wyHrEy8gXvyogTjF4wtkd7GrdYxEJOIC9nyyif5pzOG\u002BVf4m0LB\u002Bw7ylWMbqyijn\u002Bfa07XV2a2\u002BfD3y39QvdHdv8WjuwLzeca/yJQWFRYaRXZl2rcbtCt\u002B7VV30HW5dD6sIDMygEjkdn7P4fhIG7A1TnN8fHJ/ulYXTgUtMH3N4Zmy5L94909AAJ7P0OGulYd\u002BAMfq7OeE\u002BCQiPoRJhoHL8wOqq/NSOucyD0jM5AtoQaeNGNytGaHWwYwPjMD0yVJNYR4gEJInzZCXNTWi2pYvrzYh33mFWJtjclIORJ5TvKqKiuJWfYxQMXT0\u002B2GM0VoHzTFlmnC4RfYVbYhwmWffEYqSWpzmGHEK\u002BXh9Z0kJfAfLNsV9Rmf5Z7rhcgmMu/cfYzwvlmVyY9dQ6si8o\u002BX6UzvZDh80eGJv5PnlJlg4mksFUx33tGLtP\u002BwGkSbaEL0Y3dslO8R7Whx5845ZmEpFHf5qd\u002B0YsBzLKLG4XjgXgENBOqePDDZ\u002BArvLr/PkX1OIjJDcxqaaXBvjQ8lBdxcCyoV1U9f8w9Ba6s\u002BezuKfvKwsACkDdFIlOTzcpdhhZKMO5fSwq/WJ\u002BSzoQGb\u002BPBENIOBdNPd80egzalMel\u002B3EX41W8LGkwEQVKwZIj1M2oiDon68oMH4av4hLdEUTkUeb0UpYj9bcdJ/80YM3HcVymCWtZL4/S3gfYbMzUPTebB/bLkxD2zW27XPE99TXNuDB7k7PhyBjhsdLnDVMcoOQH9gDp5isIkBW1Y6KcQyPeQOBSBCj0ei1gBO6DZROyPmeir03luByxQJgHxfknYWKErTorlK8FkDIuqS0UC3pkBn16N2T3oxP4pQv2T3FjII/y\u002BJM3dw024xOn/6RICXxFSjvkGvkE3UbohDWBuAEXegFJK7dNdmS7VAdZp0v\u002Bw5jbvCex2WxmZzB4kGQX94MEEONPiuX8k/D1Xg9TNI/4qzVyLKHA8ofuOffSZTtJ69cZ8BLMX77plJeoi5vE2XKYBwbmnQKShkx\u002BHaOENstdV4/dhvvjLaJ48J8FwOFc41CZMdofhTTGO7KCbw5ztcPytG2IHUoET3aZNv\u002BO7FS\u002BcnrdSVSc2KtFZZdI4Od6kYMAT3jJWGN4Ox4XzfDhGhozswznZi/BAqOvkfL3/H9CvKmtPg8AAjHUgrMHPiHljRSUyGwiSAmB6GyBLoAgXKz\u002BGHilctUH4tf\u002BM2x7LJ\u002Bbft20ZY2ttvMaZb6VqLaeKwA59Hg1bQPr9ZctMg7Jp3LcEeNmlWY0WfVZ\u002B7uDiwwKzFe\u002BjhMTuGq5yFsRjS\u002B2c7BcV\u002BHBzL1f8FjJ5QyChqau9BRFHWLl74yruTfQptiTanjoJoMxiV4YLpIMJ89\u002BVzX5PW\u002BUwGad3nLXHGv2LcGnKXGUcZv4DaIAgTNC8j3gL6wA4pEd0MSC2DdUuO5lLhI3ZhUPgNIp0BMWADL3GmV3L\u002BUUm94oZ6cMRe9O6thB6O1YV0B8hXWe73qOUWd\u002Ba\u002BzLHJ/Aeai4nb\u002B6hFAzfzB3UIJw5EPf4cvlxv\u002B82av\u002BITDLlEDQ1IfIKSpnZ/veJHvO/WKayd9p/YA\u002BtaQKRf7Uw2VGfH58LTlE9M\u002BklrF/\u002BB2DeKmpabzRUKKNJEofjiXzHxsVn/uszz7AMh92g3Q42RWLsQK2OHg7YG7Ogc/kkOZI3nGdylyRUz7K0zIswSIsRdYjlkVdinuAk7dO\u002BXsngGO0\u002BeQUt3LAlOds/kG9o2e\u002BLgwIrVSF0l3ZdjWqygVcvJ8Z4n90cd08FzZjKMuUlLxf5DDGHRLCAH7OlJ35dN1NNAdNFJWwqD4U8rYsvNvu41P5SNt5p4VBpcTOuX54R\u002BGlUlcB2/TuHrUtE3Yk4Oho2ALfK3P4NvRCwJ90OXnF\u002BVGKX/cgUdlRh3eTBcXcN7dmKVaWx7rNpdHdwGaJ8s8zJPncwFjUbBzkCKGtE5QYj9JoOKJCxs3jDKNqoFwED9r/Qp0meJV1MvDgPA8y9x5Mgw\u002BmrINi1aq\u002BqVebF2utGR\u002Bu/b6v5oi5NYIL0HudbzIkqeNV522RwjlSDpy9"}--><div id="newscomments-Add" class="blaz-adder comments"><div class="commentbreak"><div></div>
									<div><button type="button" class="button mini" onclick="return LPIS.goToLast();"><i class="fas fa-arrow-down"></i>Last Comment</button></div></div><div id="i7101073" class="comment"><div class="commentmember"><img src="https://www.sideshow.com/photo/300715_sq.jpg" class="avatar" alt="Super-man's avatar" /><a href="/member/71033" data-member="71033"><strong>Super-man</strong></a><time datetime="2022-11-06T07:53-05:00">Today, 7:53 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101073,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="7"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101073,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p>This is simply <strong>UNREAL!!!</strong> <img src="/emoticons/twemoji/svg/1f911.svg" border="0" alt="&#129297;" style="width: 1.5em; height: 1.5em; margin: 0 .05em 0 .1em; vertical-align: -.1em;" draggable="false" /></p></div>
								<div class="commentfooter"></div></div></div><div id="i7101077" class="comment"><div class="commentmember"><a href="/member/229961" data-member="229961"><strong>Powerball777</strong></a><time datetime="2022-11-06T07:57-05:00">Today, 7:57 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101077,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="4"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101077,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p><span style="font-size: 16px;">&quot;UNIMAGINABLE&quot; WEALTH!</span></p>

<p><span style="font-size: 16px;">$2.0B and cash value of $1.0B when it's fully loaded!&nbsp;</span></p></div>
								<div class="commentfooter"></div></div></div><div id="i7101090" class="comment"><div class="commentmember"><img src="/avatars/morph.jpg" class="avatar" alt="travelintrucker's avatar" /><a href="/member/172108" data-member="172108"><strong>travelintrucker</strong></a><time datetime="2022-11-06T08:11-05:00">Today, 8:11 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101090,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="2"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101090,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p>I saw #Powerball trending on Twitter. Now, I know why. THIS IS INSANE!!! I'm buying 3 tickets for the game. Good luck to all playing on monday!!</p></div>
								<div class="commentfooter"></div></div></div><div id="i7101091" class="comment"><div class="commentmember"><img src="https://cdn2.iconfinder.com/data/icons/security-2-1/512/spy-512.png" class="avatar" alt="hearsetrax's avatar" /><a href="/member/54024" data-member="54024"><strong>hearsetrax</strong></a><time datetime="2022-11-06T08:12-05:00">Today, 8:12 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101091,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="3"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101091,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p><span style="font-size: 18px;"><strong>nearly speechless....</strong></span></p>

<p><img src="https://tenor.com/view/dont-dont-talk-to-me-evil-eye-twitch-crazy-eyes-gif-15702608.gif" border="0" alt="" width="225" height="225" /></p></div>
								<div class="commentfooter"></div></div></div><div id="i7101094" class="comment"><div class="commentmember"><a href="/member/12171" data-member="12171"><strong>hsg2000</strong></a><time datetime="2022-11-06T08:19-05:00">Today, 8:19 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101094,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="5"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101094,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p>it is so tempting now !</p>

<p>Everyone will rush to buy tickets, I will buy only two !</p></div>
								<div class="commentfooter"></div></div></div><div id="i7101096" class="comment"><div class="commentmember"><img src="https://www.gravatar.com/avatar/37ce5fb33e1c00f3aa416ad011945578?r=pg&f=y&s=128&d=identicon" class="avatar premium" alt="wander73's avatar" /><a href="/member/155979" data-member="155979" class="platinum"><strong>wander73</strong></a><time datetime="2022-11-06T08:22-05:00">Today, 8:22 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101096,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="2"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101096,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p>I avoid social media platforms.&nbsp; &nbsp;they're no good.</p></div>
								<div class="commentfooter"></div></div></div><div id="i7101097" class="comment"><div class="commentmember"><img src="https://www.gravatar.com/avatar/37ce5fb33e1c00f3aa416ad011945578?r=pg&f=y&s=128&d=identicon" class="avatar premium" alt="wander73's avatar" /><a href="/member/155979" data-member="155979" class="platinum"><strong>wander73</strong></a><time datetime="2022-11-06T08:23-05:00">Today, 8:23 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101097,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="2"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101097,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p>$3&nbsp;billion before a ticket is hit.</p></div>
								<div class="commentfooter"></div></div></div><div id="i7101102" class="comment"><div class="commentmember"><img src="https://i.postimg.cc/4dcztH39/Nolz-june15.jpg" class="avatar" alt="CDanaT's avatar" /><a href="/member/123153" data-member="123153"><strong>CDanaT</strong></a><time datetime="2022-11-06T08:35-05:00">Today, 8:35 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101102,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="6"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101102,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p><strong><span style="font-size: 16px;">$1.9&nbsp;BILLION ANNUITY/$929&nbsp;MILLION CASH/ $585,270,000 cash take home</span></strong></p>

<p><strong><span style="font-size: 16px;">Does present quite a nice opportunity to end 2022 on. Let the pondering begin.</span></strong></p>

<p>&nbsp;</p>

<p>&nbsp;</p>

<p><span style="font-size: 18px;">Best of luck to all LP participants.</span></p></div>
								<div class="commentfooter"></div></div></div><div id="i7101104" class="comment"><div class="commentmember"><a href="/member/15486" data-member="15486"><strong>delS</strong></a><time datetime="2022-11-06T08:36-05:00">Today, 8:36 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101104,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="3"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101104,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p>Incredibly mindblowing!</p></div>
								<div class="commentfooter"></div></div></div><div id="i7101113" class="comment"><div class="commentmember"><img src="https://cdn2.iconfinder.com/data/icons/security-2-1/512/spy-512.png" class="avatar" alt="hearsetrax's avatar" /><a href="/member/54024" data-member="54024"><strong>hearsetrax</strong></a><time datetime="2022-11-06T08:45-05:00">Today, 8:45 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101113,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="3"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101113,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="quote"><button type="button" class="button mini" onclick="this.parentNode.classList.add(&#x27;open&#x27;);return false;"><i class="fas fa-plus"></i>In response to delS</button>
										<div class="quotemessage"><p class="quotemessagehead"><strong>Quote:</strong> Originally posted by delS on Nov 6, 2022</p><p>Incredibly mindblowing!</p></div></div><div class="commentbodyinner"><p><img src="https://media.tenor.com/vkrmZeShBkYAAAAC/dont-dont-talk-to-me.gif" border="0" alt="" width="300" height="300" /></p>

<p><strong>I've just about lost all feeling of both mind and body at this point&nbsp;</strong></p></div>
								<div class="commentfooter"></div></div></div><div id="i7101116" class="comment"><div class="commentmember"><img src="/avatars/lightening.jpg" class="avatar" alt="TheMeatman2005's avatar" /><a href="/member/171961" data-member="171961"><strong>TheMeatman2005</strong></a><time datetime="2022-11-06T08:48-05:00">Today, 8:48 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101116,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="4"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101116,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p><span style="font-family: 'Comic Sans MS', 'Comic Sans', Chalkboard, ChalkboardSE-Regular, TSCu_Comic, sans-serif; font-size: 16px;">I am in it to win it!</span></p>

<p><span style="font-family: Comic Sans MS, Comic Sans, Chalkboard, ChalkboardSE-Regular, TSCu_Comic, sans-serif;"><span style="font-size: 16px;">Already purchased some of my tickets. And plan on getting some more.</span></span></p></div>
								<div class="commentfooter"></div></div></div><div id="i7101121" class="comment"><div class="commentmember"><a href="/member/194387" data-member="194387"><strong>EnReval</strong></a><time datetime="2022-11-06T08:56-05:00">Today, 8:56 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101121,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="4"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101121,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p>Am not sure if I want to play more&nbsp;past my multi-draws&nbsp;I already have, been in losing streak with only hitting the red ball lately&nbsp;</p>

<p>am too tired to analyze more numbers&nbsp;</p>

<p>&nbsp;</p>

<p>dream big</p></div>
								<div class="commentfooter"></div></div></div><div id="i7101152" class="comment"><div class="commentmember"><img src="/avatars/lol.png" class="avatar premium" alt="mypiemaster's avatar" /><a href="/member/143015" data-member="143015" class="platinum"><strong>mypiemaster</strong></a><time datetime="2022-11-06T09:40-05:00">Today, 9:40 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101152,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="1"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101152,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p><strong>Currently it's just #2 on the cash value rankings . If it rolls one more time , it will completely shred , destroy and scatter both rankings. Then I shall swoop in and save the day.<img src="/emoticons/us.gif" border="0" alt="" width="68" height="50" />I will have them play the National Anthem before I collect my jackpot <img src="/emoticons/us.gif" border="0" alt="" width="68" height="50" /></strong></p></div>
								<div class="commentfooter"></div></div></div><div id="i7101162" class="comment"><div class="commentmember"><a href="/member/194387" data-member="194387"><strong>EnReval</strong></a><time datetime="2022-11-06T09:50-05:00">Today, 9:50 am</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7101162,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="1"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7101162,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p>Probably, if a high number streak happens</p></div>
								<div class="commentfooter"></div></div></div></div><button type="button" id="newscomments-Btn" class="showmore"><span>&#x25BC; More</span></button><!--Blazor:{"prerenderId":"a2fd4e7899c0425f900b9ea7228f057c"}-->
<div><a href="/rss/news/343144" class="iconlink" title="Subscribe to the RSS feed for this news story and comments."><i class="fas fa-rss-square std"></i>Subscribe to this news story</a></div>
<div style="display:none"><input name="__RequestVerificationToken" type="hidden" value="CfDJ8LHtg3RRLv5BlQ0anQ9VofN1bKCn3AYbUh3D6EsxiT_VptNo2Ny7MS6Z3ZZQK1lavHHoVCCw_qcrRY16ZfMCyAl5chcGa6Ksg8YVpiV_ZgG5tWEjVroYoBZbplJNSZ7DnF_IGKX_kxnqFfXk6uwJuos" /></div>



	</main>
		<div id="aux">
			<div id="aux-content">
				
	<div class="aud aublock"></div>
	<div class="aud aublock"></div>
	<div class="aud aublock"></div>
	<div class="aud autall"></div>

			</div>
		</div>
	<div id="user">
		<div id="user-content">
			<div id="userhead">
				<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path d="M224 256a128 128 0 100-256 128 128 0 000 256zm89.6 32h-16.7a174.3 174.3 0 01-145.8 0h-16.7A134.4 134.4 0 000 422.4V464a48 48 0 0048 48h352a48 48 0 0048-48v-41.6c0-74.2-60.2-134.4-134.4-134.4z"></path></svg>
				Guest
			</div>
			<ul>
					<li><a href="#" class="trigger-login" tabindex="-1"><i class="fas fa-lock-open fa-fw"></i>Log In</a></li>
					<li><a href="/register" tabindex="-1"><i class="fas fa-user-plus fa-fw"></i>Register</a></li>
				<li class="sep"><a href="/options" tabindex="-1"><i class="fas fa-cog fa-fw"></i>Options</a></li>
				<li><a href="#" onclick="return LP.reloadApp();" tabindex="-1"><i class="fas fa-redo fa-fw"></i>Reload App</a></li>
				<li><a id="aths" href="#" tabindex="-1"><i class="fas fa-plus fa-fw"></i>Add to Home Screen</a></li>
				<li><a href="/whatsnew" tabindex="-1"><i class="fas fa-star fa-fw"></i>What's New</a></li>
				<li><a href="/about" tabindex="-1"><i class="fas fa-info-circle fa-fw"></i>About Lottery Post</a></li>
			</ul>
		</div>
	</div>
</div>
<footer>
	<p><a href="/about">About&nbsp;Us</a>&nbsp;&nbsp;|&nbsp; <a href="/privacy">Privacy</a>&nbsp;&nbsp;|&nbsp; <a href="/dmca">DMCA</a>&nbsp;&nbsp;|&nbsp; <a href="/help">Help</a>&nbsp;&nbsp;|&nbsp; <a href="/contact">Contact&nbsp;Us</a>&nbsp;&nbsp;|&nbsp; <a href="/sitemap">Site&nbsp;Map</a></p>
	<p>This page was generated in 0.1058 seconds.<br />Copyright &copy; 1999-2022 <a href="https://www.speednet.biz/">Speednet Group</a>.&nbsp; All&nbsp;rights&nbsp;reserved.</p>
</footer>
<div id="audhead" class="aud auhead"></div>
<div id="anchorPanel"><div id="aumanchor" class="aum auhoriz"></div></div>

<script>!function(n,t,i){var r=typeof n.Promise!==i||!n.Promise.prototype["finally"]||!n.Promise.allSettled,u=typeof n.fetch!==i,f=typeof n.ResizeObserver===t;if(r&&document.write('<script src="/js/promise.min.js"><\/script>'),u){document.write('<script src="/js/fetch.min.js"><\/script>');Array.prototype.includes||(Array.prototype.includes=function(n){return!!~this.indexOf(n)});try{n.WeakSet=WeakSet}catch(e){!function(t){function u(n){i.set(this,new t);n&&n.forEach(this.add,this)}var i=new t,r=u.prototype;r.add=function(n){return i.get(this).set(n,1),this};r.delete=function(n){return i.get(this).delete(n)};r.has=function(n){return i.get(this).has(n)};n.WeakSet=u}(WeakMap)}}f&&document.write('<script src="/js/ResizeObserver.min.js"><\/script>')}(window,"undefined","function")</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script async src="https://c.amazon-adsystem.com/aax2/apstag.js"></script><script async src="/js/pb.js?v=PNp9UUeXWAzwOAMiAf-TTsmtCSrln3FM8GRSGPIIQF0"></script><script src="/js/site.min.js?v=ayIB1afp57J0USunKSTwJ7sjPLXwjXSK28QKw7Fqals"></script>
		<script src="/lib/clipboard.min.js?v=4XodgW4TwIJuDtf-v6vDJ39FVxI0veC_kSCCmnFp7ck"></script>
		<script src="/js/thread.min.js?v=R_grEmrfXPsyOHXQiV1t8-det7HxY-MmMXfKvgeVy1c"></script>
		<script src="/js/infinitescroll.min.js?v=g4KkybtZMWvuN3xKQe8v02VIa1mwX2l8TuJ8QyLnqas"></script>
		<script src="/lib/fslightbox/fslightbox.js?v=DNQLiUUcaJjo7_hyXbSv5VO7dcoFIiJaL7mlcnxFpDM"></script>
	<script src="_framework/blazor.server.js"></script>
	<script>window.addEventListener("beforeunload", function () { Blazor.defaultReconnectionHandler._reconnectionDisplay = {}; });</script>

	<script>LP.setClipboardCopyElement(".storylink",null,true,"Link copied!");</script>
	<script type="application/ld+json">{"@context":"https://schema.org/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.lotterypost.com/news/343144"},"description":"Last night Powerball didn't just set a new lottery jackpot record, it crushed the old record, putting the concept of a $2 billion lottery jackpot within reach.","commentCount":"39","datePublished":"2022-11-06T07:36:41-05:00","dateModified":"2022-11-06T07:36:41-05:00","headline":"$1.9 BILLION POWERBALL JACKPOT SETS WORLD RECORD OF UNIMAGINABLE WEALTH","keywords":"lottery,2,41,168,206","image":["/images/newsicon_powerball.jpg"],"thumbnailUrl":"/images/newsicon_powerball.jpg","dateline":"","author":{"@type":"Person","name":"Todd Northrop"},"isAccessibleForFree":true,"publisher":{"@type":"Organization","name":"Lottery Post","logo":{"@type":"ImageObject","url":"https://www.lotterypost.com/images/lp_icon_310.png"}}}</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=G-GBR57VB2CX"></script>
<script>function gtag(){dataLayer.push(arguments)}window.dataLayer=window.dataLayer||[];gtag("js",new Date);gtag("config","G-GBR57VB2CX");</script>
<script async src="https://secure.quantserve.com/quant.js"></script>
<script>window._qevents=window._qevents||[];window._qevents.push({qacct:"p-7alUP9zu-TfBA"})</script>
<noscript><div style="display:none"><img src="//pixel.quantserve.com/pixel/p-7alUP9zu-TfBA.gif" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="application/ld+json">
	{"@context":"https://schema.org/","@id":"https://www.lotterypost.com/#organization","@type":"Organization","name":"Lottery Post","url":"https://www.lotterypost.com/","logo":{"@type":"ImageObject","url":"https://www.lotterypost.com/images/lotterypost.svg","width":1200,"height":504},"founder":{"@type":"Person","name":"Todd Northrop"},"description":"Lottery results, forums, news, United States lotteries, jackpots, predictions, and information for the serious lottery player.","sameAs":["https://www.youtube.com/LotteryPost","https://www.facebook.com/LotteryPost","https://twitter.com/LotteryPost","https://www.instagram.com/LotteryPost/"]}
</script>
<script type="application/ld+json">
	{"@context":"https://schema.org","@id":"https://www.lotterypost.com/#website","@type":"WebSite","url":"https://www.lotterypost.com/","name":"Lottery Post","potentialAction":{"@type":"SearchAction","target":"https://www.lotterypost.com/search?q={search_term_string}&src=mc_google","query-input":"required name=search_term_string"}}
</script>
</body>
</html>
