<!DOCTYPE html>
<html lang="en"><head><meta charset="utf-8" />

<!--
	Lottery Post® (https://www.lotterypost.com)
	Author: Todd Northrop
	Contact: https://www.lotterypost.com/contact
	Copyright © 1999-2022. All Rights Reserved.
	Reproduction in whole or in part in any form or medium without express written permission of the Author is prohibited. See https://www.lotterypost.com/copyright
	Lottery Post and the Lottery Post logo are registered trademarks of Speednet Group, and may not be used without express written permission.
- - - - - - - - - - - - - - - - - - - - - - - - - - - -->

	<title>Two Illinois lottery winners in a partnership claim $1.34 billion Mega Millions jackpot | Lottery Post</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	<meta name="application-name" content="Lottery Post" />
	<meta name="format-detection" content="telephone=no" />
	<meta name="keywords" content="lottery,news,Mega Millions,Winner Stories,Jackpots,Illinois,Multi-State Game,Anonymous" />
	<meta name="description" content="Two winners in a partnership have come forward to claim the eye-watering $1.34 billion Mega Millions jackpot that was drawn in July 2022." />
	<meta name="apple-mobile-web-app-title" content="Lottery Post" />
	<meta property="og:site_name" content="Lottery Post" />
	<meta property="og:title" content="Two Illinois lottery winners in a partnership claim $1.34 billion Mega Millions jackpot" />
	<meta property="og:description" content="Two winners in a partnership have come forward to claim the eye-watering $1.34 billion Mega Millions jackpot that was drawn in July 2022." />
	<meta property="og:image" content="https://www.lotterypost.com/images/newsicons/newsicon_megamillions.jpg" />
	<meta property="og:type" content="website" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:site" content="@LotteryPost" />
	<meta name="theme-color" content="#bcceff" />
	<meta property="og:url" content="https://www.lotterypost.com/news/342559" />
	<link rel="canonical" href="https://www.lotterypost.com/news/342559" />
	<link rel="alternate" href="https://www.lotterypost.com/rss/news/342559" type="application/rss+xml" title="Subscribe to &quot;Two Illinois lottery winners in a partnership claim $1.34 billion Mega Millions jackpot&quot;" />
	<link rel="icon" href="/favicon.ico" sizes="any">
	<link rel="icon" href="/favicon.svg" type="image/svg+xml">
	<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png" />
	<link rel="manifest" href="/site.webmanifest">
	<link rel="preload" as="font" type="font/woff2" href="/fonts/NotoSans-Regular.woff2" />
	<link rel="preload" as="font" type="font/woff2" href="/fonts/NotoSans-Italic.woff2" />
	<link rel="preload" as="font" type="font/woff2" href="/fonts/NotoSans-Bold.woff2" />
	<link rel="preload" as="font" type="font/woff2" href="/fonts/NotoSans-BoldItalic.woff2" />
	<link rel="preload" as="font" type="font/woff2" href="/lib/fa/webfonts/fa-solid-900.woff2" />
	<link rel="preload" as="font" type="font/woff2" href="/lib/fa/webfonts/fa-brands-400.woff2" />
	<link rel="stylesheet" href="/lib/fa/css/all.min.css?v=cpCCrLFdFQDBm5Tm4jhvrpyrflM54ZawRJISyyRq04Q" />
	<link rel="stylesheet" href="/css/site.min.css?v=yrcCLABsE83OHDY7gjJ1xHFHCg4eauiKEjmhJVNLz24" />
		<link rel="stylesheet" href="/css/newsstory.min.css?v=iIBJlmuvLPQ1-QQhenBYdVjgJJN5Pn9p_DDStD-S2Sk" />

	<script>var LPInit={menuVersion:'34',status:0,lastUsername:''};</script>
	<base href="/" />
</head>
<body class="newsstory">
	<header>
		<div id="menuicon" class="icn"><i></i></div>
		<div id="refreshicon" class="icn"><i class="fas fa-redo"></i></div>
		<div id="backicon" class="icn"><i class="fas fa-arrow-left"></i></div>
		<a id="HeaderLogo" href="/" title="Lottery Post"><img src="/images/lotterypost.svg" width="190" height="50" alt="Lottery Post" /></a>
		<div id="searchicon" class="icn"><i class="fas fa-search"></i></div>
<div id="shareicon" class="icn"></div>		<div id="usericon" class="icn"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path d="M224 256a128 128 0 100-256 128 128 0 000 256zm89.6 32h-16.7a174.3 174.3 0 01-145.8 0h-16.7A134.4 134.4 0 000 422.4V464a48 48 0 0048 48h352a48 48 0 0048-48v-41.6c0-74.2-60.2-134.4-134.4-134.4z"></path></svg></div>
	</header>
	<nav>
		<div id="menuicon2container">
			<div id="menuicon2" class="icn"><i></i></div>
		</div>
		<div id="menu">
			<ul>
				<li><a href="/forums"><i class="fas fa-comment"></i>Forums</a></li>
				<li><a href="/results"><i class="fas fa-check-circle"></i>Results</a></li>
				<li><a href="/predictions"><i class="fas fa-bullseye"></i>Predictions</a></li>
				<li><a href="/members"><i class="fas fa-user"></i>Members</a></li>
				<li><a href="/systems"><i class="fas fa-chart-line"></i>Systems</a></li>
				<li><a href="/resources"><i class="fas fa-info-circle"></i>Resources</a></li>
			</ul>
		</div>
		<div id="auxcommand">
			<div id="search">
				<div><input type="text" id="mainSearchInput" maxlength="250" placeholder="Search Lottery Post" /><i id="mainSearchSubmit" class="fas fa-search fa-fw"></i></div>
			</div>
			<div id="userinfo">
					<strong>Welcome Guest</strong> ( <a href="#" class="trigger-login">Log In</a> | <a href="/register">Register</a> )
			</div>
		</div>
	</nav>
<div id="content">
	<div id="quick">
		<div id="quick-content">
			<div id="quick-logo"><img src="/images/lotterypost.svg" width="100" height="26" alt="Lottery Post" /></div>
			<ul>
				<li><a href="/">Home</a></li>
				<li><a href="/memberships"><i class="fas fa-star std"></i> Premium Memberships</a></li>
				<li><a href="/results">Lottery Results</a></li>
				<li><a href="/forums">Forums</a></li>
				<li><a href="/predictions">Predictions</a></li>
				<li><a href="/videos">Lottery Post Videos</a></li>
				<li><a href="/news">News</a></li>
				<li><a href="/results/search">Search Drawings</a></li>
				<li><a href="/search">Search Lottery Post</a></li>
				<li><a href="/systems">Lottery Systems</a></li>
				<li><a href="/charts">Lottery Charts</a></li>
				<li><a href="/wheels">Lottery Wheels</a></li>
				<li><a href="/jackpots">Worldwide Jackpots</a></li>
				<li><a href="/quickpicks">Quick Picks</a></li>
				<li><a href="/onthisday">On This Day in History</a></li>
				<li><a href="/blogs">Blogs</a></li>
				<li><a href="/games">Online Games</a></li>
				<li><a href="/features">Premium Features</a></li>
				<li><a href="/contact">Contact Us</a></li>
				<li><a href="/whitelist">Whitelist Lottery Post</a></li>
				<li><a href="/rules">Rules</a></li>
				<li><a href="/books"><i class="fas fa-book std"></i> Lottery Book Store</a></li>
				<li><a href="https://shop.lotterypost.com/"><i class="fas fa-gift std"></i> Lottery Post Gift Shop</a></li>
			</ul>
			<p class="socialmedia"><a href="https://www.facebook.com/LotteryPost" title="Facebook"><i class="fab fa-facebook"></i></a><a href="https://www.twitter.com/lotterypost" title="Twitter"><i class="fab fa-twitter"></i></a><a href="https://www.instagram.com/lotterypost" title="Instagram"><i class="fab fa-instagram"></i></a><a href="https://www.youtube.com/lotterypost" title="YouTube"><i class="fab fa-youtube"></i></a></p>
			<a href="https://www.usamega.com" title="Powerball and Mega Millions lottery results and news"><img src="/images/usa-mega-button-2.png" class="usamega" width="140" height="97" alt="USA Mega"></a>
			<div id="audmenu" class="aud autall"></div>
			<p><a title="Lottery Places free app for iPhone, Android, and Windows" href="https://www.lotteryplaces.com/"><img src="/images/LotteryPlaces_140x375_2x.jpg" width="140" height="375" alt="Lottery Places"></a></p>
			<ul>
				<li><a href="/js-compress">JavaScript Compressor</a></li>
				<li><a href="/css-compress">CSS Compressor</a></li>
				<li><a href="https://mybrowserinfo.com/" rel="external">Browser Information</a></li>
			</ul>
			<div class="timesummary">
				<p>The time is now 5:12&nbsp;pm</p>
					<p>You last visited<br />September&nbsp;21,&nbsp;2022, 5:12&nbsp;pm</p>
				<p>All times shown are<br />Eastern Time (GMT-5:00)</p>
			</div>
		</div>
	</div>
	<main>
<img src="/b.gif" alt=""/>		<div class="aum auhoriz"></div>
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":{"@type":"Thing","@id":"/"}},{"@type":"ListItem","position":2,"name":"Lottery News","item":{"@type":"Thing","@id":"/news"}},{"@type":"ListItem","position":3,"name":"Two Illinois lottery winners in a partnership claim $1.34 billion Mega Millions jackpot","item":{"@type":"Thing","@id":"/news/342559"}}]}</script><div class="breadcrumb"><a href="/">Home</a>&nbsp;&rsaquo; <a href="/news">Lottery News</a>&nbsp;&rsaquo; Two Illinois lottery winners in a partnership claim $1.34 billion Mega Millions jackpot</div>
<h1 class="main">Two Illinois lottery winners in a partnership claim $1.34 billion Mega Millions jackpot</h1>
<p class="pubinfo">Sep 21, 2022, 3:58 pm (<a href="#" onclick="return LP.scrollTo('#newscomments');">3 comments</a>)<span class="social"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.lotterypost.com%2Fnews%2F342559" class="iconlink bold inline"><i class="fab fa-facebook std"></i>Share</a><a href="https://twitter.com/share?url=https%3A%2F%2Fwww.lotterypost.com%2Fnews%2F342559&text=Two&#x2B;Illinois&#x2B;lottery&#x2B;winners&#x2B;in&#x2B;a&#x2B;partnership&#x2B;claim&#x2B;%241.34&#x2B;billion&#x2B;Mega&#x2B;Millions&#x2B;jackpot" class="iconlink bold inline"><i class="fab fa-twitter std"></i>Tweet</a><a href="#" class="storylink iconlink bold inline" data-clipboard-text="https://www.lotterypost.com/news/342559"><i class="fas fa-copy std"></i>Copy Link</a> </span></p>
<article>
	<img src="/images/newsicons/newsicon_megamillions.jpg" width="140" height="100" class="articleicon" alt="Mega Millions" />
	<p style="font-size: 115%; font-weight: bold;">Winners split behemoth win within timeframe to claim cash prize</p>

<p style="font-size: 80%;">By Kate Northrop</p>

<p><span itemprop="dateline">CHICAGO, Ill.</span>&nbsp;&mdash; Two winners in a partnership have come forward to claim the eye-watering $1.34&nbsp;billion Mega Millions jackpot that was drawn in July&nbsp;2022.</p>

<p>One single ticket was all it took to win the record <a href="/news/341791" rel="external">$1.34&nbsp;billion Mega Millions jackpot</a> on July&nbsp;29,&nbsp;2022, but two people jointly stepped forward to claim it all.</p>

<p>Today, the Illinois Lottery announced that the prize has officially been claimed, shared by a partnership that agreed to split the winnings if won, and they kept their billion-dollar promise.</p>

<p>&quot;I've been working for the Illinois Lottery for over five years, and this is by far the largest prize I've ever had to process,&quot; Illinois Lottery Claims Manager Luis Rodriguez said in a press release. &quot;When we met with the winners' lawyers there was a real buzz of excitement in the room,&quot; said Rodriguez.</p>

<p>With Illinois allowing winners of $250,000 to remain anonymous, the two ticketholders predictably opted not to give out their names, and it is very likely we won't find out their identities anytime soon. Rodriguez was there to support the winners and their legal representatives during the claim process.</p>

<p>&quot;It's a surreal feeling giving away this amount of money and knowing what a huge impact this is going to make on the winners' lives, and for others close to them as well,&quot; Rodriguez continued. &quot;It was an incredible feeling just to be part of that process &mdash; so I can only imagine how the winners themselves are feeling.&quot;</p>

<p>While the Illinois Lottery cannot share any information about the winners, they did say that they must be absolutely &quot;over the moon&quot; with their win.</p>

<div id="aumhoriz" class="aum auhoriz"></div><p>The partners claimed the prize just before a <a href="/news/342441" rel="external">major deadline</a> that would have prevented them from claiming it as a cash option. Had they waited until Sept.&nbsp;27,&nbsp;2022, less than a week away, they would have only had the option to claim the prize as an annuity.</p>

<p>In Illinois, Mega Millions winners get one year from the draw date to claim their prize, but only as an annuity. The prize can only be claimed as a lump sum within 60 days.</p>

<p>But nearly eight weeks after the historic drawing, it's no longer a topic of conversation. Instead, they're likely focused on what they're going to do with an unimaginable amount of money.</p>

<p>&quot;These winners are now in the enviable position of deciding what to do with their newfound fortune,&quot; Lottery Director Harold Mays noted. &quot;They stopped into the Speedway in Des Plaines and grabbed a Mega Millions ticket while they were there. That turned out to be an absolutely life changing decision when a $3 line of Mega Millions with Megaplier turned into a $1.34&nbsp;billion jackpot win.&quot;</p>

<p>Over the past few weeks, the two winners have been busy working with a team consisting of professional legal and financial advisors in preparation for the claim.</p>

<p>They chose to take the lump sum payment of $780.5&nbsp;million. According to <a href="https://www.usamega.com/mega-millions/jackpot/2022/7/29" rel="external">USA Mega</a>, their net payout will be about $453.12&nbsp;million after taxes.</p>

<p>During the jackpot roll, which lasted for 29 drawings without a winner between April&nbsp;16 and July&nbsp;29, the state of Illinois also came out on top, having generated $34&nbsp;million for the Common School Fund through Mega Millions sales.</p>

<p>Retailers were paid a collective $3.75&nbsp;million in commissions and bonuses for selling winning tickets, and there were over 1.4 million winning tickets in Illinois totaling $11.8&nbsp;million in prizes, excluding the jackpot, including four players who won $1&nbsp;million.</p>

<p>The next Mega Millions drawing will take place on Fri., Sept.&nbsp;23 at 11:00 pm EST for a jackpot of $301&nbsp;million. The Powerball jackpot is not far behind, sitting at $251&nbsp;million for the drawing on Wed., Sept.&nbsp;21 at 10:59 pm EST.</p>
</article>
	<p><i class="fas fa-globe"></i> Lottery Post Staff</p>
<div class="aum auhoriz"></div>
<div class="relatedinfo">
	<div>
		<div class="relatedlinks">
			<h1>Related links</h1>
				<p><a href="https://www.usamega.com/">USA Mega - Home of Powerball and Mega Millions</a></p>
				<p><a href="https://www.lotterypost.com/partner/45">Play Mega Millions online</a></p>
				<p><a href="https://www.lotterypost.com/partner/michigan_megamillions">Buy official Mega Millions tickets from the Michigan Lottery</a></p>
				<p><a href="https://www.lotterypost.com/partner/minnesota_megamillions">Buy official Mega Millions tickets from the Minnesota Lottery</a></p>
				<p><a href="https://www.lotterypost.com/partner/oregon_megamillions">Buy official Mega Millions tickets from the Oregon Lottery</a></p>
				<p><a href="https://www.lotterypost.com/partner/texas_megamillions">Buy official Mega Millions tickets from the Texas Lottery</a></p>
				<p><a href="https://www.lotterypost.com/partner/virginia_megamillions">Buy official Mega Millions tickets from the Virginia Lottery</a></p>
		</div>
		<div class="relatednewsstories">
			<h1>Related news stories</h1>
				<p><a href="/news/333916">Anonymous New Jersey winner claims $202 million Mega Millions lottery jackpot</a><span>Sep 30, 2020</span></p>
				<p><a href="/news/332588">Arizona couple steps forward to claim $410 million Mega Millions jackpot</a><span>Jun 19, 2020</span></p>
				<p><a href="/news/329521">Lucky Texan just claimed biggest prize ever paid to a single player in state&#x27;s lottery</a><span>Oct 29, 2019</span></p>
				<p><a href="/news/326032">Winner of $1.5B lottery jackpot donates some winnings to Alabama tornado victims</a><span>Mar 18, 2019</span></p>
				<p><a href="/news/307835">Illinois couple claim $134 million Mega Millions lottery jackpot</a><span>Oct 25, 2016</span></p>
		</div>
	</div>
	<div>
		<h1>Tags for this story</h1>
		<ul class="tags">
			<li><a href="/search/tag?q=anonymous" rel="tag" style="font-size:15px;" title="Anonymous">Anonymous</a></li>&#32;
			<li><a href="/search/tag?q=illinois" rel="tag" style="font-size:15px;" title="Illinois">Illinois</a></li>&#32;
			<li><a href="/search/tag?q=jackpots" rel="tag" style="font-size:22px;" title="Jackpots">Jackpots</a></li>&#32;
			<li><a href="/search/tag?q=mega_millions" rel="tag" style="font-size:18px;" title="Mega Millions">Mega Millions</a></li>&#32;
			<li><a href="/search/tag?q=multi-state_game" rel="tag" style="font-size:19px;" title="Multi-State Game">Multi-State Game</a></li>&#32;
			<li><a href="/search/tag?q=winner_stories" rel="tag" style="font-size:24px;" title="Winner Stories">Winner Stories</a></li>&#32;
		</ul>
		<h2>Other popular tags</h2>
		<ul class="tags clr">
			<li><a href="/search/tag?q=administration" rel="tag" style="font-size:13px;" title="Administration">Administration</a></li>&#32;
			<li><a href="/search/tag?q=crime" rel="tag" style="font-size:13px;" title="Crime">Crime</a></li>&#32;
			<li><a href="/search/tag?q=financials" rel="tag" style="font-size:14px;" title="Financials">Financials</a></li>&#32;
			<li><a href="/search/tag?q=insider_buzz" rel="tag" style="font-size:14px;" title="Insider Buzz">Insider Buzz</a></li>&#32;
			<li><a href="/search/tag?q=legal" rel="tag" style="font-size:14px;" title="Legal">Legal</a></li>&#32;
			<li><a href="/search/tag?q=legislation" rel="tag" style="font-size:13px;" title="Legislation">Legislation</a></li>&#32;
			<li><a href="/search/tag?q=powerball" rel="tag" style="font-size:15px;" title="Powerball">Powerball</a></li>&#32;
			<li><a href="/search/tag?q=retailer" rel="tag" style="font-size:13px;" title="Retailer">Retailer</a></li>&#32;
			<li><a href="/search/tag?q=scratch_games" rel="tag" style="font-size:14px;" title="Scratch Games">Scratch Games</a></li>&#32;
			<li><a href="/search/tag?q=winning_ticket_announcement" rel="tag" style="font-size:13px;" title="Winning Ticket Announcement">Winning Ticket Announcement</a></li>&#32;
			<li style="float:right; margin:5px 0 0 10px;"><a href="/tags" style="font-size:14px;" ToolTip="Display all news story tags (the &quot;Tag Cloud&quot;)">More &raquo;</a></li>
		</ul>
	</div>
</div>
<div id="audhoriz" class="aud auhoriz"></div>
<h1>Comments</h1>
<div id="newscomments"></div>
<!--Blazor:{"sequence":0,"type":"server","prerenderId":"0646c324149b457296e2ba7bc7bae9a1","descriptor":"CfDJ8K\u002Bi0v5wm8dLip7YGXXiGSrjqmvRVuaxb7JCWlOvL85HHY9uEXd\u002BF95YsC4ZrGKn3YQy8\u002Bglc4T0pKglEllsjaloNt7BOPyITxmAOrf5X/nRHS3tRJUEnuS3rXe2Ixqi045pY43PEv6jzK7HCoM2iyIINw\u002BQjeTNqRxI7tKfxROb\u002BWX0r3aW58hrLyXBWt\u002BTjT0mxaaDC2MVMCHiTpKAsKVtPTsfAdBc1NzBfH3zmjgvp8QIfh7OGeiT7pmoMDQ4l\u002BHxuV8/gKq\u002BC1tsyDcw0gqPAJglwZ5jD7vKIiKprfcePTGA4zT2zgcg\u002BJeiMGi/4NKC8um76\u002BGqfUhSyyEmjAFyOeneF7fe1AVtaWlD76azdxTBzZBu9DY6iFVeYj\u002BlQmiXoaFsgFmV/pUPbZk6qnxUq44G8n1QYQKQA/35anizyB5ULW16GijrdgCa2rw\u002BKOL9nKjv9sQ5pGh\u002BPBZz6xP34smHqatqc2EwpGFVAgHGiVX4mkgkb63fZfJr5d\u002BGU5Nc3TLUbOAJyoS8ORydFP03tnEEaPc0GQ7ZFghcG8o8D9xAqocgC27JgiX5p21O4lVqLxZvFTMD4spHFEIl8VRgXKSmpkxzukEc9R2Ach5SfRuL8jHv/bfTHDBHM25H3WZLOfRpE7fJYwS\u002BipCrC8PGJZJKt4DtbTZYZX1kncll/DgwtLbs8elhDStkKFUY9iFR2SccV3TBLuEU6fE479tNFYxzGBWFcvv4ARXknDuFkuZMSDj8iU8lgQiYetfjor\u002Bb2hW3P4E4614GXErLn68AGXzSsHOigCqVk/5bRfyhQEovwaHR0iprwOcgRVwl0DS3jrgQ5THcjYNl3\u002BRMwwA3IcNJmiRFcIpthqrQ\u002BP8ofO6L8vztSIW1WlAGJx7RGdFmUwSZ\u002BDlbzBnvkd/n902NkP5arJzEYOrG9Ri7lN9aa9Xt/MydMCjUJI6r0o3P8HmRn\u002B6PRd\u002BuS7brmzzH/YNkvkURHJAd22fjPuEygnJc4\u002B0TsfxYvmJS0cUwfjjPNodD9SYFbbWVyG18Tb1jiYciP0e2KFISxg5j\u002BN13\u002BAIw9KMZoFBsjPh2BkSfWaeiBr7GtIIhHe\u002Bn04yxRHG\u002BlxMtvS8HwuNq98M8JFq5QalMNouzNbGmLpjFY9b5Wf/ydUXBxhQAZZhC/IH1ASK4Kx8U3mLLqJiht4CEa4yX9ma5ariITafMLatUnpbyxQZjai5ZqV/dIFcx9GAZ6VO/hrUAs00/0LA8bGXYqjX\u002BKiRKc/S5AxrWMA5rqqxCTk7dec1HKbYHLeaRjODgLnlis4Emvwd9unkYrX\u002BY/uK9PrZn8HEzmkpo1GVSi7JC64lM7tCJ8Iqz1q27QQQbH8tCT6QMTWiaeX6iEbS0oVl8ZV27m1FjKj6QAXpp7hytOPHWXCjDmUdsaPU3BsIbZYv7F\u002BzqLJwzTMnV1DwJkEiQU6Ulcy5z74LfmOy9BVXqWMs1QuPLlqCZbfcCaDoqrRL\u002BDwQvUlEmMsBggcy6rbbbtNnrqWZekn4PcnSjJQC56vfAYdbq1mp382kGjb9qZkBraDwZH6pixS7XQwnnKwDrwvO91fagF7yCiJbgbl5yykvG48zpUlHE27QR7I718GypCDOn53dtErdtCNXXQOFyejcyYDIbZwfeHupQwTHs9AgJtl7r9f8cU\u002BwQ\u002B/6hmvV2iG/yNX9qFLeYJhUBKuIqkNa779bGsPzQU8NF4Vpn8E3DFFQxPFMRz\u002BGEMTdiuVPzZPrDR\u002BPJGHpjdWRVzH4kN1yBWkD9SY8tPT2/Y/Dfkm4R/SwMZN4g6vY1WxHyrPhKWp5cuXCnwuuk4O4311U1X4\u002BfejfgJtpugqyPfFTxcCLHVoau8HHQoVZdLVAbDY7fG3WSiRhRGK0Awdc7guE7qGPWLSoE/BvNE7a3iYC5MXBK2AfDFQQWjMo/kNhFUvoBAyDg8LIPIrdc3qbbXf12e4mqn5knPU1wZJ34Ph8dECPl\u002B1NlCnsaFfWV2RVrDLI7MiSJpX9W40nbZbooXmYuNsy2WMF5/2Z6/503vBcAj3ZDPv9luYWFJhmgiYCMcLTl6dDEGw982LHK8lrFNuq3C1ByjphhXDdBsgeFWJ6HEQxGRg9CEplCBl1lL2VqEcELOisqL78yRHoUElmPEtuMyAipMF3NTxSghCfcq6GPuNKex2DfhFT9esaxwC0\u002B2PFUmlQ1Wx3PRt3o9LaqBIh5ck9b/AvlQ9J1syZ9l/Gw9HIODWbmEkaUb2qLpswwnz6ESaiLGLRmEbddGdQQf\u002BUE18QJoUdXSYjHGZe3umWcutDVUAD3aORY2PR1zNe\u002B2GW5MXUQJ3xba6VbOo9ePoNtF6EzFpFB6Nbjg/Hw7iD3deIYQnJZzmllCDFaFGsHFrwVrSlYDUuCyqh82oU4RFtWmMHr24to6Caly\u002BhCPQRew9M85gsZKsv0kkcumTjoMbbwxifoG1A98kMREivY9xeq\u002BwukIeyuJioGC4opXPOxVGryeQoaQJqz4KaHmTLBJJjFXfi/JKRDUiIFcTYXFk8oWS8UZ08T7d\u002BKTUlO5UxccSlbNHbqqs5LNlxO14e2QnelJi9yUFY1wbZd\u002BcjOnnkOePFN6U8cWVmg6bI6TTR6xIrZ9e07FdODHVUgnlrB0hUfUNDWagw18/Ef85WKn3\u002B1kTp6"}--><div id="newscomments-Add" class="blaz-adder comments"><div class="commentbreak"><div></div>
									<div><button type="button" class="button mini" onclick="return LPIS.goToLast();"><i class="fas fa-arrow-down"></i>Last Comment</button></div></div><div id="i7063672" class="comment"><div class="commentmember"><a href="/member/138458" data-member="138458" class="platinum"><strong>noise-gate</strong></a><time datetime="2022-09-21T16:00-05:00">Today, 4:00 pm</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7063672,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="1"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7063672,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p>* Enjoy your wealth!</p></div>
								<div class="commentfooter"></div></div></div><div id="i7063687" class="comment"><div class="commentmember"><a href="/member/204745" data-member="204745" class="platinum"><strong>scorpio45</strong></a><time datetime="2022-09-21T16:19-05:00">Today, 4:19 pm</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7063687,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="0"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7063687,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="commentbodyinner"><p>was it a QUICK PICK,they hide that so no one knows if it was rigged by lottery?</p></div>
								<div class="commentfooter"></div></div></div><div id="i7063699" class="comment"><div class="commentmember"><img src="https://members.lotterypost.com/todd/images/avatar/Cylon-200.jpg" class="avatar premium" alt="Todd's avatar" /><a href="/member/1" data-member="1" class="platinum"><strong>Todd</strong></a><time datetime="2022-09-21T16:37-05:00">Today, 4:37 pm</time></div>
							<div class="commentcontrols"><div class="commentscore"><button type="button" class="upvote" onclick="return Thd.scoreSet(this,7063699,1);" title="Upvote" aria-label="Upvote">▲</button><i class="score" title="1"></i><button type="button" class="downvote" onclick="return Thd.scoreSet(this,7063699,-1);" title="Downvote" aria-label="Downvote">▼</button></div></div>
							<div class="commentbody widthscroller fullwidth"><div class="quote"><button type="button" class="button mini" onclick="this.parentNode.classList.add(&#x27;open&#x27;);return false;"><i class="fas fa-plus"></i>In response to scorpio45</button>
										<div class="quotemessage"><p class="quotemessagehead"><strong>Quote:</strong> Originally posted by scorpio45 on Sep 21, 2022</p><p>was it a QUICK PICK,they hide that so no one knows if it was rigged by lottery?</p></div></div><div class="commentbodyinner"><p>So are you among those who feel that lottery winners should never be allowed to remain anonymous?</p></div>
								<div class="commentfooter"></div></div></div><div class="commentbreak"><div>End of comments</div>
							<div><button type="button" class="button mini" onclick="return LP.scrollTo('#newscomments');"><i class="fas fa-arrow-up"></i>First Comment</button></div></div></div><!--Blazor:{"prerenderId":"0646c324149b457296e2ba7bc7bae9a1"}-->
<div><a href="/rss/news/342559" class="iconlink" title="Subscribe to the RSS feed for this news story and comments."><i class="fas fa-rss-square std"></i>Subscribe to this news story</a></div>
<div style="display:none"><input name="__RequestVerificationToken" type="hidden" value="CfDJ8K-i0v5wm8dLip7YGXXiGSrYCRS51mKpc6_BODbauSzIlUXcgLMCP0nZKeeBRF1uVx1ZBjG3B7JDTQhXUzTmcBxiO4OeMOcUxFc9sKb2aKp886mon8q7cdtB9nw_Wh7jd6SRuFAI91C-LdhnR2PQpY0" /></div>



	</main>
		<div id="aux">
			<div id="aux-content">
				
	<div class="aud aublock"></div>
	<div class="aud aublock"></div>
	<div class="aud aublock"></div>
	<div class="aud autall"></div>

			</div>
		</div>
	<div id="user">
		<div id="user-content">
			<div id="userhead">
				<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path d="M224 256a128 128 0 100-256 128 128 0 000 256zm89.6 32h-16.7a174.3 174.3 0 01-145.8 0h-16.7A134.4 134.4 0 000 422.4V464a48 48 0 0048 48h352a48 48 0 0048-48v-41.6c0-74.2-60.2-134.4-134.4-134.4z"></path></svg>
				Guest
			</div>
			<ul>
					<li><a href="#" class="trigger-login" tabindex="-1"><i class="fas fa-lock-open fa-fw"></i>Log In</a></li>
					<li><a href="/register" tabindex="-1"><i class="fas fa-user-plus fa-fw"></i>Register</a></li>
				<li class="sep"><a href="/options" tabindex="-1"><i class="fas fa-cog fa-fw"></i>Options</a></li>
				<li><a href="#" onclick="return LP.reloadApp();" tabindex="-1"><i class="fas fa-redo fa-fw"></i>Reload App</a></li>
				<li><a id="aths" href="#" tabindex="-1"><i class="fas fa-plus fa-fw"></i>Add to Home Screen</a></li>
				<li><a href="/whatsnew" tabindex="-1"><i class="fas fa-star fa-fw"></i>What's New</a></li>
				<li><a href="/about" tabindex="-1"><i class="fas fa-info-circle fa-fw"></i>About Lottery Post</a></li>
			</ul>
		</div>
	</div>
</div>
<footer>
	<p><a href="/about">About&nbsp;Us</a>&nbsp;&nbsp;|&nbsp; <a href="/privacy">Privacy</a>&nbsp;&nbsp;|&nbsp; <a href="/dmca">DMCA</a>&nbsp;&nbsp;|&nbsp; <a href="/help">Help</a>&nbsp;&nbsp;|&nbsp; <a href="/contact">Contact&nbsp;Us</a>&nbsp;&nbsp;|&nbsp; <a href="/sitemap">Site&nbsp;Map</a></p>
	<p>This page was generated in 0.0216 seconds.<br />Copyright &copy; 1999-2022 <a href="https://www.speednet.biz/">Speednet Group</a>.&nbsp; All&nbsp;rights&nbsp;reserved.</p>
</footer>
<div id="audhead" class="aud auhead"></div>
<div id="anchorPanel"><div id="aumanchor" class="aum auhoriz"></div></div>

<script>!function(n,t,i){var r=typeof n.Promise!==i||!n.Promise.prototype["finally"]||!n.Promise.allSettled,u=typeof n.fetch!==i,f=typeof n.ResizeObserver===t;if(r&&document.write('<script src="/js/promise.min.js"><\/script>'),u){document.write('<script src="/js/fetch.min.js"><\/script>');Array.prototype.includes||(Array.prototype.includes=function(n){return!!~this.indexOf(n)});try{n.WeakSet=WeakSet}catch(e){!function(t){function u(n){i.set(this,new t);n&&n.forEach(this.add,this)}var i=new t,r=u.prototype;r.add=function(n){return i.get(this).set(n,1),this};r.delete=function(n){return i.get(this).delete(n)};r.has=function(n){return i.get(this).has(n)};n.WeakSet=u}(WeakMap)}}f&&document.write('<script src="/js/ResizeObserver.min.js"><\/script>')}(window,"undefined","function")</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script async src="https://c.amazon-adsystem.com/aax2/apstag.js"></script><script async src="/js/pb.js?v=PNp9UUeXWAzwOAMiAf-TTsmtCSrln3FM8GRSGPIIQF0"></script><script src="/js/site.min.js?v=ayIB1afp57J0USunKSTwJ7sjPLXwjXSK28QKw7Fqals"></script>
		<script src="/lib/clipboard.min.js?v=4XodgW4TwIJuDtf-v6vDJ39FVxI0veC_kSCCmnFp7ck"></script>
		<script src="/js/thread.min.js?v=R_grEmrfXPsyOHXQiV1t8-det7HxY-MmMXfKvgeVy1c"></script>
		<script src="/js/infinitescroll.min.js?v=g4KkybtZMWvuN3xKQe8v02VIa1mwX2l8TuJ8QyLnqas"></script>
		<script src="/lib/fslightbox/fslightbox.js?v=DNQLiUUcaJjo7_hyXbSv5VO7dcoFIiJaL7mlcnxFpDM"></script>
	<script src="_framework/blazor.server.js"></script>
	<script>window.addEventListener("beforeunload", function () { Blazor.defaultReconnectionHandler._reconnectionDisplay = {}; });</script>

	<script>LP.setClipboardCopyElement(".storylink",null,true,"Link copied!");</script>
	<script type="application/ld+json">{"@context":"https://schema.org/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.lotterypost.com/news/342559"},"description":"Two winners in a partnership have come forward to claim the eye-watering $1.34 billion Mega Millions jackpot that was drawn in July 2022.","commentCount":"3","datePublished":"2022-09-21T03:58:25-04:00","dateModified":"2022-09-21T03:58:25-04:00","headline":"Two Illinois lottery winners in a partnership claim $1.34 billion Mega Millions jackpot","keywords":"lottery,1,15,41,55,206,217","image":["/images/newsicon_megamillions.jpg"],"thumbnailUrl":"/images/newsicon_megamillions.jpg","dateline":"CHICAGO, Ill.","author":{"@type":"Person","name":"Kate Northrop"},"isAccessibleForFree":true,"publisher":{"@type":"Organization","name":"Lottery Post","logo":{"@type":"ImageObject","url":"https://www.lotterypost.com/images/lp_icon_310.png"}}}</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=G-GBR57VB2CX"></script>
<script>function gtag(){dataLayer.push(arguments)}window.dataLayer=window.dataLayer||[];gtag("js",new Date);gtag("config","G-GBR57VB2CX");</script>
<script async src="https://secure.quantserve.com/quant.js"></script>
<script>window._qevents=window._qevents||[];window._qevents.push({qacct:"p-7alUP9zu-TfBA"})</script>
<noscript><div style="display:none"><img src="//pixel.quantserve.com/pixel/p-7alUP9zu-TfBA.gif" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="application/ld+json">
	{"@context":"https://schema.org/","@id":"https://www.lotterypost.com/#organization","@type":"Organization","name":"Lottery Post","url":"https://www.lotterypost.com/","logo":{"@type":"ImageObject","url":"https://www.lotterypost.com/images/lotterypost.svg","width":1200,"height":504},"founder":{"@type":"Person","name":"Todd Northrop"},"description":"Lottery results, forums, news, United States lotteries, jackpots, predictions, and information for the serious lottery player.","sameAs":["https://www.youtube.com/LotteryPost","https://www.facebook.com/LotteryPost","https://twitter.com/LotteryPost","https://www.instagram.com/LotteryPost/"]}
</script>
<script type="application/ld+json">
	{"@context":"https://schema.org","@id":"https://www.lotterypost.com/#website","@type":"WebSite","url":"https://www.lotterypost.com/","name":"Lottery Post","potentialAction":{"@type":"SearchAction","target":"https://www.lotterypost.com/search?q={search_term_string}&src=mc_google","query-input":"required name=search_term_string"}}
</script>
</body>
</html>
